post #21 of 21
Hi I'm new in here.. I'm not sure though if it could be the same issue with you guys as I'm experiencing this problem mostly when there's a video playback running such as streaming (youtube). Never check first if it will occur also while playing Diablo 3.

http://i4.photobucket.com/albums/y114/twyxted/OriginPC%20Issue/IMG_1112_zps4f408e59.jpg
http://i4.photobucket.com/albums/y114/twyxted/OriginPC%20Issue/IMG_1111_zpsda66750f.jpg
http://i4.photobucket.com/albums/y114/twyxted/OriginPC%20Issue/IMG_1110_zps16991ca1.jpg
http://i4.photobucket.com/albums/y114/twyxted/OriginPC%20Issue/IMG_1109_zpscb0b8e8b.jpg
http://i4.photobucket.com/albums/y114/twyxted/OriginPC%20Issue/IMG_1102_zpse98c5646.jpg
http://i4.photobucket.com/albums/y114/twyxted/OriginPC%20Issue/IMG_1101_zps2a208cb7.jpg
http://i4.photobucket.com/albums/y114/twyxted/OriginPC%20Issue/IMG_1100_zpsbd3edf5f.jpg

And this is my hardware:
http://i4.photobucket.com/albums/y114/twyxted/OriginPC%20Issue/IMG_1107_zps6d5d8aac.jpg
http://i4.photobucket.com/albums/y114/twyxted/OriginPC%20Issue/IMG_1108_zps4c60dbee.jpg

It just arrived last 02-22-2013, and on the first day already experienced those pixelating things which eventually causes for my AMD Driver to stopped working.

Spoke already to the support of Origin PC and their assumption is a defective video card. Although if I'm just browsing over then net without any video streaming, it works fine. Even while playing an online browser game (hack and slash), I'm not experiencing the same problems.

Any thoughts? Because international shipping will be shouldered by me and kinda thinking if it was really a defective video card.

Here's the build:
AMD FX 8350 4.01 GHz
16.0 GB Kingston Hyper-X Memory
PowerColor PCS+ Radeon HD 7970 3GB VORTEX II
Asus Crosshair V Formula
Aver Media Live Gamer HD
Coolermaster Silent Pro Hybrid 1300W
Coolermaster Seidon 120m LCS