Overclock.net › Forums › Components › Power Supplies › New build won't turn on (OCZ ModXStream-Pro 700W)
New Posts  All Forums:Forum Nav:

New build won't turn on (OCZ ModXStream-Pro 700W)

post #1 of 5
Thread Starter 
Been contemplating joining these forums for a bit now and sadly a problem I can't seem to solve is what puts me over the edge to make an account. Will try to contribute in the future.

Anyway, my problem is I just assembled my PC and no matter what I do it won't turn on. I'm not sure if it's the PSU, the case itself or something else. Hopefully you guys can help me out.

The PSU is an OCZ ModXStream-Pro 700W. I've tripled checked the connections and it "should" be turning the computer on. The lights on the motherboard turn on, but that's it. I'm not too sure where I stand, whether or not I have just a faulty power supply or if it's something else. I'd like to find the cause before I try exchanging/returning anything. Any help at all is appreciated. Not sure what else to put down so if I missed something, please let me know.


Motherboard: http://www.newegg.com/Product/Product.aspx?Item=N82E16813131790

Case: http://www.newegg.com/Product/Product.aspx?Item=N82E16811146073


Thanks for your time.
post #2 of 5
Are you using an ivy bridge chip?
     
CPUMotherboardGraphicsRAM
Intel Core i7-4870HQ @ 2.5 GHz (Turbo @ 3.7 GHz) Apple Logic Board Nvidia GeForce GT 750M 2GB 16 GB 1600 MHz DDR3 
Hard DriveOSMonitorKeyboard
APPLE SSD SM0512F 500GB macOS Sierra 15" Retina Display (2880 x 1800) Full-size backlit keyboard with 78 (U.S.) keys 
PowerCaseMouseAudio
85W Magsafe 2 Precision Aluminum Unibody Multi-Touch Trackpad Focusrite Scarlett 2i4 2nd Gen 
CPUGraphicsRAMHard Drive
Intel Core i5-3317U @ 1.7GHz (Turbo @ 2.6 GHz) Intel HD Graphics 4000 4 GB 1600 MHz DDR3L SDRAM APPLE SSD TS128E 
OSMonitorKeyboardPower
macOS Sierra 11.6" LCD/LED Backlit IPS Display (1366 x 768) Full-size backlit keyboard with 78 (U.S.) keys 85W Magsafe 2 
CaseMouse
Precision Aluminum Unibody Multi-Touch Trackpad 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel Core i7-4870HQ @ 2.5 GHz (Turbo @ 3.7 GHz) Apple Logic Board Nvidia GeForce GT 750M 2GB 16 GB 1600 MHz DDR3 
Hard DriveOSMonitorKeyboard
APPLE SSD SM0512F 500GB macOS Sierra 15" Retina Display (2880 x 1800) Full-size backlit keyboard with 78 (U.S.) keys 
PowerCaseMouseAudio
85W Magsafe 2 Precision Aluminum Unibody Multi-Touch Trackpad Focusrite Scarlett 2i4 2nd Gen 
CPUGraphicsRAMHard Drive
Intel Core i5-3317U @ 1.7GHz (Turbo @ 2.6 GHz) Intel HD Graphics 4000 4 GB 1600 MHz DDR3L SDRAM APPLE SSD TS128E 
OSMonitorKeyboardPower
macOS Sierra 11.6" LCD/LED Backlit IPS Display (1366 x 768) Full-size backlit keyboard with 78 (U.S.) keys 85W Magsafe 2 
CaseMouse
Precision Aluminum Unibody Multi-Touch Trackpad 
  hide details  
Reply
post #3 of 5
Thread Starter 
Neg, Sandy bridge
post #4 of 5
Did you install motherboard stand offs?

Also, try resetting cmos and try posting with only 1 stick of RAM. Always a possibility a stick of ram is bad. I've had it happen before.
Edited by EpicPie - 2/7/13 at 4:14am
     
CPUMotherboardGraphicsRAM
Intel Core i7-4870HQ @ 2.5 GHz (Turbo @ 3.7 GHz) Apple Logic Board Nvidia GeForce GT 750M 2GB 16 GB 1600 MHz DDR3 
Hard DriveOSMonitorKeyboard
APPLE SSD SM0512F 500GB macOS Sierra 15" Retina Display (2880 x 1800) Full-size backlit keyboard with 78 (U.S.) keys 
PowerCaseMouseAudio
85W Magsafe 2 Precision Aluminum Unibody Multi-Touch Trackpad Focusrite Scarlett 2i4 2nd Gen 
CPUGraphicsRAMHard Drive
Intel Core i5-3317U @ 1.7GHz (Turbo @ 2.6 GHz) Intel HD Graphics 4000 4 GB 1600 MHz DDR3L SDRAM APPLE SSD TS128E 
OSMonitorKeyboardPower
macOS Sierra 11.6" LCD/LED Backlit IPS Display (1366 x 768) Full-size backlit keyboard with 78 (U.S.) keys 85W Magsafe 2 
CaseMouse
Precision Aluminum Unibody Multi-Touch Trackpad 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel Core i7-4870HQ @ 2.5 GHz (Turbo @ 3.7 GHz) Apple Logic Board Nvidia GeForce GT 750M 2GB 16 GB 1600 MHz DDR3 
Hard DriveOSMonitorKeyboard
APPLE SSD SM0512F 500GB macOS Sierra 15" Retina Display (2880 x 1800) Full-size backlit keyboard with 78 (U.S.) keys 
PowerCaseMouseAudio
85W Magsafe 2 Precision Aluminum Unibody Multi-Touch Trackpad Focusrite Scarlett 2i4 2nd Gen 
CPUGraphicsRAMHard Drive
Intel Core i5-3317U @ 1.7GHz (Turbo @ 2.6 GHz) Intel HD Graphics 4000 4 GB 1600 MHz DDR3L SDRAM APPLE SSD TS128E 
OSMonitorKeyboardPower
macOS Sierra 11.6" LCD/LED Backlit IPS Display (1366 x 768) Full-size backlit keyboard with 78 (U.S.) keys 85W Magsafe 2 
CaseMouse
Precision Aluminum Unibody Multi-Touch Trackpad 
  hide details  
Reply
post #5 of 5
Thread Starter 
Standoffs are on, tried resetting and have tried the RAM, still nothing.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › New build won't turn on (OCZ ModXStream-Pro 700W)