Overclock.net › Forums › Components › Hard Drives & Storage › RAID Controllers and Software ›  USB 3.0 RAID Enclosure Corrupted Files?
New Posts  All Forums:Forum Nav:

USB 3.0 RAID Enclosure Corrupted Files?

post #1 of 5
Thread Starter 
I just got this Sans Digital "TowerRaid" TR5UT+(B). It's connected by USB 3.0 to my computer at work. I've got 5 x 2TB WD Blacks in RAID5 in it. Small files do fine, but I mainly store images in the RAID, that are 15-30GB usually, and they are all corrupted when I bring them back down. Has anyone had problems with these kind of devices before? My first thought is to try the eSATA connection and see how it does with that. I'm also wondering if it has something to do with the fact I initialized them as GPT so I could just have one giant volume, instead of MBR. Don't know?
Low Tide
(12 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.7GHz Asus P8Z77-V Pro EVGA GTX 670 FTW 8GB G. Skill 2133MHz 
Hard DriveCoolingOSMonitor
Samsung 850 Pro 256GB Prolimatech Megahalems Rev. C Windows X Samsung T240HD 
KeyboardPowerCaseAudio
Ducky DK9008G2 Red Corsair TX850W V1 Corsair Carbide 300R X-Fi XtremeGamer 
  hide details  
Reply
Low Tide
(12 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.7GHz Asus P8Z77-V Pro EVGA GTX 670 FTW 8GB G. Skill 2133MHz 
Hard DriveCoolingOSMonitor
Samsung 850 Pro 256GB Prolimatech Megahalems Rev. C Windows X Samsung T240HD 
KeyboardPowerCaseAudio
Ducky DK9008G2 Red Corsair TX850W V1 Corsair Carbide 300R X-Fi XtremeGamer 
  hide details  
Reply
post #2 of 5
The whole point of RAID is to prevent data loss. Is there some third party software tool provided that will allow you to check the integrity of your RAID array?

The datasheet says "True hardware RAID design within the enclosure. No driver and additional RAID controller needed." and "Over 2TB per volume via eSATA and USB on OS that supports 2TB or above.".....that should imply that GPT will work just fine.

I would not rule out the possibility of the problem being the USB 3.0 conneciton. Are you using a USB 3.0 "expansion header" on your motherboard, or plugging directly into the back of the motherboard itself? I would try plugging directly into the back of the motherboard, that will rule out noise/interference/wiring issues. Also try a different USB 3.0 cable. Another thought, wiggle both USB ports and see if it feels like a solder joint might be loose. I've been burned by USB connections with broken solder joints,...where they work most of the time and corrupt data the other half of the time.

Did you motherboard come with any software designed to accelerate the USB 3.0? Alot of motherboards these days come with special drivers that will allow the USB ports to go faster (It's called "Turbo mode" on my particular motherboard). These drivers are notorious for causing weird problems.

Personally, I would go with E-sata. USB 3.0 (in my humble opinion) has always been a headache every time I try to do something. E-Sata is designed for hard drive connections. Try that.
Edited by crimsontears809739 - 2/8/13 at 10:04am
Deus Ex Machina
(19 items)
 
   
CPUMotherboardGraphicsRAM
i5 580M Dell 0R1203 NVIDIA Quadro FX 2800M Samsung 4Gb 
Hard DriveHard DriveOptical DriveOS
TOSHIBA MK3256GSYF  TOSHIBA MK3256GSYF  DVD-Rom HL-DT-ST DVD+-RW GU40N Windows 7 Professional 
Audio
Dell Computer 5 Series/3400 Series Chipset Fami... 
CPUMotherboardGraphicsGraphics
Athlon 64 X2 6400+  Asus M2N-E Nforce 500 SLi 8800GT  9800 GT 
RAMHard DriveOptical DriveOS
OCZ ReaperX WD LG lightscribe Multilayer DVD burner Windows 7 
PowerCase
Antec 500W Smartpower 2.0 Aspire X-Navigator 
  hide details  
Reply
Deus Ex Machina
(19 items)
 
   
CPUMotherboardGraphicsRAM
i5 580M Dell 0R1203 NVIDIA Quadro FX 2800M Samsung 4Gb 
Hard DriveHard DriveOptical DriveOS
TOSHIBA MK3256GSYF  TOSHIBA MK3256GSYF  DVD-Rom HL-DT-ST DVD+-RW GU40N Windows 7 Professional 
Audio
Dell Computer 5 Series/3400 Series Chipset Fami... 
CPUMotherboardGraphicsGraphics
Athlon 64 X2 6400+  Asus M2N-E Nforce 500 SLi 8800GT  9800 GT 
RAMHard DriveOptical DriveOS
OCZ ReaperX WD LG lightscribe Multilayer DVD burner Windows 7 
PowerCase
Antec 500W Smartpower 2.0 Aspire X-Navigator 
  hide details  
Reply
post #3 of 5
Thread Starter 
My workstation uses a USB 3.0 PCI-E add on card, so I wish I could try that. The enclosure came with that USB Boost software, but I didn't know it was that when I installed it. I thought I was just getting the users manual and next thing I know I've got that crap on my computer. It looks like sketchy software anyways, so I'm going to get rid of that first. It also came with an eSATA card, but it's PCI-E also and my computer only has one PCI-E slot. I'll just order an eSATA PCI card and try it. Thanks for reply.
Low Tide
(12 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.7GHz Asus P8Z77-V Pro EVGA GTX 670 FTW 8GB G. Skill 2133MHz 
Hard DriveCoolingOSMonitor
Samsung 850 Pro 256GB Prolimatech Megahalems Rev. C Windows X Samsung T240HD 
KeyboardPowerCaseAudio
Ducky DK9008G2 Red Corsair TX850W V1 Corsair Carbide 300R X-Fi XtremeGamer 
  hide details  
Reply
Low Tide
(12 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.7GHz Asus P8Z77-V Pro EVGA GTX 670 FTW 8GB G. Skill 2133MHz 
Hard DriveCoolingOSMonitor
Samsung 850 Pro 256GB Prolimatech Megahalems Rev. C Windows X Samsung T240HD 
KeyboardPowerCaseAudio
Ducky DK9008G2 Red Corsair TX850W V1 Corsair Carbide 300R X-Fi XtremeGamer 
  hide details  
Reply
post #4 of 5
Thread Starter 
Added a PCI eSATA card today. Reset and reformatted the RAID5 enclosure. Put some images up to the RAID5 and brought them back down perfectly. No corruption. Amazing that the USB 3.0 connection is so unreliable compared to the eSATA.
Low Tide
(12 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.7GHz Asus P8Z77-V Pro EVGA GTX 670 FTW 8GB G. Skill 2133MHz 
Hard DriveCoolingOSMonitor
Samsung 850 Pro 256GB Prolimatech Megahalems Rev. C Windows X Samsung T240HD 
KeyboardPowerCaseAudio
Ducky DK9008G2 Red Corsair TX850W V1 Corsair Carbide 300R X-Fi XtremeGamer 
  hide details  
Reply
Low Tide
(12 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.7GHz Asus P8Z77-V Pro EVGA GTX 670 FTW 8GB G. Skill 2133MHz 
Hard DriveCoolingOSMonitor
Samsung 850 Pro 256GB Prolimatech Megahalems Rev. C Windows X Samsung T240HD 
KeyboardPowerCaseAudio
Ducky DK9008G2 Red Corsair TX850W V1 Corsair Carbide 300R X-Fi XtremeGamer 
  hide details  
Reply
post #5 of 5
USB 3.0 has only caused me problems, but i thought i was the only one. X-D Glad to see you have it fixed.
Deus Ex Machina
(19 items)
 
   
CPUMotherboardGraphicsRAM
i5 580M Dell 0R1203 NVIDIA Quadro FX 2800M Samsung 4Gb 
Hard DriveHard DriveOptical DriveOS
TOSHIBA MK3256GSYF  TOSHIBA MK3256GSYF  DVD-Rom HL-DT-ST DVD+-RW GU40N Windows 7 Professional 
Audio
Dell Computer 5 Series/3400 Series Chipset Fami... 
CPUMotherboardGraphicsGraphics
Athlon 64 X2 6400+  Asus M2N-E Nforce 500 SLi 8800GT  9800 GT 
RAMHard DriveOptical DriveOS
OCZ ReaperX WD LG lightscribe Multilayer DVD burner Windows 7 
PowerCase
Antec 500W Smartpower 2.0 Aspire X-Navigator 
  hide details  
Reply
Deus Ex Machina
(19 items)
 
   
CPUMotherboardGraphicsRAM
i5 580M Dell 0R1203 NVIDIA Quadro FX 2800M Samsung 4Gb 
Hard DriveHard DriveOptical DriveOS
TOSHIBA MK3256GSYF  TOSHIBA MK3256GSYF  DVD-Rom HL-DT-ST DVD+-RW GU40N Windows 7 Professional 
Audio
Dell Computer 5 Series/3400 Series Chipset Fami... 
CPUMotherboardGraphicsGraphics
Athlon 64 X2 6400+  Asus M2N-E Nforce 500 SLi 8800GT  9800 GT 
RAMHard DriveOptical DriveOS
OCZ ReaperX WD LG lightscribe Multilayer DVD burner Windows 7 
PowerCase
Antec 500W Smartpower 2.0 Aspire X-Navigator 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: RAID Controllers and Software
Overclock.net › Forums › Components › Hard Drives & Storage › RAID Controllers and Software ›  USB 3.0 RAID Enclosure Corrupted Files?