Overclock.net › Forums › Graphics Cards › AMD/ATI › Sapphire RMA
New Posts  All Forums:Forum Nav:

Sapphire RMA - Page 2

post #11 of 17
If your GPU ends up being the culprit, I just got my card back from Sapphire and it took about 2 weeks from the time I sent it in to getting a new, upgraded replacement. I recorded a short video documenting the problem and they replaced my 7870 with the OC version. Very painless and free with invoice as other have mentioned, besides shipping to them of course.
n O D E .
(16 items)
 
  
CPUMotherboardGraphicsRAM
4690k ASRock Z97E-ITX/ac Gigabyte WindForce GTX770 Samsung 30nm  
Hard DriveHard DriveOptical DriveCooling
OCZ Arc 100 WD Blue pshhhhhhhhh c'mon son Cryorig H7 
OSMonitorKeyboardPower
8.1 Pro Acer H236L bid Logitech K120 CoolerMaster V650s 
CaseMouseAudioAudio
Fractal Design Node 304 Logitech MX518 FiiO E10K Olympus 2 Sennheiser HD 558 
  hide details  
Reply
n O D E .
(16 items)
 
  
CPUMotherboardGraphicsRAM
4690k ASRock Z97E-ITX/ac Gigabyte WindForce GTX770 Samsung 30nm  
Hard DriveHard DriveOptical DriveCooling
OCZ Arc 100 WD Blue pshhhhhhhhh c'mon son Cryorig H7 
OSMonitorKeyboardPower
8.1 Pro Acer H236L bid Logitech K120 CoolerMaster V650s 
CaseMouseAudioAudio
Fractal Design Node 304 Logitech MX518 FiiO E10K Olympus 2 Sennheiser HD 558 
  hide details  
Reply
post #12 of 17
Quote:
Originally Posted by Nick7269 View Post

Yeah like Xoriam has stated, you should try a few things before blaming the gpu. Try resetting the cmos and booting with only one stick of ram. If that does not work, try the other stick of ram.

this exactly, sometimes ram sticks perfer diffrent slots.

i almost had a heartattack the first time i ran into this situation.

(anyways i hope for you its just that, but anyways sapphire is usually really cool about RMA and sometimes they will even give you a better card)
Ryzen
(9 items)
 
X58 Xeon ROG
(13 items)
 
IVY
(13 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700x MSI B350 Tomahawk EVGA GTX 980 TI Corsair Vengeance LPX 
Hard DriveCoolingOSPower
Crucial MX100 Corsair H80i Windows 10 64bit EVGA Supernova 850 G2 
Audio
Boss gt-001 
CPUMotherboardGraphicsRAM
Intel Xeon x5660 @ 4,6ghz (max 5,02ghz) Asus Rampage III EVGA GTX 970 Corsair Dominator 12gb 
Hard DriveCoolingOSMonitor
Kingston SSD Corsair H80i Windows 8.1 64bit Toshiba 40" 
KeyboardPowerMouse
Logitech G106 Corsair CX650 Logitech G600 
CPUMotherboardGraphicsRAM
I5 3570k Gigabyte G1 Sniper 3 EVGA GTX 980 TI SC+ kingston hyperx beast 2400 mhz 8GB 
Hard DriveCoolingOSMonitor
Crucial MX100 Corsair H80i Windows 8.1 64bit Phillips BDM4065UC 40" 4k MONITOR 
KeyboardPowerCaseMouse
Logitech G11 EVGA Supernova G2 850watt Haf XB EVO Razer Naga 
Audio
M-audio Mtrack Mk II 
  hide details  
Reply
Ryzen
(9 items)
 
X58 Xeon ROG
(13 items)
 
IVY
(13 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700x MSI B350 Tomahawk EVGA GTX 980 TI Corsair Vengeance LPX 
Hard DriveCoolingOSPower
Crucial MX100 Corsair H80i Windows 10 64bit EVGA Supernova 850 G2 
Audio
Boss gt-001 
CPUMotherboardGraphicsRAM
Intel Xeon x5660 @ 4,6ghz (max 5,02ghz) Asus Rampage III EVGA GTX 970 Corsair Dominator 12gb 
Hard DriveCoolingOSMonitor
Kingston SSD Corsair H80i Windows 8.1 64bit Toshiba 40" 
KeyboardPowerMouse
Logitech G106 Corsair CX650 Logitech G600 
CPUMotherboardGraphicsRAM
I5 3570k Gigabyte G1 Sniper 3 EVGA GTX 980 TI SC+ kingston hyperx beast 2400 mhz 8GB 
Hard DriveCoolingOSMonitor
Crucial MX100 Corsair H80i Windows 8.1 64bit Phillips BDM4065UC 40" 4k MONITOR 
KeyboardPowerCaseMouse
Logitech G11 EVGA Supernova G2 850watt Haf XB EVO Razer Naga 
Audio
M-audio Mtrack Mk II 
  hide details  
Reply
post #13 of 17
Thread Starter 
Well, lo and behold, reseating ram the ram solved my problem! I'm happy with the outcome and now everything runs flawless. Thank you Xoriam for suggesting this. I even went and tested the ram sticks independently, in different slots too just to make sure they weren't bad and nothing. They work!
System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570k MSI z77-GD65 EVGA 980 ACX 2.0 Gkill Ripjaw X 16 gb 
Hard DriveOptical DriveCoolingOS
Mushkin 64GB SSD Generic DVD Drive h100i Windows 8 64-bit 
MonitorKeyboardPowerCase
QNIX QX2710LED CORSAIR K70 Corsair gs600 Corsair 540 
Mouse
Logitech G9 
  hide details  
Reply
System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570k MSI z77-GD65 EVGA 980 ACX 2.0 Gkill Ripjaw X 16 gb 
Hard DriveOptical DriveCoolingOS
Mushkin 64GB SSD Generic DVD Drive h100i Windows 8 64-bit 
MonitorKeyboardPowerCase
QNIX QX2710LED CORSAIR K70 Corsair gs600 Corsair 540 
Mouse
Logitech G9 
  hide details  
Reply
post #14 of 17
Quote:
Originally Posted by Jaycee17 View Post

Well, lo and behold, reseating ram the ram solved my problem! I'm happy with the outcome and now everything runs flawless. Thank you Xoriam for suggesting this. I even went and tested the ram sticks independently, in different slots too just to make sure they weren't bad and nothing. They work!

You should test your RAM just to be on the safe side with memtest. Test each stick individually and then together.
R116
(23 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 5820k @ 4.6GHz / 4.3GHz Asus X99 Deluxe Nvidia GTX 980Ti 4 X 4GB G.Skill Ripjaws 4  
Hard DriveHard DriveCoolingCooling
Seagate Barracuda 2TB Samsung 850 Evo 250GB EK Supremacy Evo  EK Mosfet X99 
CoolingCoolingCoolingCooling
EK-FC Titan X Alphacool NexXxos XT45 360 Alphacool NexXxos UT60 240 Alphacool VPP655T + EK D5 X-RES 200 CSQ 
CoolingCoolingOSMonitor
Corsair SP120 x5 Corsair AF140 x1 Windows 10 Pro x64 Benq XL2730Z @ 144Hz 
KeyboardPowerCaseMouse
CM Storm Quickfire TK EVGA 850W Supernova G2 Corsair 750D Zowie EC2-A 
Mouse PadAudioOther
OCUK Mega Mat / Steelseries QCK+ CREATIVE Soundblaster Z mCubed T-Balancer 
  hide details  
Reply
R116
(23 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 5820k @ 4.6GHz / 4.3GHz Asus X99 Deluxe Nvidia GTX 980Ti 4 X 4GB G.Skill Ripjaws 4  
Hard DriveHard DriveCoolingCooling
Seagate Barracuda 2TB Samsung 850 Evo 250GB EK Supremacy Evo  EK Mosfet X99 
CoolingCoolingCoolingCooling
EK-FC Titan X Alphacool NexXxos XT45 360 Alphacool NexXxos UT60 240 Alphacool VPP655T + EK D5 X-RES 200 CSQ 
CoolingCoolingOSMonitor
Corsair SP120 x5 Corsair AF140 x1 Windows 10 Pro x64 Benq XL2730Z @ 144Hz 
KeyboardPowerCaseMouse
CM Storm Quickfire TK EVGA 850W Supernova G2 Corsair 750D Zowie EC2-A 
Mouse PadAudioOther
OCUK Mega Mat / Steelseries QCK+ CREATIVE Soundblaster Z mCubed T-Balancer 
  hide details  
Reply
post #15 of 17
Quote:
Originally Posted by Jaycee17 View Post

Well, lo and behold, reseating ram the ram solved my problem! I'm happy with the outcome and now everything runs flawless. Thank you Xoriam for suggesting this. I even went and tested the ram sticks independently, in different slots too just to make sure they weren't bad and nothing. They work!

thumb.gif I'm glad I was able to help you solve your problem without going through any un-neccessary steps!
Ryzen
(9 items)
 
X58 Xeon ROG
(13 items)
 
IVY
(13 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700x MSI B350 Tomahawk EVGA GTX 980 TI Corsair Vengeance LPX 
Hard DriveCoolingOSPower
Crucial MX100 Corsair H80i Windows 10 64bit EVGA Supernova 850 G2 
Audio
Boss gt-001 
CPUMotherboardGraphicsRAM
Intel Xeon x5660 @ 4,6ghz (max 5,02ghz) Asus Rampage III EVGA GTX 970 Corsair Dominator 12gb 
Hard DriveCoolingOSMonitor
Kingston SSD Corsair H80i Windows 8.1 64bit Toshiba 40" 
KeyboardPowerMouse
Logitech G106 Corsair CX650 Logitech G600 
CPUMotherboardGraphicsRAM
I5 3570k Gigabyte G1 Sniper 3 EVGA GTX 980 TI SC+ kingston hyperx beast 2400 mhz 8GB 
Hard DriveCoolingOSMonitor
Crucial MX100 Corsair H80i Windows 8.1 64bit Phillips BDM4065UC 40" 4k MONITOR 
KeyboardPowerCaseMouse
Logitech G11 EVGA Supernova G2 850watt Haf XB EVO Razer Naga 
Audio
M-audio Mtrack Mk II 
  hide details  
Reply
Ryzen
(9 items)
 
X58 Xeon ROG
(13 items)
 
IVY
(13 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700x MSI B350 Tomahawk EVGA GTX 980 TI Corsair Vengeance LPX 
Hard DriveCoolingOSPower
Crucial MX100 Corsair H80i Windows 10 64bit EVGA Supernova 850 G2 
Audio
Boss gt-001 
CPUMotherboardGraphicsRAM
Intel Xeon x5660 @ 4,6ghz (max 5,02ghz) Asus Rampage III EVGA GTX 970 Corsair Dominator 12gb 
Hard DriveCoolingOSMonitor
Kingston SSD Corsair H80i Windows 8.1 64bit Toshiba 40" 
KeyboardPowerMouse
Logitech G106 Corsair CX650 Logitech G600 
CPUMotherboardGraphicsRAM
I5 3570k Gigabyte G1 Sniper 3 EVGA GTX 980 TI SC+ kingston hyperx beast 2400 mhz 8GB 
Hard DriveCoolingOSMonitor
Crucial MX100 Corsair H80i Windows 8.1 64bit Phillips BDM4065UC 40" 4k MONITOR 
KeyboardPowerCaseMouse
Logitech G11 EVGA Supernova G2 850watt Haf XB EVO Razer Naga 
Audio
M-audio Mtrack Mk II 
  hide details  
Reply
post #16 of 17
Nice!
I love it when a plan comes together! (I stole that line )
     
CPUMotherboardGraphicsRAM
Intel i7 3770k @ 4.5ghz GIGABYTE GA-Z77X-UD5H Zotac 1080 gtx Samsung  
Hard DriveOSMonitorPower
Samsung 500gb SSD M$ 10 Asus ROG PG348Q Corsair 
Case
Case Labs 
CPUMotherboardGraphicsRAM
QX9650 EP45-UD3P Gygabyte XFX 5770 4x1gb Gskill  
Hard DriveOSMonitorKeyboard
Raptor Raid 0 Vista 64bit Samsung 2494 G15 v1 
PowerCaseMouse
Corsair Case Labs MX518 
CPUMotherboardRAMHard Drive
Intel i5 3570k Gigabyte H77N-Wifi GSkill 2x2gb Crucial M4 256gb 
Hard DriveOptical DriveCoolingOS
4x2tb raid Blu-ray Corsair H90 W7 Home Premium 
CaseMouseAudioAudio
Case Labs S3 Mercury Logitech MX Performance Audio Engine 5 Dayton Sub-120 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel i7 3770k @ 4.5ghz GIGABYTE GA-Z77X-UD5H Zotac 1080 gtx Samsung  
Hard DriveOSMonitorPower
Samsung 500gb SSD M$ 10 Asus ROG PG348Q Corsair 
Case
Case Labs 
CPUMotherboardGraphicsRAM
QX9650 EP45-UD3P Gygabyte XFX 5770 4x1gb Gskill  
Hard DriveOSMonitorKeyboard
Raptor Raid 0 Vista 64bit Samsung 2494 G15 v1 
PowerCaseMouse
Corsair Case Labs MX518 
CPUMotherboardRAMHard Drive
Intel i5 3570k Gigabyte H77N-Wifi GSkill 2x2gb Crucial M4 256gb 
Hard DriveOptical DriveCoolingOS
4x2tb raid Blu-ray Corsair H90 W7 Home Premium 
CaseMouseAudioAudio
Case Labs S3 Mercury Logitech MX Performance Audio Engine 5 Dayton Sub-120 
  hide details  
Reply
post #17 of 17
Last week i overheated my HD7870 OC GPU VRM with more than 100°c and since then i have no video input. I just bought Artic Accelero III, and it seems this GPU cooler does a ****ty job at cooling all components...

I checked the pcb, no exploded things... i mounted the original cooler back on and i've send it to my retailer for RMA with just "no video input" as problem....

I also had a hard time removing thermal paste, glue from the Artic set and i'm hoping and wondering now if they will just give me a new card or refuse me? If you look a the card closely you cannot see any user errors
Edited by misterD - 3/5/13 at 4:29pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Sapphire RMA