Overclock.net › Forums › Graphics Cards › AMD/ATI › New HD 7870 causing computer to freeze on boot.
New Posts  All Forums:Forum Nav:

New HD 7870 causing computer to freeze on boot.

post #1 of 4
Thread Starter 
So I decided I needed a new graphics card since my old HD5850 just doesn't give me enough power for games. I decided to go with a gigabyte HD 7870 since it seemed like a good card. The problem is after swapping it out my computer freezes on boot. The first time I try booting it nothing happens the monitor and computer turn on but it just black screens and stays there. After powering it down and restarting it then it will display the first screen and freeze there (the screen that tells me what buttons to push to get bios or boot menu and such). At this screen it just freezes and I can't do anything, can't get into bios or boot menu. I sent it back for a replacement and the same thing happens with the new card so it has to be something else or very bad luck. If I put my old card in the computer starts fine. I placed the card in my roommates computer and his computer booted up fine so I'm not sure what the problem is.

windows 7-64bit OS
i7-860 cpu with a coolmaster evo cpu cooler
intel DP55wg motherboard
coolmax NW-650B powersupply
CORSAIR Vengeance 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory
Old graphics card is ATI HD 5850
New one that is not working gigabyte ATI HD 7870: -GV-R7870C-GD

My bios and drivers are up to date.
post #2 of 4
Have you reset your cmos yet/
post #3 of 4
Thread Starter 
I have not. I'm somewhat of a novice when it comes to BIOS stuff and I've never had a problem switching out a graphics card before. My concern here is if I reset the cmos could that make my current old graphics card that i am using not work anymore?
post #4 of 4
Thread Starter 
Did all the driver removing stuff and I have all the power connecters hooked up. Still no go. I even reset my CMOS. I'm truly stumped. My roommate has a Sapphire HD 7870 card and I took it and put it in and my comp booted up with no problem. So for some reason the Gigabyte version of the card won't work on my comp and I have no clue why. I'm just giving up and sending it back. Going to try getting a Sapphire one since that seemed to work. Thanks for your help.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › New HD 7870 causing computer to freeze on boot.