Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Linux won't boot when set CPU multi x21
New Posts  All Forums:Forum Nav:

Linux won't boot when set CPU multi x21 - Page 3

post #21 of 36
Quote:
Originally Posted by EduFurtado View Post

OK, if it's stability issue, couldn't I fix that by adding more volts, reducing the base clock to reduce the final CPU clock or both at once?

This is the part I don't understand, because if it's a stability issue, I could make it stable, right? But apparently I can't.


It's not that I don't respect you or your inputs, it's that this seems to be an exception and maybe you are thinking of a general case. I say this because I couldn't find any history of somebody relating a problem similar to this when I googled.

no. what CPU are you using? CPUs have walls, not just in pure clock speed but different walls on multis, and voltage, and stuff like that.

if this is your i5 750 there then you are pushing the cap. those things are hit or miss if they can get to 4GHz. sure, if you have huge high end motherboard, some phase cooling, and a big power supply you could probably pull 5GHz out of that thing, but with air and a limited number of volts your just asking for problems if you continue to push that overclock. windows might not tell you it's unstable, but linux clearly is. it's an issue of linux showing faults better then windows, not it being uncompatible with linux. this is quite clearly a stability issue.
post #22 of 36
Here's an end-all to the stability/compatibility argument. I run an i7 920 at Multi 21 (max multi is 20, 21 is used for turbo), and my system boots fine.
However, that isn't to say that I have a suggestion, can you boot the system using another multi, and provide the results of:
Code:
lsmod | grep -i cpufreq*

If it returns anything, then Kernel mode cpu frequency scaling is enabled, and it can cause issues running at a turbo multi. Blacklist the cpufreq kernel module (you lose power savings from dynamic scaling entirely) and see if it boots then. If not, it is 100% sure a stability issue. Linux is *very* picky about stability. Also, log of the output from the Kernel panic would help indicate whether it was a stability (MCEs, etc) or a compatibility (Not support, etc) or a kernel module throwing the exception (CPU freq failing to adjust the multiplier, because it is beyond the range presented by the BIOS)
Also, ignore the fact that SpeedStep is disabled. That has zero impact on CPUFreq. Why, I don't know - but I've seen CPUFreq modprobe and work fine, with SpeedStep disabled. IMO it shouldn't, but it can, probably because it doesn't use the same technology.
    
CPUMotherboardGraphicsRAM
Core i7 920 D0 4.2ghz HT (1.3625v) Asus R3E 2xGTX 460 (non SLi, no overclock) 6x2gb G.skill @ 6-8-6-24-1T 
Hard DriveOptical DriveOSMonitor
WD-VR 300GBx1, 2xWD 1tb,2x60gb Agility Some crappy combo burner... Arch x64 3xDell U2410f rev A02 
KeyboardPowerCaseMouse
X-Armor U9BL TT Toughpower 1200w (NTB more efficient) Mountain Mods Pinnacle 24 CYO Roccat Kone (R.I.P. A4Tech x7) 
Mouse Pad
Steelpad Experience I-1 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Core i7 920 D0 4.2ghz HT (1.3625v) Asus R3E 2xGTX 460 (non SLi, no overclock) 6x2gb G.skill @ 6-8-6-24-1T 
Hard DriveOptical DriveOSMonitor
WD-VR 300GBx1, 2xWD 1tb,2x60gb Agility Some crappy combo burner... Arch x64 3xDell U2410f rev A02 
KeyboardPowerCaseMouse
X-Armor U9BL TT Toughpower 1200w (NTB more efficient) Mountain Mods Pinnacle 24 CYO Roccat Kone (R.I.P. A4Tech x7) 
Mouse Pad
Steelpad Experience I-1 
  hide details  
Reply
post #23 of 36
I noticed you repp'd me, did you resolve your issue, or was it stability related? Just for community documentation, others Googling around could very well stumble upon this thread, and it would be nice to have the answer ;-)
Thanks
    
CPUMotherboardGraphicsRAM
Core i7 920 D0 4.2ghz HT (1.3625v) Asus R3E 2xGTX 460 (non SLi, no overclock) 6x2gb G.skill @ 6-8-6-24-1T 
Hard DriveOptical DriveOSMonitor
WD-VR 300GBx1, 2xWD 1tb,2x60gb Agility Some crappy combo burner... Arch x64 3xDell U2410f rev A02 
KeyboardPowerCaseMouse
X-Armor U9BL TT Toughpower 1200w (NTB more efficient) Mountain Mods Pinnacle 24 CYO Roccat Kone (R.I.P. A4Tech x7) 
Mouse Pad
Steelpad Experience I-1 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Core i7 920 D0 4.2ghz HT (1.3625v) Asus R3E 2xGTX 460 (non SLi, no overclock) 6x2gb G.skill @ 6-8-6-24-1T 
Hard DriveOptical DriveOSMonitor
WD-VR 300GBx1, 2xWD 1tb,2x60gb Agility Some crappy combo burner... Arch x64 3xDell U2410f rev A02 
KeyboardPowerCaseMouse
X-Armor U9BL TT Toughpower 1200w (NTB more efficient) Mountain Mods Pinnacle 24 CYO Roccat Kone (R.I.P. A4Tech x7) 
Mouse Pad
Steelpad Experience I-1 
  hide details  
Reply
post #24 of 36
Thread Starter 
You seem to be right. But, ironically, I have lost all of my OC profiles saved to my motherboard and now I will have to work them all over again.

You were all right to say it was a stability problem, but I am still curious to find out the reasons behind it.

I was gonna post back my results, but then I lost my profiles, and I'm waiting till I have time to start all over again.
post #25 of 36
Quote:
Originally Posted by EduFurtado View Post

You were all right to say it was a stability problem, but I am still curious to find out the reasons behind it.

A while stab in the dark here, but perhaps it's because you were overclocking past supported maximums? rolleyes.gif

Besides, there's no guarantees in overclocking. Some people have instabilities at much lower overclocks. If there were guarantees then all those CPUs would have been sold at the higher clock speeds to begin with. So it's just luck of the draw as to whether the your hardware will copy with such speeds, and by the sounds of it, you've been very lucky as it is.

Quite frankly, I think you're being more than a little unreasonable expecting your system to work flawlessly under such conditions.
Edited by Plan9 - 2/22/13 at 12:56am
post #26 of 36
Thread Starter 
Quote:
Originally Posted by Plan9 View Post

Quote:
Originally Posted by EduFurtado View Post

You were all right to say it was a stability problem, but I am still curious to find out the reasons behind it.

A while stab in the dark here, but perhaps it's because you were overclocking past supported maximums? rolleyes.gif

Besides, there's no guarantees in overclocking. Some people have instabilities at much lower overclocks. If there were guarantees then all those CPUs would have been sold at the higher clock speeds to begin with. So it's just luck of the draw as to whether the your hardware will copy with such speeds, and by the sounds of it, you've been very lucky as it is.

Quite frankly, I think you're being more than a little unreasonable expecting your system to work flawlessly under such conditions.

it was stable with one OS, it should be stable with the other.

But besides that, there is the fact that it seems to be something related to the multiplier, and not to the actual clock.

The data I had so far:

windows:
stable @ 3,8 with x21 multi. 1.35vcore 1.15 vtt
stable @ 3,8 with x20 multi, 1.35vcore 1.20 vtt

linux:
unstable @ 3,8 with x21 multi. 1.35vcore 1.15 vtt
unstable @ 3,8 with x21 multi. 1.40vcore 1.20 vtt - should be stable, right? At least to boot.
stable @ 3,8 with x20 multi, 1.35vcore 1.20 vtt - same as windows. this is what makes me think it's related to the multiplier.

this is what doesn't make sense to me.

it has to be something related to a certain base clock:
the default for my CPU is 133.
If, for example, I need to push it over 200, many features in the motherboard have to be disabled, for example the x21 multiplier is no longer available.

My guess is that something like this happens at a lower base clock, and linux has problems with it
post #27 of 36
Quote:
Originally Posted by EduFurtado View Post

it was stable with one OS, it should be stable with the other.

What everyone has been saying the entire time is that Linux is more efficient with it's CPU usage, and because of that Linux is more picky when it comes to overclocking than Windows is. Therefore you need to basically forget everything from when you overclocked it with Windows because with Linux it is a completely different beast. The problem seems to be that forcing a multiplier of 21 causes some slight instability with your chip that windows didn't care about, but is causing problems with Linux. You're likely going to have to either accept that you can't force the multi to be 21 and live with a lower overclock that will still probably preform just as well or better than a higher overclock in windows, or go back to windows.
post #28 of 36
Quote:
Originally Posted by EduFurtado View Post

it was stable with one OS, it should be stable with the other.

I think we've tried to be nice long enough. But have you not read anything we said?

Linux uses the CPU more efficiently than Windows does, so what Windows may consider stable, may not be stable enough for Linux to consider stable.

If you don't understand this simple concept, give up on Linux and go back to Windows.
post #29 of 36
It has nothing to do with stability. Linux incorrectly reads the multiplier, assuming its 20x when its actually 21x. This causes a timing discrepancy that results in a kernel panic. Eg. say you have bclk set to 191x21 for 4011MHz actual speed. Linux acts as if its running at 191x20 for 3820MHz.
    
CPUMotherboardGraphicsRAM
Core i5 4670k ASUS Maximus VI Gene Gigabyte GTX 460 1GB Kingston Hyper-X 
Hard DriveHard DriveHard DriveHard Drive
Samsung 830 OCZ Vertex 3 WD6401AALS WD5000AAKS 
CoolingOSMonitorMonitor
Noctua NH-D14 elementary OS Dell Ultrasharp U2312HM LG W2442PA-BF 
KeyboardPowerCaseMouse
Microsoft Sidewinder X4 Corsair HX750W Corsair Graphite 600T Logitech G700 
Audio
ASUS Xonar DG 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Core i5 4670k ASUS Maximus VI Gene Gigabyte GTX 460 1GB Kingston Hyper-X 
Hard DriveHard DriveHard DriveHard Drive
Samsung 830 OCZ Vertex 3 WD6401AALS WD5000AAKS 
CoolingOSMonitorMonitor
Noctua NH-D14 elementary OS Dell Ultrasharp U2312HM LG W2442PA-BF 
KeyboardPowerCaseMouse
Microsoft Sidewinder X4 Corsair HX750W Corsair Graphite 600T Logitech G700 
Audio
ASUS Xonar DG 
  hide details  
Reply
post #30 of 36
Thread Starter 
Quote:
Originally Posted by FateousMaximous View Post

Quote:
Originally Posted by EduFurtado View Post

it was stable with one OS, it should be stable with the other.



What everyone has been saying the entire time is that Linux is more efficient with it's CPU usage, and because of that Linux is more picky when it comes to overclocking than Windows is. Therefore you need to basically forget everything from when you overclocked it with Windows because with Linux it is a completely different beast. The problem seems to be that forcing a multiplier of 21 causes some slight instability with your chip that windows didn't care about, but is causing problems with Linux. You're likely going to have to either accept that you can't force the multi to be 21 and live with a lower overclock that will still probably preform just as well or better than a higher overclock in windows, or go back to windows.

Quote:
Originally Posted by Shrak View Post

Quote:
Originally Posted by EduFurtado View Post

it was stable with one OS, it should be stable with the other.

I think we've tried to be nice long enough. But have you not read anything we said?

Linux uses the CPU more efficiently than Windows does, so what Windows may consider stable, may not be stable enough for Linux to consider stable.

If you don't understand this simple concept, give up on Linux and go back to Windows.

Oh, so you have been TRYING to be nice?

You are the ones that think you know SOOOO much, but guess what? Do you know those people that think they know everything already, so they turn they back to new things and end up as the most ignorant ones around all of those with their eyes opened?

YOU are one of them, my friend.



PLEASE, give me some PROOF proof.gif that linux uses the CPu so much better to explain everything that is going on?


Moreover, why the heck do you assume you are the linux expert and I'm the one that doesn't know anything about it, buddy? I bet I know just as much or more than you about linux.

You are the one that haven't been paying attention to what I was saying.

Quote:
Originally Posted by nathris View Post

It has nothing to do with stability. Linux incorrectly reads the multiplier, assuming its 20x when its actually 21x. This causes a timing discrepancy that results in a kernel panic. Eg. say you have bclk set to 191x21 for 4011MHz actual speed. Linux acts as if its running at 191x20 for 3820MHz.

THIS is what I was thinking of an couldn't put into words.Makes sense, instead of just self promoting "This is like this and it is because I know it"
Suspected something like this from the start.

Did you ran into this same problem? (I guess not since, I had a p55 FTW and I didn't remember it allowing me to force x21 multi. Great board, until my old PSU fried it frown.gif )
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Linux won't boot when set CPU multi x21