Overclock.net › Forums › Case Mods & Cases › Computer Cases › Cooler Master Storm Trooper Issue Help!
New Posts  All Forums:Forum Nav:

Cooler Master Storm Trooper Issue Help!

post #1 of 4
Thread Starter 
Not sure if anyone else has this problem, with my storm trooper my front fan makes a small rattling noise, now a while ago i cleaned out the dust and it sort of helped and the sound sort of went away, im not sure if i should RMA my case or not, although the fan does not make a crunching noise, or i see no cables near the fan itself, i have looked at it countless times, seems fine to me.
post #2 of 4
Quote:
Originally Posted by ad556 View Post

Not sure if anyone else has this problem, with my storm trooper my front fan makes a small rattling noise, now a while ago i cleaned out the dust and it sort of helped and the sound sort of went away, im not sure if i should RMA my case or not, although the fan does not make a crunching noise, or i see no cables near the fan itself, i have looked at it countless times, seems fine to me.

Try this first: take out the fan and blow air gently in the rear hub area in the opening to where the fan blade hub is and then try it again.

 

If that doesn't work, just RMA the fan NOT the entire case.

 

Hope this helps.

post #3 of 4
Thread Starter 
Quote:
Originally Posted by nickt1862 View Post

Try this first: take out the fan and blow air gently in the rear hub area in the opening to where the fan blade hub is and then try it again.

If that doesn't work, just RMA the fan NOT the entire case.

Hope this helps.
I've tried to unscrew the fan but the screws are in pretty tight, ill try and take it out again and see if it works.
post #4 of 4
Quote:
Originally Posted by ad556 View Post

Quote:
Originally Posted by nickt1862 View Post

Try this first: take out the fan and blow air gently in the rear hub area in the opening to where the fan blade hub is and then try it again.

If that doesn't work, just RMA the fan NOT the entire case.

Hope this helps.
I've tried to unscrew the fan but the screws are in pretty tight, ill try and take it out again and see if it works.

 

Also when you eventually get the fan in your hands, check that the fan blades to the hub doesn't have real bad "wobbly" play as I wouldn't re-install it back if that were the scenario.

 

I've had bad cooler master fans out of the box that I RMA-ed, so you're not the first.smile.gif

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Cases
Overclock.net › Forums › Case Mods & Cases › Computer Cases › Cooler Master Storm Trooper Issue Help!