Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › I have a Ubuntu and movie issue
New Posts  All Forums:Forum Nav:

I have a Ubuntu and movie issue

post #1 of 4
Thread Starter 
I recently went to my dark corner of the house and trimmed up my old p4 movie pc. ( New wires, ram, hdd, pci wireless n card ). I gave my old parts to a friend who needed. Movies have always worked silky smooth before. ( Windows and linux mint ) But now I'm trying to stream 1080p HD mp4-avi over my network with the Iomega ez NAS 2TB with just the latest ubuntu.

My problem: Movies will start out smooth. About 5 minutes into it, it'll start slowing down and chopping. Then I'll see little squares multi coloured. Sometimes it'll freeze completely and won't read the file.

The pc:
Pentium 4 prescott 2.8 Ghz
2 Gb DDR2 ram
Asus Hd 5450 512 MB
40 GB IDE 7200RPM HDD
New wires
PSU
Thermaltake copper headsink with Arctic silver 5

I'm using Prop drivers also.


Please help? smile.gif

Thanks
post #2 of 4
What player are you using? Does it happen with a different player?
Also, if you play a 1080p file off your main HDD, is it smooth?


PS: The multi colored squares could be the file skipping. Are the sqares pink or green? If so, check your GPU temps.
TRON3000
(15 items)
 
 
ASUSness
(5 items)
 
CPUMotherboardGraphicsRAM
Q6600 G0 SLACR @ 3.0 GHz Gigabyte GA-EP31-DS3L MSI 7950 OC BE 3GB 2X2 GB 800 mhz Corsair 
Hard DriveOptical DriveOSOS
Seagate Barracuda 7200rpm 500GB LG super multi Windows 8.1 Pro 64 bit Windows 8 pro 64 bit 
OSMonitorPower
Ubuntu 12.10 Acer 19"W 4ms AL1916W Coolermaster 500W 
CPUGraphicsRAMHard Drive
Intel Core i5-5200U Intel HD Graphics 5500 4GB DDR3L 1600 MHz 128GB SSD 
OSMonitorAudio
Windows 10 64-bit 13.3 in Full HD infinity display Waves MaxxAudio 
CPUGraphicsRAMOS
Intel Core i3 3217U Intel(R) HD Graphics 4000 4.00GB DDR3 Windows 10 64-bit 
Monitor
14" Multitouch 1366x768 
  hide details  
Reply
TRON3000
(15 items)
 
 
ASUSness
(5 items)
 
CPUMotherboardGraphicsRAM
Q6600 G0 SLACR @ 3.0 GHz Gigabyte GA-EP31-DS3L MSI 7950 OC BE 3GB 2X2 GB 800 mhz Corsair 
Hard DriveOptical DriveOSOS
Seagate Barracuda 7200rpm 500GB LG super multi Windows 8.1 Pro 64 bit Windows 8 pro 64 bit 
OSMonitorPower
Ubuntu 12.10 Acer 19"W 4ms AL1916W Coolermaster 500W 
CPUGraphicsRAMHard Drive
Intel Core i5-5200U Intel HD Graphics 5500 4GB DDR3L 1600 MHz 128GB SSD 
OSMonitorAudio
Windows 10 64-bit 13.3 in Full HD infinity display Waves MaxxAudio 
CPUGraphicsRAMOS
Intel Core i3 3217U Intel(R) HD Graphics 4000 4.00GB DDR3 Windows 10 64-bit 
Monitor
14" Multitouch 1366x768 
  hide details  
Reply
post #3 of 4
Thread Starter 
Quote:
Originally Posted by kenpachiroks View Post

What player are you using? Does it happen with a different player?
Also, if you play a 1080p file off your main HDD, is it smooth?


PS: The multi colored squares could be the file skipping. Are the sqares pink or green? If so, check your GPU temps.

I was using VLC which is my main player. MPlayer skips, chops, and the audio gets out of sync. Off the main HDD is a slight change but my CPU is still getting pinned out. I think there's a CPU and GPU offloading issue here. I've tried different drivers, different methods of installing those drivers..
post #4 of 4
First reinstall your catalyst drivers. Ununtu installs an ATI driver(fglxr). Get the new ones from ATI
DO NOT try to install a new version over an old one. Remove your existing driver first
Code:
$ sudo sh /usr/share/ati/fglrx-uninstall.sh
$ sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx.

skip the first command if the file doesn't exist. Then install the new drivers and reboot

Next,

Install "Compizconfig settings manager"
Code:
sudo apt-get install compizconfig-settings-manager

In CompizConfig Settings Manager, select "General", then "Composite" & disable "Detect refresh rate"

Change the "Refresh" to your monitor's native refresh rate(check for your monitor)

Back in "General" options, select "OPENGL" & disable "Synch to Vblank"
Let us know if this works smile.gif

Warning: Spoiler! (Click to show)
PS: Disable screensaver. It might be trying to kick in during video playback
Code:
gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

Edited by kenpachiroks - 2/17/13 at 10:55pm
TRON3000
(15 items)
 
 
ASUSness
(5 items)
 
CPUMotherboardGraphicsRAM
Q6600 G0 SLACR @ 3.0 GHz Gigabyte GA-EP31-DS3L MSI 7950 OC BE 3GB 2X2 GB 800 mhz Corsair 
Hard DriveOptical DriveOSOS
Seagate Barracuda 7200rpm 500GB LG super multi Windows 8.1 Pro 64 bit Windows 8 pro 64 bit 
OSMonitorPower
Ubuntu 12.10 Acer 19"W 4ms AL1916W Coolermaster 500W 
CPUGraphicsRAMHard Drive
Intel Core i5-5200U Intel HD Graphics 5500 4GB DDR3L 1600 MHz 128GB SSD 
OSMonitorAudio
Windows 10 64-bit 13.3 in Full HD infinity display Waves MaxxAudio 
CPUGraphicsRAMOS
Intel Core i3 3217U Intel(R) HD Graphics 4000 4.00GB DDR3 Windows 10 64-bit 
Monitor
14" Multitouch 1366x768 
  hide details  
Reply
TRON3000
(15 items)
 
 
ASUSness
(5 items)
 
CPUMotherboardGraphicsRAM
Q6600 G0 SLACR @ 3.0 GHz Gigabyte GA-EP31-DS3L MSI 7950 OC BE 3GB 2X2 GB 800 mhz Corsair 
Hard DriveOptical DriveOSOS
Seagate Barracuda 7200rpm 500GB LG super multi Windows 8.1 Pro 64 bit Windows 8 pro 64 bit 
OSMonitorPower
Ubuntu 12.10 Acer 19"W 4ms AL1916W Coolermaster 500W 
CPUGraphicsRAMHard Drive
Intel Core i5-5200U Intel HD Graphics 5500 4GB DDR3L 1600 MHz 128GB SSD 
OSMonitorAudio
Windows 10 64-bit 13.3 in Full HD infinity display Waves MaxxAudio 
CPUGraphicsRAMOS
Intel Core i3 3217U Intel(R) HD Graphics 4000 4.00GB DDR3 Windows 10 64-bit 
Monitor
14" Multitouch 1366x768 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › I have a Ubuntu and movie issue