Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Cannot Boot into AHCI MODE in Windows 8
New Posts  All Forums:Forum Nav:

Cannot Boot into AHCI MODE in Windows 8

post #1 of 6
Thread Starter 

I have read into many different threads in this category and found no resolution. The thing is; it's just is on my end of the spectrum. I need a way to set my performance on my SSD. My OS is installed on my Vertex Plus 120Gb and so is my boot loader. My problems is related to not being able to use my AHCI mode configuration. It works in Windows 7 and when I did my upgrade to Windows 8, my bios for my SATA config was reset and was set to IDE Mode. Technically, all my controllers are using the default IDE in the device manager. See pics.

 

System Info:

 

- Check sig rig or pics

- My motherboard (MSI 990fxa-gd80) is on the latest version V11.13

- My SSD OCZ vertex Plus is on it's latest firmware of 3.55

- Installed Windows 8 as an upgrade from Windows 7 with IDE enabled

 

My underperformed SSDs:

 

 

 

 

 

 

 

 

 

 

 

 

 

Here is what I've tried:

 

- Registry Hack

 

Below is one for Intel Boards


HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/services/iaStorV
right click on Start, select Modify and set Data Value to 0

 

 

 

This one is for AMD Boards


HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/services/msahci
right click on Start, select Modify and set Data Value to 0

 

 

 


- How do I install my AHCI controllers?

It's been proposed throughout the interwebz to use MIcrosoft's default AHCI controllers... but how do I do that?

 

*****Anyway, I know the easiest way is to go back and reinstall Windows 7 and leave it at that for the performance increase or reinstall Windows 8 fresh, but I only have the upgrade key, it won't work with a full installation without cheating to a pirate...*****

 

I haven't tried a full installation with the bios set to AHCI then install windows 8 to see if it works.... but, I am lazy and yes I do have backup images.... I just want to know another way around before I reformat...

 

I BSOD with a happy face when set to AHCI mode in my bios...

 

Thanks for any help in advance!

 

post #2 of 6
Change to AHCI mode from IDE mode:

Regedit:
  1. Exit all Windows-based programs.
  2. Press [Win] + R or take the RUN option from the start menu.
  3. Now type Regedit there and press Enter Key to open up the Registry Editor Window. (If you receive the User Account Control dialog box, click Continue.)
  4. Locate and then click the following registry sub key:
    Code:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci
    
  5. In the right pane right-click Start in the Name column and then click Modify.
  6. In the Value data box, type 0 [3 is default], and then click OK.
  7. On the File menu, click Exit to close Registry Editor.
  8. Restart your computer
  9. Go to UEFI/BIOS and enable AHCI, Save & Reboot
  10. Another restart will be required to finish the driver installation.
For Sale: x2 Canon 430EX II
$180 (USD)
ROG Rig
(14 items)
 
Terrorbyte V2
(82 photos)
CPUMotherboardGraphicsRAM
i7-4790 Asus Maximus VI Extreme MSI GTX 660 Ti PE OC 32GB Kingston HyperX Beast 2400MHz 
Hard DriveHard DriveHard DriveHard Drive
256GB Micron M600 1TB Micron M600 250GB Samsung 840 EVO  1TB WD Blue WD10EZEX 
Hard DriveHard DriveCoolingOS
3TB Toshiba DT01ACA300 256GB Plextor M6e Cooler Master T4 Windows 8.1 Pro 64-Bit 
PowerCase
Corsair RM650 Thermaltake Core v51 
  hide details  
Reply
For Sale: x2 Canon 430EX II
$180 (USD)
ROG Rig
(14 items)
 
Terrorbyte V2
(82 photos)
CPUMotherboardGraphicsRAM
i7-4790 Asus Maximus VI Extreme MSI GTX 660 Ti PE OC 32GB Kingston HyperX Beast 2400MHz 
Hard DriveHard DriveHard DriveHard Drive
256GB Micron M600 1TB Micron M600 250GB Samsung 840 EVO  1TB WD Blue WD10EZEX 
Hard DriveHard DriveCoolingOS
3TB Toshiba DT01ACA300 256GB Plextor M6e Cooler Master T4 Windows 8.1 Pro 64-Bit 
PowerCase
Corsair RM650 Thermaltake Core v51 
  hide details  
Reply
post #3 of 6
Thread Starter 
Quote:
Originally Posted by Sean Webster View Post
  1. Locate and then click the following registry sub key:
    Code:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\startoverride
    
  2. In the right pane right-click Start in the Name column and then click Modify.
  3. In the Value data box, type 0 [3 is default], and then click OK.
  4. On the File menu, click Exit to close Registry Editor.
  5. Restart your computer
  6. Go to UEFI/BIOS and enable AHCI, Save & Reboot
  7. Another restart will be required to finish the driver installation.

Thanks for quick reply, but I don't have that start key under startoverride... do I just add the string value?

post #4 of 6
Quote:
Originally Posted by RuBB3rBunZ View Post

Thanks for quick reply, but I don't have that start key under startoverride... do I just add the string value?
Just click the storahci folder then change that start value to 0.
For Sale: x2 Canon 430EX II
$180 (USD)
ROG Rig
(14 items)
 
Terrorbyte V2
(82 photos)
CPUMotherboardGraphicsRAM
i7-4790 Asus Maximus VI Extreme MSI GTX 660 Ti PE OC 32GB Kingston HyperX Beast 2400MHz 
Hard DriveHard DriveHard DriveHard Drive
256GB Micron M600 1TB Micron M600 250GB Samsung 840 EVO  1TB WD Blue WD10EZEX 
Hard DriveHard DriveCoolingOS
3TB Toshiba DT01ACA300 256GB Plextor M6e Cooler Master T4 Windows 8.1 Pro 64-Bit 
PowerCase
Corsair RM650 Thermaltake Core v51 
  hide details  
Reply
For Sale: x2 Canon 430EX II
$180 (USD)
ROG Rig
(14 items)
 
Terrorbyte V2
(82 photos)
CPUMotherboardGraphicsRAM
i7-4790 Asus Maximus VI Extreme MSI GTX 660 Ti PE OC 32GB Kingston HyperX Beast 2400MHz 
Hard DriveHard DriveHard DriveHard Drive
256GB Micron M600 1TB Micron M600 250GB Samsung 840 EVO  1TB WD Blue WD10EZEX 
Hard DriveHard DriveCoolingOS
3TB Toshiba DT01ACA300 256GB Plextor M6e Cooler Master T4 Windows 8.1 Pro 64-Bit 
PowerCase
Corsair RM650 Thermaltake Core v51 
  hide details  
Reply
post #5 of 6
Thread Starter 

Sorry Sean that method never did work for me... none of the registry tweaks worked...

I had to do a "Refresh of Windows 8"

Here were the steps that brought me to that conclusion:

- Tried the registry hack many times and ended up BSOD constantly

- I set AHCI mode in the bios, saved settings, rebooted

- I had to come back to bios because my boot order changes every time I switch SATA Modes

- Changed Boot Order

- Was welcomed with another BSOD

- Let Windows 8 ran it's course

- Windows 8 did it's "Automatic Repair" script

- Windows 8 couldn't repair system so it suggested many options such as "Advance Options", "Refresh PC" or "Boot into Windows 8"

- I selected the "Refresh PC" option and then selected "Refresh your PC without affecting your files" (This is faster), selecting "Remove Everything and Reinstall Windows" will do a long reformat which I didn't choose.

- I lost all my programs installed (but I have all downloaded programs)

- Window 8 installed it's generic AHCI controllers (remember I set this in my BIOS, and specifically this is like a whole reinstallation of the OS)

- FIXED the AHCI MODE PROBLEM, now I have AHCI mode enabled in BIOS and a few restarts to update Windows 8 (took like two hours to update my operating system to fully function)

- Did a system image backup to my external hard drive so I will never go through this mess again.

- Now I am happy. It took me a whole Saturday to mess with just changing a simple mode. But I bit my pride and did a reformat of my OS. rolleyes.gif

- My system runs smoother now. See available pics:

- Thank you Sean for your assistance!  smile.gif


**For anyone else that cannot solve this issue, I hope these steps will help you typically unlocking this AHCI mode after a upgrade from Windows 7.**

 

 

 

 

 

My /storahci

 

A LOT BETTER!

 

 

 

post #6 of 6
Quote:
Originally Posted by RuBB3rBunZ View Post

Sorry Sean that method never did work for me... none of the registry tweaks worked...

Win8 is slightly different on how it was fixed under Win7, there's an additional place that needs a change otherwise you'll keep getting BSOD... either way, I guess it's good to see refresh your PC also works incase you want to throw that in there.
Mine
(20 items)
 
  
Reply
Mine
(20 items)
 
  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: SSD
Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Cannot Boot into AHCI MODE in Windows 8