post #1 of 1
Thread Starter 

Need help getting started and understanding the lingo of driver names.
For 3 days I have been reading and installing - and MISSING something.

OS: Linux
I have been trying ti get the drivers to install on either Debian or Ubuntu.

I just got a Radeon HD 7750.
I want to use it primarily for number-crunching on BOINC - I need the OpenGL.

I went to the AMD website and was pleased to see that they offered proprietary drivers for Linux.
sent to:
AMD Catalyst™ Proprietary Display Driver - Linux x86 & Linux x86_64
(( OK, I have AMD 64. I assumed that x86_64 would work. ))

This called out a download for:
AMD Catalyst™ 13.1 Proprietary Linux x86 Display Driver

Here is where I get confused.

When I start the install of that driver, it then gives a choice of:
A) Install Driver 9.012 on Xorg 6.9 or later 64 bit
B) Generate Distribution Specific Driver Package

What is the 9,012 driver? fglrx?

here is what happens.
A) Errors out - One or more tools required for the installation cannoot be found on the system.
Install the required tools before installing the fglrx driver.
See /usr/share/ati/fglrx-install.log for more details.

The log says I'm missing version.h
Houston, we have a path problem..

the error message:
fglrx installation requires that the system have kernel headers.
cannot be found on this system.

But it is another path on my system:

OK. I did a punt. Tried the "Generate Distribution Specific Driver Package" option.

Not quite OK.
It supported RedHat, SUSE, Debian-Lenny (see note), Fedora, Mageia,
Mageia, Mandriva, Slackware, and Ubuntu.

I was impressed. Then I started looking at the release dates of the distributions.
The Debian Lenny release is fairly outdated.
( Squeeze followed Lenny in February, 2011. "Wheezy" is upcoming.)

I tried a
./ --buildpkg Debian/stable

This gave the error:
./packages/Debian/ 177:
dpkg-architecture: not found
Error: unsupported architecture:

Punt again.
Wipe out whole system and try Ubuntu instead of Debian.

Remenber the fglrx driver mentioned above?
When I installed those, the video crashed/hung/wentaway.

Lots of messages in the Ubuntu forums that said to uninstall fglrx.

Can anyone tell me about the relationship between
catalyst 13 and fglrx?

I read (somewhere) that catalyst required Microsoft ".net".

Suggestions? Love letters? Advice?

Many thanks in advance,

BOINC says it can't see the GPU.
I suppose this is because there is no driver. (yet)

I did cross-post in the BOINC GPU forum as well.
But I saw a wide group participation her in OCN and posted her.

Again, many thanks in advance.