Overclock.net › Forums › Video Games › PC Gaming › Tri-SLI GTX 570 & fluctuating GPU Usage. Unplayable Gameplay
New Posts  All Forums:Forum Nav:

Tri-SLI GTX 570 & fluctuating GPU Usage. Unplayable Gameplay

post #1 of 2
Thread Starter 
Here's my specs:

CPU: Intel i7 3770 (Locked version, Yet still overclocks to 4.5Ghz perfectly stable)
RAM: 16GB Corsair Vengeance 1600Mhz
Motherboard: EVGA Z77 FTW 1155
GPU: 3X GTX 570 Superclocked Edition
PSU: Cougar 1050W 80 Plus Gold
HDD: 2X Kingston HyperX 120GB SSD in Raid 0
Western Digital 750GB Caviar Black (Storage Drive)
Monitors: 3X ASUS VE248H 24" (Playing Crysis at 1080P Only)

So I got Crysis 3 yesterday, maxed all the settings out and started playing and noticed that my frame rate was extremely inconsistent and would drop down to 10FPS (From 60FPS) when turning around in-game and just at random moments. So I opened MSI Afterburner and monitored my GPUs while I was playing crysis and noticed that GPU's usage was fluctuating from 30% to 80% on each card. The usage would spike randomly causing my FPS drop to unplayable FPS at random times. I've installed all the new nVidia drivers with "Crysis 3 Performance Increase" and enabled 3-GPU Rendering and Prefer Maximum Performance in my 3D Game settings in the nVidia control panel. Nothing seems to stop this fluctuating GPU usage and it's really starting to aggravate me since the game is basically unplayable, and I know my PC can handle it. I've even tried lowering the settings to high and turning Motion Blur off and I still get GPU fluctuation and unplayable game play. If someone could help me out with this, that would be greatly appreciated. Thanks!
post #2 of 2
I would suggest to try two card only or older drivers too. Did you have any issue before with your 3 card?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Tri-SLI GTX 570 & fluctuating GPU Usage. Unplayable Gameplay