Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › HOW TO FIX explorer.exe 100% cpu usage
New Posts  All Forums:Forum Nav:

HOW TO FIX explorer.exe 100% cpu usage

post #1 of 4
Thread Starter 
This will fix it:

The obnoxious bug in XP that causes Explorer to read the entire contents of broken AVI files before allowing any access to them is caused by bad behavior of shmedia.dll.

This problem manifests itself by causing Explorer to read the entire contents of an AVI file, regarless of its size or location any time the mouse pointer is hovered over it, or an attempt is made to access it in windows explorer. This causes 'permission denied' errors when trying to simply move, copy or delete these files as they cannot be changed while Explorer has an open handle on them.

This also causes a DoS situation where large AVI's are stored on remote shares and Explorer keeps reading the files from beginning to end each time they are accessed.

To correct this misbehavior in Windows XP, remove the following registry key.

HKEY_LOCAL_MACHINE\\SOFTWARE\\Classes\\CLSID\\{87D 62D94-71B3-4b9a-9489-5FE6850DC73E}\\InProcServer32

This will prevent Explorer from loading shmedia.dll in response to file property queries on these files. This will not effect your ability to play files, get file attributes, or even view thumbnails. Say goodbye to all explorer.exe 100% CPU issues.

And Solution #2 (basically does the same thing, except you are inactivating the file attributes option)...But it WORKS--No more locked .avi files:

Well windows seem to have a REALLY big problem when it comes to reading AVI files. It seems that when you click on an AVI file in explorer, it'll try to read the entire AVI file to determine the width,height, etc. of the AVI file (this is displayed in the Properties window). Now the problem with Windows is that if you have a broken/not fully downloaded AVI file that doesnt contain this info, Windows will scan the entire AVI file trying to figure out all these properties which in the process will probably cause 100% CPU usage and heavy memory usage.

To solve this problem all you have to do is the following:

1. Open up regedit
2. Goto HKEY_CLASSES_ROOT\\SystemFileAs
sociations\\.avi\\shellex\\PropertyHandler
3. Delete the "Default" value which should be "{87D62D94-71B3-4b9a-9489-5FE6850DC73E}"

Please note that this will no longer provide you with the windows properties displaying the AVI file information such as width, height, bitrate etc. But its a small price to pay for saving you resources.

http://forums.spywareinfo.com/index.php?showtopic=884 posted by lion7718
Laptop
(13 items)
 
  
CPUGraphicsRAMHard Drive
Athlon-II P320 DualCore 2.1GHz AMD M880G with ATI Mobility Radeon HD 4250 3GB 250GB 
Optical DriveOSMonitorKeyboard
DVD/RW Windows 7 Home Premium 64Bit 24in 1080p Viewsonic Wireless 
Mouse
Wireless 
  hide details  
Reply
Laptop
(13 items)
 
  
CPUGraphicsRAMHard Drive
Athlon-II P320 DualCore 2.1GHz AMD M880G with ATI Mobility Radeon HD 4250 3GB 250GB 
Optical DriveOSMonitorKeyboard
DVD/RW Windows 7 Home Premium 64Bit 24in 1080p Viewsonic Wireless 
Mouse
Wireless 
  hide details  
Reply
post #2 of 4
Pretty Much the same as this then Really...

Quote:
AVI FILES: Warning: Please back up Registry before Performing this step. Windows XP loads the entire AVI file before playing it which can cause delays. To prevent this from happening by making a change to a ''Registry Key''.To do this go to ''Start'' ''Run'' and type ''regedit''. Then locate ''HKEY_CLASSES_ROOT\\CLSID\\{87D62D94-71B3-4B9A-9489-5FE6850DC73E}''. Rename the Key by adding a minus sign to it, For example -{87d62d94-71b3-4b9a-9489-5fe6850dc73e}.

Nice Job Jamme
post #3 of 4
Thread Starter 
" i am me " is my name but ppl say jamme all the time but it's " i am me "

I searched on here for a related topic but couldn't find one, I have ran into this in the past and thought I would post it here in windows forum!
Laptop
(13 items)
 
  
CPUGraphicsRAMHard Drive
Athlon-II P320 DualCore 2.1GHz AMD M880G with ATI Mobility Radeon HD 4250 3GB 250GB 
Optical DriveOSMonitorKeyboard
DVD/RW Windows 7 Home Premium 64Bit 24in 1080p Viewsonic Wireless 
Mouse
Wireless 
  hide details  
Reply
Laptop
(13 items)
 
  
CPUGraphicsRAMHard Drive
Athlon-II P320 DualCore 2.1GHz AMD M880G with ATI Mobility Radeon HD 4250 3GB 250GB 
Optical DriveOSMonitorKeyboard
DVD/RW Windows 7 Home Premium 64Bit 24in 1080p Viewsonic Wireless 
Mouse
Wireless 
  hide details  
Reply
post #4 of 4
Quote:
Originally Posted by iamme View Post
" i am me " is my name but ppl say jamme all the time but it's " i am me "

I searched on here for a related topic but couldn't find one, I have ran into this in the past and thought I would post it here in windows forum!
Never had problems with that myself. Good info though. Thank you taking the time to post it.

I am me too
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 8700k z370 gaming 7 evga 980 ti 32 Corsair 3200 
Hard DriveOptical DriveOSMonitor
samsung 950 HP dual layer Windows 7 64 27 dell ips  
KeyboardPowerCaseMouse
G15 1050 evga corsair 540 air G900 
Mouse Pad
generic 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 8700k z370 gaming 7 evga 980 ti 32 Corsair 3200 
Hard DriveOptical DriveOSMonitor
samsung 950 HP dual layer Windows 7 64 27 dell ips  
KeyboardPowerCaseMouse
G15 1050 evga corsair 540 air G900 
Mouse Pad
generic 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › HOW TO FIX explorer.exe 100% cpu usage