Overclock.net › Forums › Components › Mice › 'Razer Deathadder 2013' supporting 64bit?
New Posts  All Forums:Forum Nav:

'Razer Deathadder 2013' supporting 64bit?

post #1 of 9
Thread Starter 
Hi, My first post here thumb.gif

I have this mouse. works nice on my 'vista 32-bit' laptop but on my tower 'windows 7 64-bit' I am having huge driver problems!

I had the mouse working in my tower. Working fine for about a week no problems. plug n play fine. And I installed synapse, tweaked the settings. fine!
But a couple of days ago I turned my tower on the mouse wasn't being detected..huh? why?

So naturally I tried all troubleshooting, updating mouse in device manager but not recognized, restore to a previous point (which actually worked temporary but then not recognized in synapse lol), reinstalling synapse, .. nothing! It seems the drivers deleted or corrupted them somehow? strange.
It seems to do it after a reboot.
No driver in device manager being detected
When I restore to a previous point, the razer drivers show when i scan to be restore but this seems very temperamental and doesn't work.

I sent a support ticket to razer, got a reply saying "try this troubleshooting blah blah.."

Looking on their website I can't actually see that it does support 64bit so am I going mad?
Would razer sell a mouse labeled '2013' that doesn't support 64 bit? they're older deathadders seem to support 64 bit.

Its all I can think as to why my razer mouse no longer works in my tower. The mouse works fine though because I am using on my laptop to type this smile.gif

Sorry for the long winded post rolleyes.gif, Anyone got advice or experience with this mouse or razer driver problem?

thanks

reverse''
post #2 of 9
driver (synapse) and mouse (da2013) works like a charm on win 7 home premium 64 bit and win 7 prof 64 bit.
post #3 of 9
Thread Starter 
So I have synapse installed and 'its not recognizing the mouse'.

The mouse works in other pc's though ..hmm
post #4 of 9
I installed Synapse 2.0 just fine on my Windows 7 Home Premium 64-bit.

When I first got the mouse I plugged it into my PC, let Windows detect it, downloaded Synapse and installed it. Not sure if there's another driver causing your conflict but the driver software should work fine.
post #5 of 9
Mine is working fine here on Windows 7 64-bit. Are you sure the USB port you're plugged in to works OK?
KamIX
(22 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 7700K Asus Maximus IX Hero Asus Strix GTX1080 32GB G.Skill Ripjaws V DDR4-2666 CL15 
Hard DriveHard DriveHard DriveCooling
Plextor M8Pe 512GB (NVMe w/ Heatsink) Samsung 850 Evo 500GB Western Digital Black 4TB Noctua NH-D15 
OSMonitorKeyboardPower
Windows 10 64-bit Dell UltraSharp U2515H (1440p, 60Hz IPS) Vortex Pok3r (MX Blue, Double-Shot PBT Keycaps) EVGA SuperNOVA 750 G3 
CaseMouseMouse PadAudio
Coolermaster MasterCase 5 Pro w/ 4x Noctua NF-A14 Logitech G900 Zowie G-SR FiiO E10K 
AudioAudioAudioOther
Sennheiser HD598 SE (Black) Mackie CR3 Blue Microphones Snowball iCE (Black) Steam Controller 
OtherOther
CM Storm Skorpion Microsoft LifeCam Studio 
  hide details  
Reply
KamIX
(22 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 7700K Asus Maximus IX Hero Asus Strix GTX1080 32GB G.Skill Ripjaws V DDR4-2666 CL15 
Hard DriveHard DriveHard DriveCooling
Plextor M8Pe 512GB (NVMe w/ Heatsink) Samsung 850 Evo 500GB Western Digital Black 4TB Noctua NH-D15 
OSMonitorKeyboardPower
Windows 10 64-bit Dell UltraSharp U2515H (1440p, 60Hz IPS) Vortex Pok3r (MX Blue, Double-Shot PBT Keycaps) EVGA SuperNOVA 750 G3 
CaseMouseMouse PadAudio
Coolermaster MasterCase 5 Pro w/ 4x Noctua NF-A14 Logitech G900 Zowie G-SR FiiO E10K 
AudioAudioAudioOther
Sennheiser HD598 SE (Black) Mackie CR3 Blue Microphones Snowball iCE (Black) Steam Controller 
OtherOther
CM Storm Skorpion Microsoft LifeCam Studio 
  hide details  
Reply
post #6 of 9
Thread Starter 
Quote:
Originally Posted by francisw19 View Post

Mine is working fine here on Windows 7 64-bit. Are you sure the USB port you're plugged in to works OK?

Ive tried all my usb ports 2 at front 8 on back smile.gif

So I could have a dud razer mouse that has taken a disliking to MY pc lol..
I'm currently preparing and as a last resort reinstalling windows because I'm guessing so far its a driver issue on my pc.

Thanks for all your help and quick replies.. Thankyou thumb.gif
post #7 of 9
whats your motherboard?
try disabling 'intel smart connect' in BIOS
UMX4 Gaming PC
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K 4.6GHz ASUS MAXIMUS RANGER VIII Z170 MSI GTX 1080 Gaming X G.Skill Ripjaws V 2x8GB 3200MHz 
Hard DriveHard DriveHard DriveHard Drive
GoodRam Iridium Pro 240GB SanDisk A110 256GB M.2 Crucial M4 128GB Crucial MX300 525GB 
CoolingOSMonitorKeyboard
Prolimatech Megahalems Windows 10 BENQ XL2420T 120Hz QuickFire TK MX Blue 
PowerCaseMouseMouse Pad
Seasonic Platinum XP2 860W Jonsbo UMX4 Black Tempered Glass Razer Deathadder Elite Razer Gigantus 
Audio
HyperX Cloud 
  hide details  
Reply
UMX4 Gaming PC
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K 4.6GHz ASUS MAXIMUS RANGER VIII Z170 MSI GTX 1080 Gaming X G.Skill Ripjaws V 2x8GB 3200MHz 
Hard DriveHard DriveHard DriveHard Drive
GoodRam Iridium Pro 240GB SanDisk A110 256GB M.2 Crucial M4 128GB Crucial MX300 525GB 
CoolingOSMonitorKeyboard
Prolimatech Megahalems Windows 10 BENQ XL2420T 120Hz QuickFire TK MX Blue 
PowerCaseMouseMouse Pad
Seasonic Platinum XP2 860W Jonsbo UMX4 Black Tempered Glass Razer Deathadder Elite Razer Gigantus 
Audio
HyperX Cloud 
  hide details  
Reply
post #8 of 9
Thread Starter 
Quote:
Originally Posted by phyber View Post

whats your motherboard?
try disabling 'intel smart connect' in BIOS

amd phenom 2 x6 1055t
post #9 of 9
Thread Starter 
sorry lol been at the pc's all day..saw intel thought you meant chip.

gigabyte ga-790xta ud4 am3

So you are saying go in the bios and disable something.. wow what?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › 'Razer Deathadder 2013' supporting 64bit?