Overclock.net › Forums › Graphics Cards › AMD/ATI › Can someone help me troubleshoot a problem with the 7950?
New Posts  All Forums:Forum Nav:

Can someone help me troubleshoot a problem with the 7950?

post #1 of 5
Thread Starter 
Hi, I've recently purchased the 7950 and am having graphical anomaly while playing the Witcher 2. I just arrive to the Flotsam Forests and there are these flickering white flashes whenever I move my character. And the shadows just look weird.

I am playing on stock clock speed, and the temp stays under 60c. I've tried every drivers from 12.5 to 13.2 beta and the same flickering still persist. Tried 3dmark11 and Unigine Heaven and experience neither crash nor artifacts

The weird thing is, when I tried to record this flickering using Fraps and Afterburner, the flickering stopped. As soon as I disable the recording, the flickering comes back. I also noticed that if I disable Fullscreen, there would not be any flickering.

Tried the game on windows 7, reset my CPU to stock speed, problem still persist.

Do you guys think this is a hardware - related problem? If so I need to RMA the card ASAP.

P.S. I currently only have the Witcher 2 so I can't try other games.

System Specs:
i5-3570k
HD 7950
8 GB RAM
Windows 8 Pro

Thanks
Edited by driedupfish - 2/26/13 at 4:44pm
post #2 of 5
Could be an issue with the game installation. Is the copy legit? If it is, I'd try reinstalling it from Steam or Disc. thumb.gif
Dire Wolf
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7 4790K @ 4.9Ghz - 1.35v - Delidded Asus Z97 ROG Maximus VII Hero MSI GTX 1080Ti 11GB Gaming X 16GB Corsair Vengeance Pro 2400mhz 
Hard DriveHard DriveCoolingOS
Samsung SM951 M.2 NVMe - 256GB Samsung 840 EVO - 500GB Noctua NH-D15 Windows 10 Pro 
MonitorKeyboardPowerCase
IIyama 28" 4K B2888UHSU-B1 Corsair Vengeance K90 - MX Red EVGA Supernova 1300W G2 /w Be Quiet! Pure Wings 2 Corsair Carbide 540 Air 
MouseMouse PadAudioAudio
Mionix Naos 8200 Corsair Extended Mouse Mat Creative Soundblaster Z AKG K702 w/ Antlion ModMic 
Other
Logitech Extreme 3D Pro 
  hide details  
Reply
Dire Wolf
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7 4790K @ 4.9Ghz - 1.35v - Delidded Asus Z97 ROG Maximus VII Hero MSI GTX 1080Ti 11GB Gaming X 16GB Corsair Vengeance Pro 2400mhz 
Hard DriveHard DriveCoolingOS
Samsung SM951 M.2 NVMe - 256GB Samsung 840 EVO - 500GB Noctua NH-D15 Windows 10 Pro 
MonitorKeyboardPowerCase
IIyama 28" 4K B2888UHSU-B1 Corsair Vengeance K90 - MX Red EVGA Supernova 1300W G2 /w Be Quiet! Pure Wings 2 Corsair Carbide 540 Air 
MouseMouse PadAudioAudio
Mionix Naos 8200 Corsair Extended Mouse Mat Creative Soundblaster Z AKG K702 w/ Antlion ModMic 
Other
Logitech Extreme 3D Pro 
  hide details  
Reply
post #3 of 5
Thread Starter 
The game is legit. I bought the game from Steam and then got the backup copy from GOG.com. I've tried both version (steam and gog) and experience the same issue.
post #4 of 5
Thread Starter 
Can there be a possibility that the card is faulty? I've spent too much time troubleshooting and would rather go through the RMA process. However, they'll just send me back the same card if there is nothing wrong with it.
post #5 of 5
Thread Starter 
Update:

I swapped in my old 5770 and there is no more flickering. Time to RMA I guess...

I am guessing it has something to do with the 7950's GPU usage? When I use a recording software to record gameplay. the GPU usage drops to about 80's (from 99%) and there is no flickering. So does that mean when the gpu is in full load it will produce flickering? However, when I benchmark using 3dmark11 and Unigine Heaven (both stress GPU to 99% usage) there is no artifacts...,at least none that I notice.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Can someone help me troubleshoot a problem with the 7950?