Overclock.net › Forums › Cooling › Water Cooling › H100i Pump noises.
New Posts  All Forums:Forum Nav:

H100i Pump noises.

post #1 of 3
Thread Starter 
Hey there,

So I just installed my H100i in my New Fractal R4, hoping to have a very silent system, having just removed all my mechanical drives.

Anyway, I have configured it all in Corsair Link so the fans are on silent, but there is still a very audible pump noise. Even more than my Antec Kuhler 620. It is very disconcerting to hear, but it doesn't seem like the grinding noise everyone's been having.

I have the newest version of Corsair Link.

I've attached a video, it doesn't quite demonstrate the noise, but it is very loud. When I say turn up, I meant turning up the fans.




post #2 of 3
Maybe there is an air bubble? Have you tried tapping the pump and/or radiator? Or even giving your case a little shake? Other than that, your best bet might be to try an RMA if you think it's louder than it should be.

PS, your video didn't work, so I'm going off of your description.
Duty Mode
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k Asus Maximus V Formula Powercolor 7970 Vortex II Corsair Vengeance Low Profile 
Hard DriveHard DriveHard DriveOptical Drive
SanDisk Ultra SSD Corsair Force GT Western Digital Green Asus Bulk 
CoolingOSMonitorKeyboard
Corsair H100 Windows 8 64-bit Asus VG236HE Razer Black Widow Ultimate 
PowerCaseMouseAudio
Corsair AX 850 Corsair C70 - Military Green Razer Naga Plantronics GameCom 780 
  hide details  
Reply
Duty Mode
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k Asus Maximus V Formula Powercolor 7970 Vortex II Corsair Vengeance Low Profile 
Hard DriveHard DriveHard DriveOptical Drive
SanDisk Ultra SSD Corsair Force GT Western Digital Green Asus Bulk 
CoolingOSMonitorKeyboard
Corsair H100 Windows 8 64-bit Asus VG236HE Razer Black Widow Ultimate 
PowerCaseMouseAudio
Corsair AX 850 Corsair C70 - Military Green Razer Naga Plantronics GameCom 780 
  hide details  
Reply
post #3 of 3
Thread Starter 
Quote:
Originally Posted by ChrisTahoe View Post

Maybe there is an air bubble? Have you tried tapping the pump and/or radiator? Or even giving your case a little shake? Other than that, your best bet might be to try an RMA if you think it's louder than it should be.

PS, your video didn't work, so I'm going off of your description.

Should be working now smile.gif My bad!

Hmm. Yeah I might have to RMA it. Only issue is, I live in Little old New Zealand, so it'd take foreeever.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › H100i Pump noises.