Overclock.net › Forums › Graphics Cards › AMD/ATI › Can it be that three 7970's in a row are defective????
New Posts  All Forums:Forum Nav:

Can it be that three 7970's in a row are defective????

post #1 of 65
Thread Starter 
I ordered 2 XFX 7970 BE DD's two weeks ago for my main rig. I got them and happily installed them but kept having screen tearing issues as artifacts in heaven, and most importantly, in games. I also was having some lower than expected FPS after this install. After testing them in another pc and much troubleshooting, both cards were bad which I thought was very odd. I did make note that the cards were only 6 away from each other in serial number so i though maybe just a bad batch of memory or something. So in the mean time I borrowed two 7970's that are the stock diamond reference cards which work ok i guess just no custom cooling so loud/kinda hot so I ordered two more of the same card as I know two dead cards is somewhat odd. Welll my two new cards got here and for the fear of a repeat I only installed one card this time and bam artifacting in Skyrim menus (where the reference 7970's I'm using atm are not doing this at all) So I have now tried 3 different 7970 and they all have had problems. Artifacting terrible or some cannot even go through a benchmark at stock clocks without crashing /weird actions. I know everyone keeps talking about how great these are but what the HELL is wrong with them then?


So lastly I dripped in an EVGA 680 4gb and It has run excellent but the price for two 4gb 680's is around $1,100 so I would rather spend around $800-850 for the AMD if possible as i just don't think the performance difference is THAT much different (is it?)

So in short, three were tested on a new and old pc that has no troubles with NVidia cards and had no problems with the other 7970's I tried.


My main question is.......are three 7970's in a row really bad? I want to make sure its not user error and cost myself more than needs be .




So What the eff?
post #2 of 65
  • Which drivers were you using?
  • Did you uninstall drivers before changing cards?
  • If so, What method have you used?
Quad Damage
(24 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 4930k @ 4.6Ghz Asus Rampage IV Extreme (Koolance Full WB) 2 x GTX 1080ti FE in SLI (EK WATERBLOCK) Corsair Dominator GT 2133 MHz (16GB) 
Hard DriveHard DriveHard DriveHard Drive
3 TB Seagate OCZ Vertex 4 256GB Crucial M4 128GB ADATA SX900 128GB 
CoolingCoolingCoolingCooling
RIVE Koolance Waterblock (VRM and PCH) Feser X-Changer 360 Feser X-Changer 240 Feser X-Changer 480 
CoolingCoolingCoolingOS
WaterCool MoRA3 Pro with Gentle Typhoon 3 x MCP 655 pumps (With EK top...all serial) 2 x EK FC 1080ti Blocks Windows 7 Ultimate x64 
MonitorMonitorKeyboardPower
Asus ROG Swift PG348Q (3440x1440 @100hz) CrossOver 27Q Led-P Logitech G15 EVGA SuperNova 1600T2 (Titanium) 
CaseMouseMouse PadAudio
Corsair Obsidian Heavily Modded Logitech G700 RocketFish Speed/Control M-audio AV-40 (Logitech G-35) 
  hide details  
Reply
Quad Damage
(24 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 4930k @ 4.6Ghz Asus Rampage IV Extreme (Koolance Full WB) 2 x GTX 1080ti FE in SLI (EK WATERBLOCK) Corsair Dominator GT 2133 MHz (16GB) 
Hard DriveHard DriveHard DriveHard Drive
3 TB Seagate OCZ Vertex 4 256GB Crucial M4 128GB ADATA SX900 128GB 
CoolingCoolingCoolingCooling
RIVE Koolance Waterblock (VRM and PCH) Feser X-Changer 360 Feser X-Changer 240 Feser X-Changer 480 
CoolingCoolingCoolingOS
WaterCool MoRA3 Pro with Gentle Typhoon 3 x MCP 655 pumps (With EK top...all serial) 2 x EK FC 1080ti Blocks Windows 7 Ultimate x64 
MonitorMonitorKeyboardPower
Asus ROG Swift PG348Q (3440x1440 @100hz) CrossOver 27Q Led-P Logitech G15 EVGA SuperNova 1600T2 (Titanium) 
CaseMouseMouse PadAudio
Corsair Obsidian Heavily Modded Logitech G700 RocketFish Speed/Control M-audio AV-40 (Logitech G-35) 
  hide details  
Reply
post #3 of 65
Thread Starter 
the new 13.7 beta were used for these tests which I am using for the two Diamonds reference 7970's that are on loan to me right now and they are working fine. Uninstalled by using the full AMD uninstall utility. Still didn't work. Formatted the drives re-installed windows and still the same results.
post #4 of 65
Update your mobo's bios.
PSU?
Workstation
(4 items)
 
  
CPUMotherboardGraphicsMonitor
Xeon E5-2690 Supermicro 2011 Nvidia GP100/ Vega FE Dell ultrasharp 4k 
  hide details  
Reply
Workstation
(4 items)
 
  
CPUMotherboardGraphicsMonitor
Xeon E5-2690 Supermicro 2011 Nvidia GP100/ Vega FE Dell ultrasharp 4k 
  hide details  
Reply
post #5 of 65
Thread Starter 
Brand new Mobo as well since I thought that would be a problem. Corsair hx850. Plenty of power
post #6 of 65
Can you post your system?Its easier for us when we know cpu,mobo, etc etc
Workstation
(4 items)
 
  
CPUMotherboardGraphicsMonitor
Xeon E5-2690 Supermicro 2011 Nvidia GP100/ Vega FE Dell ultrasharp 4k 
  hide details  
Reply
Workstation
(4 items)
 
  
CPUMotherboardGraphicsMonitor
Xeon E5-2690 Supermicro 2011 Nvidia GP100/ Vega FE Dell ultrasharp 4k 
  hide details  
Reply
post #7 of 65
Thread Starter 
Mobo-Intel DX79SI
CPU-3820 Core i7
RAM-16gb Corsair Vengeance 1600
SSD and HDD
PSU-HX850
post #8 of 65
Thread Starter 
The thing I find odd is the reference cards work but these XFX don't?
post #9 of 65
Do you have the latest BIOS?




I would also try drivers 13.1 WHQL

Looks like you're having bad luck.
Edited by KaRLiToS - 3/4/13 at 3:09pm
Quad Damage
(24 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 4930k @ 4.6Ghz Asus Rampage IV Extreme (Koolance Full WB) 2 x GTX 1080ti FE in SLI (EK WATERBLOCK) Corsair Dominator GT 2133 MHz (16GB) 
Hard DriveHard DriveHard DriveHard Drive
3 TB Seagate OCZ Vertex 4 256GB Crucial M4 128GB ADATA SX900 128GB 
CoolingCoolingCoolingCooling
RIVE Koolance Waterblock (VRM and PCH) Feser X-Changer 360 Feser X-Changer 240 Feser X-Changer 480 
CoolingCoolingCoolingOS
WaterCool MoRA3 Pro with Gentle Typhoon 3 x MCP 655 pumps (With EK top...all serial) 2 x EK FC 1080ti Blocks Windows 7 Ultimate x64 
MonitorMonitorKeyboardPower
Asus ROG Swift PG348Q (3440x1440 @100hz) CrossOver 27Q Led-P Logitech G15 EVGA SuperNova 1600T2 (Titanium) 
CaseMouseMouse PadAudio
Corsair Obsidian Heavily Modded Logitech G700 RocketFish Speed/Control M-audio AV-40 (Logitech G-35) 
  hide details  
Reply
Quad Damage
(24 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 4930k @ 4.6Ghz Asus Rampage IV Extreme (Koolance Full WB) 2 x GTX 1080ti FE in SLI (EK WATERBLOCK) Corsair Dominator GT 2133 MHz (16GB) 
Hard DriveHard DriveHard DriveHard Drive
3 TB Seagate OCZ Vertex 4 256GB Crucial M4 128GB ADATA SX900 128GB 
CoolingCoolingCoolingCooling
RIVE Koolance Waterblock (VRM and PCH) Feser X-Changer 360 Feser X-Changer 240 Feser X-Changer 480 
CoolingCoolingCoolingOS
WaterCool MoRA3 Pro with Gentle Typhoon 3 x MCP 655 pumps (With EK top...all serial) 2 x EK FC 1080ti Blocks Windows 7 Ultimate x64 
MonitorMonitorKeyboardPower
Asus ROG Swift PG348Q (3440x1440 @100hz) CrossOver 27Q Led-P Logitech G15 EVGA SuperNova 1600T2 (Titanium) 
CaseMouseMouse PadAudio
Corsair Obsidian Heavily Modded Logitech G700 RocketFish Speed/Control M-audio AV-40 (Logitech G-35) 
  hide details  
Reply
post #10 of 65
All three cards made problems in another system?
Not bad
(8 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K @ Stock Gigabyte GA-Z77-D3H Galaxy GTX 660 Ti 2 GB GC 8 GB Kingston DDR3 1600 MHz 
Hard DriveMonitorPowerCase
Seagate Barracuda 2 TB Samsung SyncMaster T23A350 1080p HEC Cougar CMX 700W V2 Cougar Volant Black 
  hide details  
Reply
Not bad
(8 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K @ Stock Gigabyte GA-Z77-D3H Galaxy GTX 660 Ti 2 GB GC 8 GB Kingston DDR3 1600 MHz 
Hard DriveMonitorPowerCase
Seagate Barracuda 2 TB Samsung SyncMaster T23A350 1080p HEC Cougar CMX 700W V2 Cougar Volant Black 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Can it be that three 7970's in a row are defective????