Overclock.net › Forums › Cooling › Water Cooling › Swiftech H220/H320/H220X/H240X/H140X and CM Glacer 240L/360L Owners' Club
New Posts  All Forums:Forum Nav:

Swiftech H220/H320/H220X/H240X/H140X and CM Glacer 240L/360L Owners' Club - Page 219

post #2181 of 20784
Quote:
Originally Posted by Inacoma79 View Post


Got my kit mounted in the front, absolutely no issues after 5-weeks, but I only run my system about 4-6 hours a day. Perhaps I'm on borrowed time, but have had a phenomenal unit and still getting awesome temps and no sounds at all. Just a whirring from the pump 1-2 seconds on start up.

I'll post as soon a something noticeable happens...which I hope won't be anytime soon tongue.gif

and all this chatter about GPU loops makes my wallet itch... LOL

Thanks! great help! Nice build btw, I can't wait.biggrin.gif
post #2182 of 20784
Quote:
Originally Posted by Silvaire View Post

I noticed that people were mentioning potential issues with having the radiator front-mounted because of it being below the pump in terms of some kind of air issue. I had planned to purchase the H220 for a Define R4 with both HDD cages removed and mounted in the front. Is this still feasible or not recommended? I have no experience with water cooling and am leery about jumping in without clear guidance that front-mounting to this case will work without too much detective work on my part.

This is how I have mine installed no issues thus far.

post #2183 of 20784
There will be a 360 Rad version that coming soon? hm... maybe i should just wait for that.
My system
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 5820K 6core Asus X99-A Asus GTX 970 4x4 16g DDR4 
Hard DriveOptical DriveCoolingOS
2 x WD 500Gb Caviar Black Raid 0 LG DVD Burner Swiftech H240X Windows 10 64bit 
MonitorKeyboardPowerCase
Dell 30" U3014 Monitor Logitech G910 Enermax Galaxy DXX 850W NZXT Switch 810 
MouseMouse Pad
Logitech G502 Roccat Sense 
  hide details  
Reply
My system
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 5820K 6core Asus X99-A Asus GTX 970 4x4 16g DDR4 
Hard DriveOptical DriveCoolingOS
2 x WD 500Gb Caviar Black Raid 0 LG DVD Burner Swiftech H240X Windows 10 64bit 
MonitorKeyboardPowerCase
Dell 30" U3014 Monitor Logitech G910 Enermax Galaxy DXX 850W NZXT Switch 810 
MouseMouse Pad
Logitech G502 Roccat Sense 
  hide details  
Reply
post #2184 of 20784
Question for the Swiftech crew....I have my pump and fans on the splitter and running off my mobo, a Z77 Saberthooth, and its running @1700-1800 no matter what settings I use in the Bios. It will get up to about 2300 when running IBT and if I disable the settings in the bios it runs at full speed and that I understand. Thing is I cant seem to get it to run any lower, like say 1000-1200 or so.
Does this sound normal for this splitter? Please advise thumb.gif
Nav's Intel
(14 items)
 
Nav Platform
(13 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X6 1090T BE @ 4.0 GHz/1.39v} Asus Crosshair IV Formula MSI 7870 Twin Frozer III Crossfire 16gb Gskill Ripjaws X-1600{9-9-9-24} 
Hard DriveOSMonitorKeyboard
WD 1TB Black/750GB Black Windows 7 64bit Pro ASUS 23.6/1920X1080 Razer 
PowerCaseMouse
Seasonic x750gold Lian Li Lancool PC-K63 Razer Death Adder 
  hide details  
Reply
Nav's Intel
(14 items)
 
Nav Platform
(13 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X6 1090T BE @ 4.0 GHz/1.39v} Asus Crosshair IV Formula MSI 7870 Twin Frozer III Crossfire 16gb Gskill Ripjaws X-1600{9-9-9-24} 
Hard DriveOSMonitorKeyboard
WD 1TB Black/750GB Black Windows 7 64bit Pro ASUS 23.6/1920X1080 Razer 
PowerCaseMouse
Seasonic x750gold Lian Li Lancool PC-K63 Razer Death Adder 
  hide details  
Reply
post #2185 of 20784
Quote:
Originally Posted by jincuteguy View Post

There will be a 360 Rad version that coming soon? hm... maybe i should just wait for that.

It's the H320 if I'm not mistaken that everyone's been mentioning and that BramSLI1 has addressed previously.

I'm thinking it would be pretty nice for Swiftech to sell the block/pump combo by itself for under $100, they'll have plenty of buyers I reckon.
Kaga (WIP)
(22 items)
 
   
GraphicsRAMMonitorPower
1080Ti x2 32GB Corsair Dominator Platinum 2666 (64GB Total) Acer Predator X34P or Equivalent Seasonic Snow Silent - 1050w 
OtherOtherOther
Custom Acrylic Engraving Straight 8 Pin cables + Cable Combs 3x EK-Vardar F2, 2x Replacement Front 140mm 
  hide details  
Reply
Kaga (WIP)
(22 items)
 
   
GraphicsRAMMonitorPower
1080Ti x2 32GB Corsair Dominator Platinum 2666 (64GB Total) Acer Predator X34P or Equivalent Seasonic Snow Silent - 1050w 
OtherOtherOther
Custom Acrylic Engraving Straight 8 Pin cables + Cable Combs 3x EK-Vardar F2, 2x Replacement Front 140mm 
  hide details  
Reply
post #2186 of 20784
Quote:
Originally Posted by navit View Post

Question for the Swiftech crew....I have my pump and fans on the splitter and running off my mobo, a Z77 Saberthooth, and its running @1700-1800 no matter what settings I use in the Bios. It will get up to about 2300 when running IBT and if I disable the settings in the bios it runs at full speed and that I understand. Thing is I cant seem to get it to run any lower, like say 1000-1200 or so.
Does this sound normal for this splitter? Please advise thumb.gif

Pump min is 1300 I believe, and what are your temps when running IBT? It maybe that it is just not getting hot enough to increase the full 3000 rpms.
post #2187 of 20784
Quote:
Originally Posted by justanoldman View Post

In two separate H220 stock rads one of the swivel fitting developed a slow, small leak. I know these are fragile and you have to very careful when taking tubing off or putting it on so I was extra careful when handling them.

Anyone else come across this issue?

You gotta be kidding me!!!!!!redface.gif
 
Blue Ice
(11 items)
 
 
CPUGraphicsHard Drive
3610QM GT 630M Crucial M4 
CPUMotherboardGraphicsRAM
i7 920 Asus Gigbyte 7950 3x2GB OCZ 
Hard DriveCoolingMonitorKeyboard
Seagate prolimatech megahalems HP 24" Razor 
PowerCaseMouse
Antec 650 Earth Watts Corsair Graphite Series 600T Special Edition WHITE Razor 
  hide details  
Reply
 
Blue Ice
(11 items)
 
 
CPUGraphicsHard Drive
3610QM GT 630M Crucial M4 
CPUMotherboardGraphicsRAM
i7 920 Asus Gigbyte 7950 3x2GB OCZ 
Hard DriveCoolingMonitorKeyboard
Seagate prolimatech megahalems HP 24" Razor 
PowerCaseMouse
Antec 650 Earth Watts Corsair Graphite Series 600T Special Edition WHITE Razor 
  hide details  
Reply
post #2188 of 20784
Dang I didn't know Swiftech located in Long beach, CA. Im in San diego about 1h drive away.
My system
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 5820K 6core Asus X99-A Asus GTX 970 4x4 16g DDR4 
Hard DriveOptical DriveCoolingOS
2 x WD 500Gb Caviar Black Raid 0 LG DVD Burner Swiftech H240X Windows 10 64bit 
MonitorKeyboardPowerCase
Dell 30" U3014 Monitor Logitech G910 Enermax Galaxy DXX 850W NZXT Switch 810 
MouseMouse Pad
Logitech G502 Roccat Sense 
  hide details  
Reply
My system
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 5820K 6core Asus X99-A Asus GTX 970 4x4 16g DDR4 
Hard DriveOptical DriveCoolingOS
2 x WD 500Gb Caviar Black Raid 0 LG DVD Burner Swiftech H240X Windows 10 64bit 
MonitorKeyboardPowerCase
Dell 30" U3014 Monitor Logitech G910 Enermax Galaxy DXX 850W NZXT Switch 810 
MouseMouse Pad
Logitech G502 Roccat Sense 
  hide details  
Reply
post #2189 of 20784
Not able to upload the pictures atm, but it looks like the HAF XM is a no go for the H220. Mounting the radiator inside is not possible due to the 8 pin power connector on my UD5H, regardless of which way the radiator faces. The rear 140mm fan is also an issue if the hoses are towards the back, but replacing it with a 120mm would solve that small issue. Due to the design of the case you can only mount the radiator with the hoses facing towards the back of the case, if you want the fill port facing upwards.



The fill caps on this radiator are where the H220 fill cap comes up, and as you can see, there's no matching opening on the other end of the case. So even if I mount it outside facing downwards, there's no place for the hoses to go. If I mount it outside facing up, the extra height from the fill cap itself prevents the top from being able to be put back on.

Was wanting a new case anyway, but had really hoped this would work.
Edited by Skullwipe - 4/29/13 at 5:47pm
post #2190 of 20784
Quote:
Originally Posted by colforbin View Post

Pump min is 1300 I believe, and what are your temps when running IBT? It maybe that it is just not getting hot enough to increase the full 3000 rpms.
Oh I thought it was 1200, ok. My temps are just fine on IBT, hottest core today has been 74c with the pump getting up to 2300 or so.
I am just cant seem to get it below 1700 atm.
Nav's Intel
(14 items)
 
Nav Platform
(13 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X6 1090T BE @ 4.0 GHz/1.39v} Asus Crosshair IV Formula MSI 7870 Twin Frozer III Crossfire 16gb Gskill Ripjaws X-1600{9-9-9-24} 
Hard DriveOSMonitorKeyboard
WD 1TB Black/750GB Black Windows 7 64bit Pro ASUS 23.6/1920X1080 Razer 
PowerCaseMouse
Seasonic x750gold Lian Li Lancool PC-K63 Razer Death Adder 
  hide details  
Reply
Nav's Intel
(14 items)
 
Nav Platform
(13 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X6 1090T BE @ 4.0 GHz/1.39v} Asus Crosshair IV Formula MSI 7870 Twin Frozer III Crossfire 16gb Gskill Ripjaws X-1600{9-9-9-24} 
Hard DriveOSMonitorKeyboard
WD 1TB Black/750GB Black Windows 7 64bit Pro ASUS 23.6/1920X1080 Razer 
PowerCaseMouse
Seasonic x750gold Lian Li Lancool PC-K63 Razer Death Adder 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › Swiftech H220/H320/H220X/H240X/H140X and CM Glacer 240L/360L Owners' Club