Overclock.net › Forums › Cooling › Water Cooling › Swiftech H220/H320/H220X/H240X/H140X and CM Glacer 240L/360L Owners' Club
New Posts  All Forums:Forum Nav:

Swiftech H220/H320/H220X/H240X/H140X and CM Glacer 240L/360L Owners' Club - Page 818

post #8171 of 20720
Quote:
Originally Posted by timnswede View Post

I was more worried about the sound of the stock fans. I believe it is the same fan as the one on my 212 evo, and that thing gets rather loud at full speed. I do have three Cougar CF-V12HB fans laying around, but I couldn't find much info about people using them on radiators. Plus this is my first time water cooling so all I really know is that I need/want fans with high static pressure.

It's definitely loud at full rpm, but you don't really need to spin them at more than 1000rpm really.
post #8172 of 20720
Quote:
Originally Posted by criskoe View Post

Seeing threads like " MY PUMP DIED AGAIN " on the swiftech forum keeps making me hesitant. And it has caused me to never fully submit my order but i constantly find it in my shopping cart.

I do notice that the product support seems to be top notch tho.

Heres the thing, I use my PC allot and I just dont want down times and lengthy RMA procedures, and shipping costs. ect. ect. And most importantly I dont want to regret the buy.

Id like to get a H320 and i plan to use it stock and unmodified for its life. Am i crazy to expect a maintenance free unit for the duration of its warranty? Or am i just dreaming? Is this possible with this unit? IS there anything I should be aware of this unit that isnt said on the website? Id really like to be able to just put it in my system and forget about it.

My current H100 has done me well over the last 2 years and havent had any issues. Can I expect the same from this product?

Can anyone say its been in their system untouched for as long as these things have been out? I realize that support forums generally are people with issues seeking help and usually definitely out number people that come to just say nice things about a product. So I thought the best place to ask would be the Owners Thread here smile.gif

Thanks for any feed back

i have had the h320 in my system since it was available in the uk--probably 5 or 6 months now

never had to touch it once and never had a single issue with it even though i mounted it vertically rather than horizontally

upgraded from an h80 and dont regret it for a second smile.gif
post #8173 of 20720
Received my H320 today! I'm holding off until this weekend to install it.

Side Piece
(13 items)
 
  
CPUMotherboardGraphicsRAM
core i7 5820k MSI x99s gaming 7 EVGA GTX 1080 PNY 
Hard DriveOptical DriveCoolingOS
Samsung 850 evo 500gb asus dvd/cd rw Cryorig R1 Ultimate Windows 8.1 64 bit 
MonitorKeyboardPowerCase
dell s2716dg logitech  Evga 750 G2 haf x 
Mouse
logitech G502 
  hide details  
Reply
Side Piece
(13 items)
 
  
CPUMotherboardGraphicsRAM
core i7 5820k MSI x99s gaming 7 EVGA GTX 1080 PNY 
Hard DriveOptical DriveCoolingOS
Samsung 850 evo 500gb asus dvd/cd rw Cryorig R1 Ultimate Windows 8.1 64 bit 
MonitorKeyboardPowerCase
dell s2716dg logitech  Evga 750 G2 haf x 
Mouse
logitech G502 
  hide details  
Reply
post #8174 of 20720
Add me to the list. Here is my h220 in my Air 540. I hear some water sloshing with the pump at high rpms. Not sure if it is normal or if it needs to be bled any. Here is a pic!

post #8175 of 20720
Hello guys.... After 6 months of use my H220 manifests a strange and annoying problem.

I have a 4770k OC at 4.6 frequency. The fan speed in the bios I've always held to the highest...and never any problem: the H220 it was quiet enough.

Now, suddenly, without having touched nothing: the H220 makes a loud noise as soon as the PC starts: this buzz disappears only after you have started a CPU-stress test: then when the rpm of the H220 increase.

Any help?

Thanks.
post #8176 of 20720
biggest scare of the month. temps started climbing, but CPU fan was still giving an RPM. manually shut down at 90 degrees. turns out that there was a large air bubble in the pump. promptly fixed it, back at 20.(I noticed that i tried to get a tiny bubble from my res to my pump, it wouldn't suck it up, but the unit still was making noise and a rpm still existed, so something was goingup)
Obligatory Build
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Asus P8Z77-M Pro Sapphire Reference 290 w/ Aquacomputer Kryogeni... Samsung Low Voltage 
Hard DriveHard DriveCoolingMonitor
Western Digital Caviar Blue PNY XLR8 Swiftech H220 + Swiftech 120mm Rad Acer P216HL Black 
KeyboardPowerCaseMouse
Ducky Legend Rosewill Hive 550w Silverstone PS07B-W Mionix Avior 7000 
Mouse Pad
Custom Artscow Mousepad 
  hide details  
Reply
Obligatory Build
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Asus P8Z77-M Pro Sapphire Reference 290 w/ Aquacomputer Kryogeni... Samsung Low Voltage 
Hard DriveHard DriveCoolingMonitor
Western Digital Caviar Blue PNY XLR8 Swiftech H220 + Swiftech 120mm Rad Acer P216HL Black 
KeyboardPowerCaseMouse
Ducky Legend Rosewill Hive 550w Silverstone PS07B-W Mionix Avior 7000 
Mouse Pad
Custom Artscow Mousepad 
  hide details  
Reply
post #8177 of 20720
Can I run a second pump if my main pump is down and just use the block as a cpu block?
post #8178 of 20720
Quote:
Originally Posted by ivanlabrie View Post

Can I run a second pump if my main pump is down and just use the block as a cpu block?

Yes, that shouldn't be an issue. What pump are you planning to use so that I can assist you with setting it up?
post #8179 of 20720
Big changes coming for my rig!

New 29" ultra-wide monitor, running off my new R9 270X....

New 4770K w/ my 240L block / pump and custom setup, acrylic tubing, and RAM block coming!

My S3 (Surf-N-Turf / The Unknown Soldier) will be getting a facelift!!!




Thanks - T
post #8180 of 20720
Quote:
Originally Posted by BramSLI1 View Post

Yes, that shouldn't be an issue. What pump are you planning to use so that I can assist you with setting it up?

mcp655 and a dedicated reservoir.

Think I should just remove the impeller from my pump?
Quote:
Originally Posted by Thrasher1016 View Post

Big changes coming for my rig!

New 29" ultra-wide monitor, running off my new R9 270X....

New 4770K w/ my 240L block / pump and custom setup, acrylic tubing, and RAM block coming!

My S3 (Surf-N-Turf / The Unknown Soldier) will be getting a facelift!!!




Thanks - T

Very nice, but change that gpu tongue.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › Swiftech H220/H320/H220X/H240X/H140X and CM Glacer 240L/360L Owners' Club