Overclock.net › Forums › Graphics Cards › AMD/ATI › AMD Drivers causing flickering and artifacts! Help!
New Posts  All Forums:Forum Nav:

AMD Drivers causing flickering and artifacts! Help!

post #1 of 12
Thread Starter 
I have a Radeon 7850 and just today whenever I start my PC I get artifacts and screen flickering.

I uninstalled the beta drivers 13.2 and everything went back to normal.

Now whenever I install any drivers I get the same problem...artifacts and screen flickering! Can someone please help me?! So far I tried 13.2 beta drivers and 13.1 and both give me problems.
FIRST BUILD
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k MSI Z77A-G45 HIS Radeon 7850 2GB Corsair XMS3 8GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force 3 Seagate 250GB 7,200 RPM Western Digital 1TB 7,200 RPM Asus 24x 
CoolingCoolingOSMonitor
Arctic Accelero Xtreme for GPU Stock Windows 8 Viewsonic 22" 1920x1080 
PowerCaseMouse
Antec EarthWatts EA650 650w Thermaltake V3 Microsoft Sidewinder x5 
  hide details  
Reply
FIRST BUILD
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k MSI Z77A-G45 HIS Radeon 7850 2GB Corsair XMS3 8GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force 3 Seagate 250GB 7,200 RPM Western Digital 1TB 7,200 RPM Asus 24x 
CoolingCoolingOSMonitor
Arctic Accelero Xtreme for GPU Stock Windows 8 Viewsonic 22" 1920x1080 
PowerCaseMouse
Antec EarthWatts EA650 650w Thermaltake V3 Microsoft Sidewinder x5 
  hide details  
Reply
post #2 of 12
Can you please elaborate what is your exact system config? I also got flickering with the 13.2 beta 7 but no problems with any other driver. Maybe its the beta driver?
post #3 of 12
Thread Starter 
Quote:
Originally Posted by davidm71 View Post

Can you please elaborate what is your exact system config? I also got flickering with the 13.2 beta 7 but no problems with any other driver. Maybe its the beta driver?

i5 3570k
MSI z77a-g45
HIS Radeon 7850 2GB
Antec 650w power supply
12gb ram

I've used both Catalyst 13.2 beta and 13.1 and get problems. When I uninstall the drivers I get no problems. I checked GPU-z without drivers and my speeds are different..so I think the problems lies with idle speeds.
FIRST BUILD
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k MSI Z77A-G45 HIS Radeon 7850 2GB Corsair XMS3 8GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force 3 Seagate 250GB 7,200 RPM Western Digital 1TB 7,200 RPM Asus 24x 
CoolingCoolingOSMonitor
Arctic Accelero Xtreme for GPU Stock Windows 8 Viewsonic 22" 1920x1080 
PowerCaseMouse
Antec EarthWatts EA650 650w Thermaltake V3 Microsoft Sidewinder x5 
  hide details  
Reply
FIRST BUILD
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k MSI Z77A-G45 HIS Radeon 7850 2GB Corsair XMS3 8GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force 3 Seagate 250GB 7,200 RPM Western Digital 1TB 7,200 RPM Asus 24x 
CoolingCoolingOSMonitor
Arctic Accelero Xtreme for GPU Stock Windows 8 Viewsonic 22" 1920x1080 
PowerCaseMouse
Antec EarthWatts EA650 650w Thermaltake V3 Microsoft Sidewinder x5 
  hide details  
Reply
post #4 of 12
Thread Starter 
Ok problem just got weirder.

MY screen flickers when in desktop, but only artifacts when in Windows 8 Start screen.
FIRST BUILD
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k MSI Z77A-G45 HIS Radeon 7850 2GB Corsair XMS3 8GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force 3 Seagate 250GB 7,200 RPM Western Digital 1TB 7,200 RPM Asus 24x 
CoolingCoolingOSMonitor
Arctic Accelero Xtreme for GPU Stock Windows 8 Viewsonic 22" 1920x1080 
PowerCaseMouse
Antec EarthWatts EA650 650w Thermaltake V3 Microsoft Sidewinder x5 
  hide details  
Reply
FIRST BUILD
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k MSI Z77A-G45 HIS Radeon 7850 2GB Corsair XMS3 8GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force 3 Seagate 250GB 7,200 RPM Western Digital 1TB 7,200 RPM Asus 24x 
CoolingCoolingOSMonitor
Arctic Accelero Xtreme for GPU Stock Windows 8 Viewsonic 22" 1920x1080 
PowerCaseMouse
Antec EarthWatts EA650 650w Thermaltake V3 Microsoft Sidewinder x5 
  hide details  
Reply
post #5 of 12
Try a different cable, hdmi connection as opposed to dvi? Did you try a clean install? Install your monitor drivers?
post #6 of 12
Thread Starter 
Quote:
Originally Posted by davidm71 View Post

Try a different cable, hdmi connection as opposed to dvi? Did you try a clean install? Install your monitor drivers?

tried cable. tried monitor drivers. i will try clean install soon. I'm in safe mode right now and everything is perfect.
FIRST BUILD
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k MSI Z77A-G45 HIS Radeon 7850 2GB Corsair XMS3 8GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force 3 Seagate 250GB 7,200 RPM Western Digital 1TB 7,200 RPM Asus 24x 
CoolingCoolingOSMonitor
Arctic Accelero Xtreme for GPU Stock Windows 8 Viewsonic 22" 1920x1080 
PowerCaseMouse
Antec EarthWatts EA650 650w Thermaltake V3 Microsoft Sidewinder x5 
  hide details  
Reply
FIRST BUILD
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k MSI Z77A-G45 HIS Radeon 7850 2GB Corsair XMS3 8GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force 3 Seagate 250GB 7,200 RPM Western Digital 1TB 7,200 RPM Asus 24x 
CoolingCoolingOSMonitor
Arctic Accelero Xtreme for GPU Stock Windows 8 Viewsonic 22" 1920x1080 
PowerCaseMouse
Antec EarthWatts EA650 650w Thermaltake V3 Microsoft Sidewinder x5 
  hide details  
Reply
post #7 of 12
Thread Starter 
is there a way i can change my 2d clocks from safe mode??
FIRST BUILD
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k MSI Z77A-G45 HIS Radeon 7850 2GB Corsair XMS3 8GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force 3 Seagate 250GB 7,200 RPM Western Digital 1TB 7,200 RPM Asus 24x 
CoolingCoolingOSMonitor
Arctic Accelero Xtreme for GPU Stock Windows 8 Viewsonic 22" 1920x1080 
PowerCaseMouse
Antec EarthWatts EA650 650w Thermaltake V3 Microsoft Sidewinder x5 
  hide details  
Reply
FIRST BUILD
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k MSI Z77A-G45 HIS Radeon 7850 2GB Corsair XMS3 8GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force 3 Seagate 250GB 7,200 RPM Western Digital 1TB 7,200 RPM Asus 24x 
CoolingCoolingOSMonitor
Arctic Accelero Xtreme for GPU Stock Windows 8 Viewsonic 22" 1920x1080 
PowerCaseMouse
Antec EarthWatts EA650 650w Thermaltake V3 Microsoft Sidewinder x5 
  hide details  
Reply
post #8 of 12
Install the 12.11 and see if the issue persists.
post #9 of 12
Thread Starter 
IM SO SORRY

MY CABLE WASN'T COMPLETELY PLUGGED INTO THE MONITOR!

problem is solved now
FIRST BUILD
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k MSI Z77A-G45 HIS Radeon 7850 2GB Corsair XMS3 8GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force 3 Seagate 250GB 7,200 RPM Western Digital 1TB 7,200 RPM Asus 24x 
CoolingCoolingOSMonitor
Arctic Accelero Xtreme for GPU Stock Windows 8 Viewsonic 22" 1920x1080 
PowerCaseMouse
Antec EarthWatts EA650 650w Thermaltake V3 Microsoft Sidewinder x5 
  hide details  
Reply
FIRST BUILD
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570k MSI Z77A-G45 HIS Radeon 7850 2GB Corsair XMS3 8GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force 3 Seagate 250GB 7,200 RPM Western Digital 1TB 7,200 RPM Asus 24x 
CoolingCoolingOSMonitor
Arctic Accelero Xtreme for GPU Stock Windows 8 Viewsonic 22" 1920x1080 
PowerCaseMouse
Antec EarthWatts EA650 650w Thermaltake V3 Microsoft Sidewinder x5 
  hide details  
Reply
post #10 of 12
Quote:
Originally Posted by xerb View Post

IM SO SORRY

MY CABLE WASN'T COMPLETELY PLUGGED INTO THE MONITOR!

problem is solved now

Score!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › AMD Drivers causing flickering and artifacts! Help!