Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Cannot get StorAHCI enabled in Win8, Samsung 840 Pro
New Posts  All Forums:Forum Nav:

Cannot get StorAHCI enabled in Win8, Samsung 840 Pro - Page 2

post #11 of 14
Thread Starter 
Just reinstalled....it doesn't want anything to do with AHCI it seems. BIOS is blatently in AHCI mode...what is going on.
Unlawful
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon II X4 620 ASUS M4A785G-M EVO XFX ATI HD4650 4GB G.Skill Ripjaws DDR3 1333 
Hard DriveHard DriveHard DriveOS
Samsung 830 Seagate Barracude 7200.12 Samsung F3 1TB Windows 7 Home x64 
PowerCase
Seasonic M12-II 430W Modular Cooler Master Elite 332 
  hide details  
Reply
Unlawful
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon II X4 620 ASUS M4A785G-M EVO XFX ATI HD4650 4GB G.Skill Ripjaws DDR3 1333 
Hard DriveHard DriveHard DriveOS
Samsung 830 Seagate Barracude 7200.12 Samsung F3 1TB Windows 7 Home x64 
PowerCase
Seasonic M12-II 430W Modular Cooler Master Elite 332 
  hide details  
Reply
post #12 of 14
Thread Starter 
Weird thing happened...I switched around the SATA cables and by some magic, the SSD is now in AHCI mode, though I'm 99.99% sure all of the sata ports are on the same controller and that it shouldn't matter which port a drive is connected to.

Weird...
Unlawful
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon II X4 620 ASUS M4A785G-M EVO XFX ATI HD4650 4GB G.Skill Ripjaws DDR3 1333 
Hard DriveHard DriveHard DriveOS
Samsung 830 Seagate Barracude 7200.12 Samsung F3 1TB Windows 7 Home x64 
PowerCase
Seasonic M12-II 430W Modular Cooler Master Elite 332 
  hide details  
Reply
Unlawful
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon II X4 620 ASUS M4A785G-M EVO XFX ATI HD4650 4GB G.Skill Ripjaws DDR3 1333 
Hard DriveHard DriveHard DriveOS
Samsung 830 Seagate Barracude 7200.12 Samsung F3 1TB Windows 7 Home x64 
PowerCase
Seasonic M12-II 430W Modular Cooler Master Elite 332 
  hide details  
Reply
post #13 of 14
You have a third party controller or else it wouldn't have done that. And the setting for that controller is somewhere else in the BIOS.

Or, most likely, I heard that if you set the first 1-4 ports to AHCI the others will default to IDE with some AMD mobos.
post #14 of 14
His brother's board is an ASRock FM2A85X Extreme4-M, and it only has the AMD SATA controller. So it could be as Sean said, only some of the SATA ports are in AHCI mode.

Or the cold start after the SSD was moved to a different port, combined with a registry change finally got the AHCI driver loaded, although we don't know which one is being used.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: SSD
Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Cannot get StorAHCI enabled in Win8, Samsung 840 Pro