Overclock.net › Forums › Graphics Cards › Graphics Cards - General › My experience with MSI RMA.
New Posts  All Forums:Forum Nav:

My experience with MSI RMA.

post #1 of 2
Thread Starter 
I noticed a lot of people write about their RMA experience so here's mine.

AMD 7870 1GHz edition had a problem. White lines, and blue lines and what not. I went on their website and submitted an RMA form. The next day I received the conformation and had the card shipped it the same day (Feb 28). The card got delivered on a Saturday (Mar 2) but they were closed to it had to be redelivered on Monday. It wasn't until Friday (8th) that it got scanned in their system, and I received an email telling me they did a day after. On the 12th they shipped something out. Neither the email or the online tracking told me what. For all I know it could be my card that was rejected.Anyway, I received a the same model card that's been swapped.

Shipping it to them cost me $10 and they shipped it back via UPS with good packaging except the top of the card wasn't protected with anything except the cardboard box.


Overall a pretty good experience if only they can be a little faster on their feet.
4-year build.
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 @ 4GHz 1.27v (LOAD) EVGA 750i SLI EVGA GTX 460 768MB SC @ 870/1075 G.SKILL PI Black 4GB 4-4-4-12 850MHz 
Hard DriveOSMonitorPower
WD Blue Caviar 320GB Windows 7 x64 DELL SE198WFP ThermalTake TR2 430w 
Case
It's a table!! 
  hide details  
Reply
4-year build.
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 @ 4GHz 1.27v (LOAD) EVGA 750i SLI EVGA GTX 460 768MB SC @ 870/1075 G.SKILL PI Black 4GB 4-4-4-12 850MHz 
Hard DriveOSMonitorPower
WD Blue Caviar 320GB Windows 7 x64 DELL SE198WFP ThermalTake TR2 430w 
Case
It's a table!! 
  hide details  
Reply
post #2 of 2
MSI, worse than the worst I have ever had.
a DKA-790GX, fan-socket not working after 1 year and 359 days as I remember. Sent them a request for RMA.
Two weeks later ( = 2 years and 6 days), they sent me an email said that I needed to pay 35 dollars for processing fee and the labor cost would be informed to me once they received and tested the board. Just WOW!
Another MSI H55 something, I don't remember, dead after over one year, sent for RMA. Warranty voided because of the CPU socket was not included (no bent pin because it was in its original box). another WOW!

3 years for parts, 2 years labor. WOW!

No more MSI for me. It was just too many WOW!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Graphics Cards - General
Overclock.net › Forums › Graphics Cards › Graphics Cards - General › My experience with MSI RMA.