Overclock.net › Forums › Graphics Cards › AMD/ATI › Low framerate and GPU usage? HIS 7850
New Posts  All Forums:Forum Nav:

Low framerate and GPU usage? HIS 7850

post #1 of 6
Thread Starter 
I went out on a limb and decided to try and AMD card, in particular an HIS 7850 2GB model. I've been a faithful NVIDIA since 2005 with my last ATI card being the 128 RAGE tongue.gif

These frame drops happen because GPU usage remains low revealed by Afterburner. Source games, Skyrim, Tomb Raider, GTA IV all dip below 20fps regardless of settings at 1920x1080. Even MSI Kombustor has a hard time staying at 100% usage. I am flabbergasted.

I thought power would be a problem with the 550w Antec but the system draws 110-170 while gaming and 370w under full load.

I read some suggestions that the CPU could be a bottleneck. An FX6300 at 4.2GHz seems like it can handle 1080 high no problem.

13.1 and 13.3 drivers perform the same. Ran Driver Sweeper between installs. One last thing to note I'm running Server 2008 R2. Maybe it's doing something here but I think it shouldn't matter since it's very similar to Windows 7. So I am left thinking that there's some power management feature I haven't discovered or that ATI drivers are buggy.



Also take a look at the bizarre usage from Team Fortress 2.



Tomb Raider. It seems normal but it's on medium/high. Why not 100%?

post #2 of 6
Max your power limit.
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
post #3 of 6
^What he said
post #4 of 6
Thread Starter 
Thanks for the suggestion. It didn't change anything so it should be receiving all the power it can. Does AMD have a powersaving feature somewhere?
post #5 of 6
Thread Starter 
The problem was Server 2008. Installed Windows 7 and everything worked like normal.
post #6 of 6
Quote:
Originally Posted by tsm106 View Post

Max your power limit.

How would one do this? Move the core voltage slider all the way over? Last time I tried that with an old 4850 is started screaming at me... Pretty sure it didn't like it.
Xeno Storm V 1.2
(19 items)
 
RetroPie
(13 items)
 
 
CPUMotherboardGraphicsRAM
ARM Cortex-A7 Raspberry Pi 2 Model B Broadcom VideoCore IV 512MB 
Hard DriveHard DriveCoolingOS
64GB Corsair Voyager Go 16GB Micro SD Aluminum heat spreaders RetroPi 
MonitorKeyboardPowerCase
Samsung 23" LED Logitech Wireless Touch Keyboard K400 Anker 24W PowerPort 2 OneNineDesign RasPi Black 
Other
8Bitdo NES30 Pro Controller 
CPUMotherboardGraphicsRAM
i5 7200U Dell Intel HD 8GB LPDDR3 1866MHz 
Hard DriveOSMonitor
M.2 128GB Windows 10 13.3" FHD AG 
  hide details  
Reply
Xeno Storm V 1.2
(19 items)
 
RetroPie
(13 items)
 
 
CPUMotherboardGraphicsRAM
ARM Cortex-A7 Raspberry Pi 2 Model B Broadcom VideoCore IV 512MB 
Hard DriveHard DriveCoolingOS
64GB Corsair Voyager Go 16GB Micro SD Aluminum heat spreaders RetroPi 
MonitorKeyboardPowerCase
Samsung 23" LED Logitech Wireless Touch Keyboard K400 Anker 24W PowerPort 2 OneNineDesign RasPi Black 
Other
8Bitdo NES30 Pro Controller 
CPUMotherboardGraphicsRAM
i5 7200U Dell Intel HD 8GB LPDDR3 1866MHz 
Hard DriveOSMonitor
M.2 128GB Windows 10 13.3" FHD AG 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Low framerate and GPU usage? HIS 7850