post #1 of 1
Thread Starter 
The rig:
Win7
EVGA 670 FTW (few days old RMA)
EVGA 670 SuperClocked (still haven't send it back)
i5 2500k at 3.7ghz
ASRock z68
OCZ ZX 850w
8 gigs of 1600 G.Skill
500GB WD Green (WD5000AADS)
932 HAF


First, this is my first post, so hello to you all. Second, I'm going to tell my entire story, because I don't know what's relevant and what's not:

It had all begun around two weeks ago when I started seeing huge skyscraper-like artifacts in Farcry 3 and a reduction in performance overall on my 670 (like increased temperatures, spikes in FPS, and crashes). First, I assumed my video card was going, but then I started to monitor CPU temps during full load (and at idle) and found that they were in their 50s even at idle. Okay, so, easy, right? Bought a Hyper 212 Plus and Arctic Ice. Installed/applied both. Temps were then more than perfect. At least CPU temps. My 670 was still having the same problems, but with even more instability. Alright, easy once again, right? RMA'd the card.

Received a 670 FTW three days later (very impressed with that). Installed it. Played Starcraft 2 for a while and everything was perfect. Then, to test my out my new card, I played Farcry 3. Performed much better then the SuperClocked edition. I was happy as ever (my problems were fixed) . . . until I exited the game. As soon I did so, blue squares littered the desktop (what I assume were artifacts), the computer froze, and video signal was lost. Ok. Restarted. Tried again. Same thing happened. Started Battlefield 3, played the game on highest settings with a pretty steady 60 FPS (on 64 Large Conquest), then exited the game. Same thing. As soon as I quit a game, those blue squares showed up, froze, and lost of signal. This didn't happen with Starcraft 2 (maybe because that game didn't stress my video card one bit).

Since I saw that once, before I lost video signal, the video drivers crashed, I used Driver Fusion to clean up a few unwanted files (which ended up being over 25 gigs in size, somehow). Took my 6 hours to get it working again, since the 670 FTW didn't want to show video signal, but I got it working eventually (ty, reddit). Also tried booting from another HD. The problems persisted.

The next day, upon waking and turning my computer on, resolution was first set to 800x480, then switching to 1024x768 right from the start. Additionally, I now had horizontal weird wiggly lines all over the screen, some pink, some yellow (these were in effect even in BIOS). The computer ran a couple of minutes like this (laggy and unresponsive with those lines) until video signal was lost completely. Cool. Restarted the computer. Entered BIOS just for the heck of it. Lines were still present and resolution was ridiculous. Booted up. Lost signal. Restarted computer one more time. No signal. Tried the second PCI-E slot. No signal. Tried the old SuperClocked 670 . . . signal! But, unfortunately, it wasn't being detected. Computer was running on onboard graphics through the 670 hdmi port, but the 670 might as well have not been inserted.

I now can't get either 670 to work even for a second.

I've contacted ASRock about an RMA, but they're taking their sweet time in responding.

Alright, and the next part is sort of a horror story. It might be relevant, and it might not be. The timing sort of fits, though.

I quit smoking 3 weeks ago and moved to smoking EonSmoke (electric cigarettes). I charged the batteries though my computer's USB port since the very beginning. I also have very long hair (it's relevant!) and use a recliner with fabric that "electrifies" my body. So, whenever I needed to charge my ecig, I stood up, walked over to the computer, and switched out the cigs (because one was always charging). The problem was that every time I touched the cig in the USB port, I would shock myself (and the cig) with static electricity. A lot of it. One day, as I did this, my computer restarted upon my touch. That was my eureka moment: "Oh, so I probably shouldn't have been shocking my computer for weeks, half a dozen times a day."

Could this have somehow fried my mobo? I mean, it's working fine now, because I'm not using a video card, so I'm honestly confounded.

Help? Please? Playing SC2 on medium (sort of) is horrific.

And thank you all in advance!

Edit: Forgot to say that both my CPU and first 670 were overclocked, but not in any drastic way. With the 670 FTW, I didn't even have a change to try OCing.
Edited by Protoliterary - 3/18/13 at 1:27pm