Overclock.net › Forums › Graphics Cards › AMD/ATI › Updated with Video: Weird screen glitch (Sapphire 6950). Need some help.
New Posts  All Forums:Forum Nav:

Updated with Video: Weird screen glitch (Sapphire 6950). Need some help.

post #1 of 14
Thread Starter 
UPDATE: Here's a video showing the screen glitch that I'm experiencing. It shows the glitch as well as how I've been managing to fix it. Basically this glitch only occurs if I apply any sort of OC settings in MSI Afterburner



Hi guys,

So today I decided to try my hand at overclocking my GPU. I've been using MSI Afterburner for awhile to record game footage but never actually touched the overclocking stuff. So anyway I went from stock clocks of 800/1250 to a seemingly stable 840/1290. As I was about to push further, I found a thread about unlocking my 6950 and turning it into a 6970 via a BIOS flash. I understood the risks and decided to try it out anyway thinking my card had the dual-BIOS recovery feature as I could see the numbers "1" and "2" on the side of my card.

After several failed attempts with ATI Winflash, I went with ATI flash and a bootable DOS pendrive. The flash was finally successful and verified. I rebooted my rig only to be greeted with this terrible sight:

Restarts didn't fix it. Switching DVI ports didn't fix it. I checked for the dual-BIOS switch, turns it there is none. Those numbers were just some random markings apparently. So at this point I thought I had completely boned myself and bricked the card.

Luckily I had an old GTS 450 lying around so I managed to use that to power my display and re-flash my 6950 with the previous BIOS that I had backed up. I put everything back together and so far it looks like all is well:


So after about an hour of fixing the bad flash, I finally get back to my desktop. I decide to continue doing overclocks. I raise to 860 and hit apply and suddenly there's a torrent of flickers/tears/artifacts. Strange. I run FurMark and all seems normal. Suddenly I tab into Google Chrome and the flickers/tears/artifacts start coming again. I'm not sure how to describe it but basically everything was kinda jumping around and there were random horizontal black lines. It seemed to occur on websites with moving elements or whenever I moused over something.

Perhaps it was the overclock. I go back down to stock clocks, hit apply, but the craziness is still there. So at this point I'm really not sure what to do and randomly decided to fire up 3DMark 11 with my 840/1290 overclock. Funnily enough, the screen craziness stopped. Finished 3DMark-ing and so far all seems good.

What I'm afraid of right now though are two things:

1) Did the BIOS flash do any sort of damage to my 6950 or is it all good?

2) What is that crazy screen tearing/flickering and why did it suddenly stop? How can I prevent that from happening again?

Sorry for the long post but I felt it was necessary to get all the details. Hope I was clear on everything and would definitely appreciate any insight smile.gif
Edited by MobiusLOL - 3/24/13 at 1:59am
post #2 of 14
Quote:
Originally Posted by MobiusLOL View Post

Hi guys,

So today I decided to try my hand at overclocking my GPU. I've been using MSI Afterburner for awhile to record game footage but never actually touched the overclocking stuff. So anyway I went from stock clocks of 800/1250 to a seemingly stable 840/1290. As I was about to push further, I found a thread about unlocking my 6950 and turning it into a 6970 via a BIOS flash. I understood the risks and decided to try it out anyway thinking my card had the dual-BIOS recovery feature as I could see the numbers "1" and "2" on the side of my card.

After several failed attempts with ATI Winflash, I went with ATI flash and a bootable DOS pendrive. The flash was finally successful and verified. I rebooted my rig only to be greeted with this terrible sight: Warning: Spoiler! (Click to show)
Restarts didn't fix it. Switching DVI ports didn't fix it. I checked for the dual-BIOS switch, turns it there is none. Those numbers were just some random markings apparently. So at this point I thought I had completely boned myself and bricked the card.

Luckily I had an old GTS 450 lying around so I managed to use that to power my display and re-flash my 6950 with the previous BIOS that I had backed up. I put everything back together and so far it looks like all is well: Warning: Spoiler! (Click to show)

So after about an hour of fixing the bad flash, I finally get back to my desktop. I decide to continue doing overclocks. I raise to 860 and hit apply and suddenly there's a torrent of flickers/tears/artifacts. Strange. I run FurMark and all seems normal. Suddenly I tab into Google Chrome and the flickers/tears/artifacts start coming again. I'm not sure how to describe it but basically everything was kinda jumping around and there were random horizontal black lines. It seemed to occur on websites with moving elements or whenever I moused over something.

Perhaps it was the overclock. I go back down to stock clocks, hit apply, but the craziness is still there. So at this point I'm really not sure what to do and randomly decided to fire up 3DMark 11 with my 840/1290 overclock. Funnily enough, the screen craziness stopped. Finished 3DMark-ing and so far all seems good.

What I'm afraid of right now though are two things:

1) Did the BIOS flash do any sort of damage to my 6950 or is it all good?

2) What is that crazy screen tearing/flickering and why did it suddenly stop? How can I prevent that from happening again?

Sorry for the long post but I felt it was necessary to get all the details. Hope I was clear on everything and would definitely appreciate any insight smile.gif

As for the artifacts you are getting in chrome maybe the same as firefox since this is what I had the artifacts are caused by hardware acceleration and can be turned off in the settings under options>Advanced>browsing this has just only been added into it so maybe its the same for you in chrome.

As for the mouse thing I think it has to do with the settings under mouse with is the enhanced pointer pecision which you could also give a try as that has happened to me also with 2 screens showing the mouse pointer and one being all crazy.

There should be a switch at the top of your card which has 2 bios settings 1st is flash able, 2nd is a factory reset just incase, running gpu-z and save your 2nd bios and flash the original factory bios 2 onto the 1st profile, other users might be able to help you since this is something I have never done.

Hope I have helped, clint.
The Beast
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 4930k  Asus Rampage IV Black Edition MSI GTX 980 Gskill Ripjaw X 16gb DDR3 2400Mhz 
Hard DriveOptical DriveCoolingOS
Intel 520 240gb SSD, 13Tb Caviar Green/Black Lite-On Bluray Writer Prolimatech Megashadow Win 10 Pro 
MonitorPowerCaseAudio
2x Samsung BX2450 Coolermaster V1000 Corsair Obsidian 800D Asus Xonar D2X, O2/ODAC, HD650 
  hide details  
Reply
The Beast
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 4930k  Asus Rampage IV Black Edition MSI GTX 980 Gskill Ripjaw X 16gb DDR3 2400Mhz 
Hard DriveOptical DriveCoolingOS
Intel 520 240gb SSD, 13Tb Caviar Green/Black Lite-On Bluray Writer Prolimatech Megashadow Win 10 Pro 
MonitorPowerCaseAudio
2x Samsung BX2450 Coolermaster V1000 Corsair Obsidian 800D Asus Xonar D2X, O2/ODAC, HD650 
  hide details  
Reply
post #3 of 14
Your first major screw up was assuming all 6950s are similar. There are many different kinds. The method you seem to have tried, which is a sloppy one in the best case scenario, was almost certainly meant for reference cards. Your card isn't an original reference card if it's missing the BIOS switch.

It's likely that your 6950 cannot be unlocked because the locked shaders are defective. However, it's possible that flashing to 6970 unmasked the shaders, and that reflashing to your original BIOS may not have correctly masked them again.

I would try wiping the card's BIOS completely by flashing a 128k blank file over it, then flash it again with your card's original BIOS. Also, uninstalling and reinstalling drivers may help.

There may be more options in atiflash to try, but I'd have to look them up.
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
post #4 of 14
Thread Starter 
Quote:
Originally Posted by Blameless View Post

Your first major screw up was assuming all 6950s are similar. There are many different kinds. The method you seem to have tried, which is a sloppy one in the best case scenario, was almost certainly meant for reference cards. Your card isn't an original reference card if it's missing the BIOS switch.

It's likely that your 6950 cannot be unlocked because the locked shaders are defective. However, it's possible that flashing to 6970 unmasked the shaders, and that reflashing to your original BIOS may not have correctly masked them again.

I would try wiping the card's BIOS completely by flashing a 128k blank file over it, then flash it again with your card's original BIOS. Also, uninstalling and reinstalling drivers may help.

There may be more options in atiflash to try, but I'd have to look them up.
Yup definitely learnt that the hard way. I'll try reinstalling drivers as soon as possible.

Also as I type this my screen is going completely insane with flashing and random lines/artifacts. It happened just as I hit apply to test a higher overclock.

I'll go reinstall drivers and come back with an update.
post #5 of 14
Quote:
Originally Posted by MobiusLOL View Post

Yup definitely learnt that the hard way. I'll try reinstalling drivers as soon as possible.

Also as I type this my screen is going completely insane with flashing and random lines/artifacts. It happened just as I hit apply to test a higher overclock.

I'll go reinstall drivers and come back with an update.

I would flash it as stated above to see if you have a stable display first before updating drivers and overclocking your 6950.
The Beast
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 4930k  Asus Rampage IV Black Edition MSI GTX 980 Gskill Ripjaw X 16gb DDR3 2400Mhz 
Hard DriveOptical DriveCoolingOS
Intel 520 240gb SSD, 13Tb Caviar Green/Black Lite-On Bluray Writer Prolimatech Megashadow Win 10 Pro 
MonitorPowerCaseAudio
2x Samsung BX2450 Coolermaster V1000 Corsair Obsidian 800D Asus Xonar D2X, O2/ODAC, HD650 
  hide details  
Reply
The Beast
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 4930k  Asus Rampage IV Black Edition MSI GTX 980 Gskill Ripjaw X 16gb DDR3 2400Mhz 
Hard DriveOptical DriveCoolingOS
Intel 520 240gb SSD, 13Tb Caviar Green/Black Lite-On Bluray Writer Prolimatech Megashadow Win 10 Pro 
MonitorPowerCaseAudio
2x Samsung BX2450 Coolermaster V1000 Corsair Obsidian 800D Asus Xonar D2X, O2/ODAC, HD650 
  hide details  
Reply
post #6 of 14
What card do u have exactly? I recently bought a msi 6950 refrence design that unlocked no problem, can u post a pic of the card so we can take a look? Ive managed to hit 950 mhz on the core and 1450 mhz on the memory with my card power settings +20 percent in amd cataltst.i have refrence design card
     
CPUMotherboardGraphicsGraphics
amd fx 6100 asus m5a97 msi radeon 6970 Msi radeon 6970  
RAMHard DriveOptical DriveCooling
corsair vengence BLUE  baracuda seagate 7200 rpm asus sata 24x drw thermaltake contac 30 cpu cooler 
OSMonitorKeyboardPower
windows 7 home premium 64 bit LG 26 inch led 1900x1080 resolution logitech mk 260 coolermaster 750 watt gx bronze 
CaseMouseMouse PadAudio
coolermaster 430 elite logitech mk 260 logitech mk 260 sony reciver hooked up to asus optical port 
OtherOther
2 blue cathode lights and 4 coolmax blue led f... Modright sleeved blue molex to sata x 4  
  hide details  
Reply
     
CPUMotherboardGraphicsGraphics
amd fx 6100 asus m5a97 msi radeon 6970 Msi radeon 6970  
RAMHard DriveOptical DriveCooling
corsair vengence BLUE  baracuda seagate 7200 rpm asus sata 24x drw thermaltake contac 30 cpu cooler 
OSMonitorKeyboardPower
windows 7 home premium 64 bit LG 26 inch led 1900x1080 resolution logitech mk 260 coolermaster 750 watt gx bronze 
CaseMouseMouse PadAudio
coolermaster 430 elite logitech mk 260 logitech mk 260 sony reciver hooked up to asus optical port 
OtherOther
2 blue cathode lights and 4 coolmax blue led f... Modright sleeved blue molex to sata x 4  
  hide details  
Reply
post #7 of 14
Yeah i think those guys are right the flash only seems to work with refrence cards,altough ive seen some non refrence cards unlock as well....i tested before and after the flash and it seems to have picked up quite a bit of fps with shaders unlocked and overckocked,went from 32fps on furmark to 43 fps resolution 1900 x 1080! If u cant unlock just run it at stock settings maybe pick up another for crossfire? Ull stilk have damn good gaming experience!
     
CPUMotherboardGraphicsGraphics
amd fx 6100 asus m5a97 msi radeon 6970 Msi radeon 6970  
RAMHard DriveOptical DriveCooling
corsair vengence BLUE  baracuda seagate 7200 rpm asus sata 24x drw thermaltake contac 30 cpu cooler 
OSMonitorKeyboardPower
windows 7 home premium 64 bit LG 26 inch led 1900x1080 resolution logitech mk 260 coolermaster 750 watt gx bronze 
CaseMouseMouse PadAudio
coolermaster 430 elite logitech mk 260 logitech mk 260 sony reciver hooked up to asus optical port 
OtherOther
2 blue cathode lights and 4 coolmax blue led f... Modright sleeved blue molex to sata x 4  
  hide details  
Reply
     
CPUMotherboardGraphicsGraphics
amd fx 6100 asus m5a97 msi radeon 6970 Msi radeon 6970  
RAMHard DriveOptical DriveCooling
corsair vengence BLUE  baracuda seagate 7200 rpm asus sata 24x drw thermaltake contac 30 cpu cooler 
OSMonitorKeyboardPower
windows 7 home premium 64 bit LG 26 inch led 1900x1080 resolution logitech mk 260 coolermaster 750 watt gx bronze 
CaseMouseMouse PadAudio
coolermaster 430 elite logitech mk 260 logitech mk 260 sony reciver hooked up to asus optical port 
OtherOther
2 blue cathode lights and 4 coolmax blue led f... Modright sleeved blue molex to sata x 4  
  hide details  
Reply
post #8 of 14
Thread Starter 
Quote:
Originally Posted by nz3777 View Post

Yeah i think those guys are right the flash only seems to work with refrence cards,altough ive seen some non refrence cards unlock as well....i tested before and after the flash and it seems to have picked up quite a bit of fps with shaders unlocked and overckocked,went from 32fps on furmark to 43 fps resolution 1900 x 1080! If u cant unlock just run it at stock settings maybe pick up another for crossfire? Ull stilk have damn good gaming experience!

I'm quite sure this is my card. Just reflashed stock BIOS again and the screen issue is still there when I try to OC and raise clocks. One way I've managed to fix it (aside from restart) is to disable and re-enable the GPU via device manager.

As for Crossfire, not really looking to do that since my case is pretty cramped as it is already. If I have some cash to spend I'd probably get a new GPU altogether but I'm hoping to avoid that for now.

Right now my main concern are those screen issues frown.gif
post #9 of 14
Thread Starter 
Just did a couple tests and played a game. Basically screen glitches seem to occur under two circumstances:

1. Overclocking, even just slightly.

2. Desktop browsing. This is the really strange thing. If I have some GPU intensive program open (like a game or whatever), the desktop screen glitches stop. I can tab out and browse normally but the second I close the game, everything starts going haywire again :/

Scratch that. The likelihood of glitching lowers somewhat slightly, but definitely still occurs.

So at this point I'm really not sure what to do. I guess I just can't OC, the failed flash might have something to do with it perhaps.
Edited by MobiusLOL - 3/23/13 at 11:06am
post #10 of 14
Quote:
Originally Posted by MobiusLOL View Post

I'm quite sure this is my card.

That card has a BIOS switch.

Are you sure the PCB on your card is black?
Quote:
Originally Posted by MobiusLOL View Post

Just reflashed stock BIOS again and the screen issue is still there when I try to OC and raise clocks.

Did you wipe the BIOS first?
Quote:
Originally Posted by MobiusLOL View Post

Right now my main concern are those screen issues frown.gif

What are you using to OC the card.
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Updated with Video: Weird screen glitch (Sapphire 6950). Need some help.