Overclock.net › Forums › Cooling › Water Cooling › H100 molex problems
New Posts  All Forums:Forum Nav:

H100 molex problems

post #1 of 4
Thread Starter 


So this is how I got my H100 and I need to get that pin inside and working. I can get it in and connected, but it does not work. I would love to RMA, but then I would have to send it to Netherlands or somewhere stupid like that and I need my computer. Any ideas? Maybe help from a Corsair rep?

Edit: to be more clear that is the power cord from the block, so it gives power to the fans and ?something else?
Ravager
(16 items)
 
  
CPUMotherboardGraphicsRAM
FX 8350 Gigabyte GA-990FXA-UD3 R5 XFX R9 390 DD Black Edition Kingston HyperX Fury  
Hard DriveHard DriveCoolingOS
Crucial BX100  WD Blue Corsair H100i GTX Windows 10 Insider Preview 
MonitorKeyboardPowerCase
AOC G2460PF 24" 144Hz Freesync Steelseries 6Gv2 EVGA Supernova 750 G2 Phanteks Enthoo Pro M 
MouseMouse PadAudioAudio
Logitech G303 Steelseries QcK Heavy Kingston HyperX Cloud ASUS Xonar U5 
  hide details  
Reply
Ravager
(16 items)
 
  
CPUMotherboardGraphicsRAM
FX 8350 Gigabyte GA-990FXA-UD3 R5 XFX R9 390 DD Black Edition Kingston HyperX Fury  
Hard DriveHard DriveCoolingOS
Crucial BX100  WD Blue Corsair H100i GTX Windows 10 Insider Preview 
MonitorKeyboardPowerCase
AOC G2460PF 24" 144Hz Freesync Steelseries 6Gv2 EVGA Supernova 750 G2 Phanteks Enthoo Pro M 
MouseMouse PadAudioAudio
Logitech G303 Steelseries QcK Heavy Kingston HyperX Cloud ASUS Xonar U5 
  hide details  
Reply
post #2 of 4
This connector powers the pump and fans.

Your photo is blurry, but it looks like the wings of the pin are pushed in. The wings need to be out a little bit, like this pic. That's how the pin holds into the connector. Use a knife carefully to slightly pry them out, so that the pin stays in the connector.


Also, the wire should be inserted into the connector in the hole right next to the other wire. Like on this pic:
Lori Lemaris 023
(21 items)
 
Felicity Harmon
(23 items)
 
Moneypenny
(12 items)
 
  hide details  
Reply
Lori Lemaris 023
(21 items)
 
Felicity Harmon
(23 items)
 
Moneypenny
(12 items)
 
  hide details  
Reply
post #3 of 4
Thread Starter 
Thank you for the input, but I already returned it, because I decided that I want a H220 instead biggrin.gif
Ravager
(16 items)
 
  
CPUMotherboardGraphicsRAM
FX 8350 Gigabyte GA-990FXA-UD3 R5 XFX R9 390 DD Black Edition Kingston HyperX Fury  
Hard DriveHard DriveCoolingOS
Crucial BX100  WD Blue Corsair H100i GTX Windows 10 Insider Preview 
MonitorKeyboardPowerCase
AOC G2460PF 24" 144Hz Freesync Steelseries 6Gv2 EVGA Supernova 750 G2 Phanteks Enthoo Pro M 
MouseMouse PadAudioAudio
Logitech G303 Steelseries QcK Heavy Kingston HyperX Cloud ASUS Xonar U5 
  hide details  
Reply
Ravager
(16 items)
 
  
CPUMotherboardGraphicsRAM
FX 8350 Gigabyte GA-990FXA-UD3 R5 XFX R9 390 DD Black Edition Kingston HyperX Fury  
Hard DriveHard DriveCoolingOS
Crucial BX100  WD Blue Corsair H100i GTX Windows 10 Insider Preview 
MonitorKeyboardPowerCase
AOC G2460PF 24" 144Hz Freesync Steelseries 6Gv2 EVGA Supernova 750 G2 Phanteks Enthoo Pro M 
MouseMouse PadAudioAudio
Logitech G303 Steelseries QcK Heavy Kingston HyperX Cloud ASUS Xonar U5 
  hide details  
Reply
post #4 of 4
Keep an eye on that pin and make sure that it does not push out the back of the molex when you insert it in the PSU molex connector. Those little wings on the pin can be slightly pried out to catch to prevent that, if they are pushed in, but they tend to break so go slow. Those pins are also easy to replace and cost only a few bucks for a pack of molex connectors if you have a local computer store near by that carries electrical bits. They are only crimped on the wire by the two left side metal tabs in WiSK's line drawing above. I always keep some extra molex connectors and pins around as this is a common issue but so easy to fix. Also take a look at the molex you are connecting it to. Make sure that the female side is a nice round O with the ends almost touching each other, as in WiSK's line drawing, which is the female side. You could also try a different connector on the PSU wire.

Oh- I see you replaced it after I replied. All the same, it's a good idea to have a pack of molex connectors around just in case. Even with SATA power connectors, molex is still used for pumps and some lights and fans, and some DVD burners.
Edited by tzvia - 3/24/13 at 8:00am
Caseless
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k Asus Maximus V Extreme EVGA 780ti SC ASC G.Skill Trident X 2400 
Hard DriveHard DriveOptical DriveCooling
Muskin MSATA Segate 3tb 7200rpm 32gig cache 2x LG BD Burner XSPC Raystorm RX360kit 
OSMonitorKeyboardPower
Windows 7 Ultimate Samsung 46" 'SmartTV' 240hz Coolermaster CM Storm Corsair 1200i 
CaseMouseMouse PadAudio
Lowes 6ft 5 shelf metal rack with extra shelf. Corsair M65 Corsair metal pad. Logitech with subwoofer or home AV (Polk, Tandb... 
Other
Soundblaster SB-Z 
  hide details  
Reply
Caseless
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k Asus Maximus V Extreme EVGA 780ti SC ASC G.Skill Trident X 2400 
Hard DriveHard DriveOptical DriveCooling
Muskin MSATA Segate 3tb 7200rpm 32gig cache 2x LG BD Burner XSPC Raystorm RX360kit 
OSMonitorKeyboardPower
Windows 7 Ultimate Samsung 46" 'SmartTV' 240hz Coolermaster CM Storm Corsair 1200i 
CaseMouseMouse PadAudio
Lowes 6ft 5 shelf metal rack with extra shelf. Corsair M65 Corsair metal pad. Logitech with subwoofer or home AV (Polk, Tandb... 
Other
Soundblaster SB-Z 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › H100 molex problems