Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › AMD woes and Linux
New Posts  All Forums:Forum Nav:

AMD woes and Linux

post #1 of 8
Thread Starter 
So I've got everything sorted for drivers, I've used the official drivers from the repo and got the beta 13.3 b7 working without a watermark. Everything works ok, it's just that performance is drastically sub-par. Fan control is terrible, unless I manually set it to a high speed it throttles. That's not too bad, I could make a script for that and be fine. The real issue is performance itself, in the Valley benchmark I can get 1600 in windows but only 1000 in linux. Now any help would be appreciated but as far as I can tell, the linux drivers are terrible. Any thoughts?
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #2 of 8
did the last version of the driver get above 1000?
post #3 of 8
Thread Starter 
I could set up the official again, though I didn't do a full run on that. However the FPS was a huge indication that I wouldn't get a high score. If the FPS doesn't start off at 40, it doesn't really matter. Let me uninstall these and see if the official repo gives any increase. It'll take me a min lol
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #4 of 8
Thread Starter 
So the repo drivers increased it to 1400, shy by 200 pts now, which is better I guess. Still can't use AA, if I do it drops the FPS in half. I've also noticed that if ran in windowed mode with the repo drivers, it doesn't work right. The program runs but it won't update the frames, or it does poorly. Unsure why that is.

(repo drivers, 13.1)
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #5 of 8
Thread Starter 
Update, still has random xorg crashes too. Kind of piss annoying when I'm doing something, oh no not the log in screen! So far, my experience has been poor and it isn't looking better either. It's going to make me continue thinking that driver use in Linux is poor for the Radeon series, so far it has been.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #6 of 8
how on earth valve will make a decent steam box option for AMD users i dont know rolleyes.gif

im assuming with amd on ps4 / xbox and windows for good drivers that they now wont really care too much about linux again. There web page for steam dev still shows steam beta? its been out properly for ages now !

perhaps steambox will be Nvidia only?
post #7 of 8
Thread Starter 
Quote:
Originally Posted by phill1978 View Post

how on earth valve will make a decent steam box option for AMD users i dont know rolleyes.gif

im assuming with amd on ps4 / xbox and windows for good drivers that they now wont really care too much about linux again. There web page for steam dev still shows steam beta? its been out properly for ages now !

perhaps steambox will be Nvidia only?

Not to be a dick but this isn't a flame thread, I'm actually wanting help to fix issues and not cause a "which is better" aspect. However this isn't making my future recommendations that much better. I haven't had issues with Nvidia, the worst being random xorg crashes with no log output. That's bothersome, which I thought it might be a beta thing... Turns out it isn't, that would be the most helpful in figuring out.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #8 of 8
Thread Starter 
K so xorg crashing is more frequent than thought, ANY help would be appreciated or I'm gonna have to ditch the card at a loss to get it moving quicker. This is unacceptable.

[edit] Flash doesn't work either, i'm guessing 2D video support isn't doing too hot. This is getting worse and worse.

Flash works now, had to pull an updates for the driver. Stock rpms didn't work.
Edited by mushroomboy - 3/25/13 at 3:48pm
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › AMD woes and Linux