Overclock.net › Forums › Graphics Cards › NVIDIA › GTX 660Ti or GTX 670 performance/gpu usage in World of Tanks - please help
New Posts  All Forums:Forum Nav:

GTX 660Ti or GTX 670 performance/gpu usage in World of Tanks - please help

post #1 of 9
Thread Starter 
Hi!

First of all my rig:

CPU: Core i5 3570K @4,5 GHz (1,18v) - max temp 62 degrees
CPU Cooler: Enermax ETS-T40-TA
GPU: MSI 660Ti Power Edition OC (@1346/7400MHz) - max temp 60 degrees
RAM: Corsair Vengeance Low Profile 2x4GB (@1600MHz 1,5v)
PSU: Corsair TXEU 750W
Case: CM HAF 912 Plus (including: 2x120mm sickleflow front fans, 1x120mm cm back fan, 1x200mm top megaflow fan, 1x120mm Thermaltake TT side fan)
OS: Windows 8 64 bit

And now my problem:

In some games (the best example here is World of Tanks) I get low GPU usage, even though I maxed out the settings. I play on 1920x1080, everything on Ultra but my GPU usage hovers only around 40-50% with Vsync On (or adaptive vsync - doesn't matter) and 70% with vsync off (but getting screen tearing).

Now my question - is it possible that my 3rd gen Intel CPU clocked to 4,5 GHz is bottlenecking the GPU? On GTX 560Ti I had constant 99% usage and no problems at all. Also with HD 7950 (which died after 2 days from buying) I had 70-80% GPU usage with vsync on and much more stable FPS.

Can anyone who owns either GTX 660Ti or GTX 670 and similar CPU do a test in World Of Tanks 8.4 game and check if he gets the same low GPU usage?

Most of the time I have stable 60 FPS with vsync but whenever there is some action going on it drops to low 40's and GPU usage still hovers at around 40-50%. Is it a driver issue? Is it even possible after so many drivers for 6xx cards were released?

Does anyone know how to fix it? I'm really going insane. mad.gif

In Far Cry 3 I get constant 90-99% gpu usage and stable FPS. Same goes for any benchmark I run except for 3dmark11 (it hovers there but GPU score is 10240 points so I guess it's decent).

What I tried:

1. New OS + new drivers
2. Setting maximum performance in Nvidia Control Panel (it saves only after I reboot my PC, if I won't do it it switches itself to adaptive)
3. Going to stock clocks with both CPU and GPU

And nothing. Can anyone provide any help on this? I can't believe this CPU is really bottlenecking especially that it didn't bottleneck 7950 which after OC is a bit faster than 660Ti.
post #2 of 9
Welcome to WoT. Wargaming has a monkey with a stick coding it.




Now if you want a real answer. The game is uses just a single core. No matter how much you overclock the gpu or how many different drivers you use your cpu will be the bottleneck.
I is bad@naming
(21 items)
 
Up and running!!
(27 items)
 
 
CPUMotherboardGraphicsGraphics
Intel 4930k Asus Rampage IV Black edition Powercolor 7870 PCS+ Sapphire 7950 
RAMHard DriveHard DriveHard Drive
16gb 2133mhz G.Skill Sniper  Kingston SSD Western Digital R4 Seagate Barracuda 
CoolingCoolingCoolingOS
EK Supremacy acetyl/Nickel XSPC EX240 Phobya DC-12 400 Windows 7 
MonitorKeyboardPowerCase
Asus 23.5" Corsair K70 Antec True Power Quattro 850w Coolermaster Storm Trooper 
MouseMouse PadAudioAudio
Logitech G400 Steelseries QCK Schiit Magni Schiit Modi 
Audio
Hifiman HE-400 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K Asrock Extreme 6 Z77 PowerColor 7870 PCS+ MYST Corsair Vengeance 
RAMHard DriveHard DriveHard Drive
Corsair Vengeance 30gb Kingston SSD 500gb seagate Western Digital R4 
Hard DriveOptical DriveCoolingCooling
Seagate Barracuda Lite-on 18x Danger Den TDX XSPC EX240 
CoolingOSOSOS
Phobya DC12-400 Windows 7 Home Premium 64bit Windows 8 pro 64bit Ubuntu 
MonitorMonitorKeyboardPower
Asus VH236H Acer V203W Logitech Business class Antec Truepower Quattro 850w 
CaseMouseMouse PadAudio
CoolerMaster Storm trooper Logitech G400 Steelseries QCK MOH edition Audio-Technica AD-700 
AudioAudioOther
Creative Soundblaster z Sony XB-800 Logysis white cold cathodes 
  hide details  
Reply
I is bad@naming
(21 items)
 
Up and running!!
(27 items)
 
 
CPUMotherboardGraphicsGraphics
Intel 4930k Asus Rampage IV Black edition Powercolor 7870 PCS+ Sapphire 7950 
RAMHard DriveHard DriveHard Drive
16gb 2133mhz G.Skill Sniper  Kingston SSD Western Digital R4 Seagate Barracuda 
CoolingCoolingCoolingOS
EK Supremacy acetyl/Nickel XSPC EX240 Phobya DC-12 400 Windows 7 
MonitorKeyboardPowerCase
Asus 23.5" Corsair K70 Antec True Power Quattro 850w Coolermaster Storm Trooper 
MouseMouse PadAudioAudio
Logitech G400 Steelseries QCK Schiit Magni Schiit Modi 
Audio
Hifiman HE-400 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K Asrock Extreme 6 Z77 PowerColor 7870 PCS+ MYST Corsair Vengeance 
RAMHard DriveHard DriveHard Drive
Corsair Vengeance 30gb Kingston SSD 500gb seagate Western Digital R4 
Hard DriveOptical DriveCoolingCooling
Seagate Barracuda Lite-on 18x Danger Den TDX XSPC EX240 
CoolingOSOSOS
Phobya DC12-400 Windows 7 Home Premium 64bit Windows 8 pro 64bit Ubuntu 
MonitorMonitorKeyboardPower
Asus VH236H Acer V203W Logitech Business class Antec Truepower Quattro 850w 
CaseMouseMouse PadAudio
CoolerMaster Storm trooper Logitech G400 Steelseries QCK MOH edition Audio-Technica AD-700 
AudioAudioOther
Creative Soundblaster z Sony XB-800 Logysis white cold cathodes 
  hide details  
Reply
post #3 of 9
Thread Starter 
Well OK but why it didn't happen with 7950 or 560Ti? 660Ti is faster than 560Ti but not faster than 7950. If AMD fixed it with Catalysts why Nvidia who is the partner of Wargaming didn't?

It seems to me that it has something to do with Kepler cards in general - saw many reports on other forums but no solution.

I also created topic about it on Nvidia forums in drivers section - maybe there I can get some help. I got less FPS with 560Ti but at least they were stable. What I'm getting now is like having SLI without actually having it (all those FPS drops, stutters) - it's really weird because for half of the time the game is ultra playable and half of the time it's not.

7950 didn't give me those issues at all. Shame it died smile.gif
post #4 of 9
Quote:
Originally Posted by Mephic View Post

Well OK but why it didn't happen with 7950 or 560Ti? 660Ti is faster than 560Ti but not faster than 7950. If AMD fixed it with Catalysts why Nvidia who is the partner of Wargaming didn't?

It seems to me that it has something to do with Kepler cards in general - saw many reports on other forums but no solution.

I also created topic about it on Nvidia forums in drivers section - maybe there I can get some help. I got less FPS with 560Ti but at least they were stable. What I'm getting now is like having SLI without actually having it (all those FPS drops, stutters) - it's really weird because for half of the time the game is ultra playable and half of the time it's not.

7950 didn't give me those issues at all. Shame it died smile.gif

The 560TI is a weaker card so it does not surprise me that it was used more. As for AMD, I have no idea. My 7870 is bottlenecked and I get a max of 63fps with moderate drops to 40fps on some maps. You can try uninstalling and then re-installing. It could be a corrupt file causing the file.
I is bad@naming
(21 items)
 
Up and running!!
(27 items)
 
 
CPUMotherboardGraphicsGraphics
Intel 4930k Asus Rampage IV Black edition Powercolor 7870 PCS+ Sapphire 7950 
RAMHard DriveHard DriveHard Drive
16gb 2133mhz G.Skill Sniper  Kingston SSD Western Digital R4 Seagate Barracuda 
CoolingCoolingCoolingOS
EK Supremacy acetyl/Nickel XSPC EX240 Phobya DC-12 400 Windows 7 
MonitorKeyboardPowerCase
Asus 23.5" Corsair K70 Antec True Power Quattro 850w Coolermaster Storm Trooper 
MouseMouse PadAudioAudio
Logitech G400 Steelseries QCK Schiit Magni Schiit Modi 
Audio
Hifiman HE-400 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K Asrock Extreme 6 Z77 PowerColor 7870 PCS+ MYST Corsair Vengeance 
RAMHard DriveHard DriveHard Drive
Corsair Vengeance 30gb Kingston SSD 500gb seagate Western Digital R4 
Hard DriveOptical DriveCoolingCooling
Seagate Barracuda Lite-on 18x Danger Den TDX XSPC EX240 
CoolingOSOSOS
Phobya DC12-400 Windows 7 Home Premium 64bit Windows 8 pro 64bit Ubuntu 
MonitorMonitorKeyboardPower
Asus VH236H Acer V203W Logitech Business class Antec Truepower Quattro 850w 
CaseMouseMouse PadAudio
CoolerMaster Storm trooper Logitech G400 Steelseries QCK MOH edition Audio-Technica AD-700 
AudioAudioOther
Creative Soundblaster z Sony XB-800 Logysis white cold cathodes 
  hide details  
Reply
I is bad@naming
(21 items)
 
Up and running!!
(27 items)
 
 
CPUMotherboardGraphicsGraphics
Intel 4930k Asus Rampage IV Black edition Powercolor 7870 PCS+ Sapphire 7950 
RAMHard DriveHard DriveHard Drive
16gb 2133mhz G.Skill Sniper  Kingston SSD Western Digital R4 Seagate Barracuda 
CoolingCoolingCoolingOS
EK Supremacy acetyl/Nickel XSPC EX240 Phobya DC-12 400 Windows 7 
MonitorKeyboardPowerCase
Asus 23.5" Corsair K70 Antec True Power Quattro 850w Coolermaster Storm Trooper 
MouseMouse PadAudioAudio
Logitech G400 Steelseries QCK Schiit Magni Schiit Modi 
Audio
Hifiman HE-400 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K Asrock Extreme 6 Z77 PowerColor 7870 PCS+ MYST Corsair Vengeance 
RAMHard DriveHard DriveHard Drive
Corsair Vengeance 30gb Kingston SSD 500gb seagate Western Digital R4 
Hard DriveOptical DriveCoolingCooling
Seagate Barracuda Lite-on 18x Danger Den TDX XSPC EX240 
CoolingOSOSOS
Phobya DC12-400 Windows 7 Home Premium 64bit Windows 8 pro 64bit Ubuntu 
MonitorMonitorKeyboardPower
Asus VH236H Acer V203W Logitech Business class Antec Truepower Quattro 850w 
CaseMouseMouse PadAudio
CoolerMaster Storm trooper Logitech G400 Steelseries QCK MOH edition Audio-Technica AD-700 
AudioAudioOther
Creative Soundblaster z Sony XB-800 Logysis white cold cathodes 
  hide details  
Reply
post #5 of 9
Thread Starter 
OK - actually that's only thing I didn't try to do, reinstalling the game.

I hope it will work. smile.gif

Thanks for input.
post #6 of 9
Thread Starter 
One more thing - is it possible that it is caused by setting maximum pre rendered frames to default in NVControlPanel? (it is set to programme mode)

When I come back home I will try to change it to 3 or 4 but just asking - I guess that if I will choose to pre render more frames by CPU, than GPU will have more work to do?
post #7 of 9
Quote:
Originally Posted by Mephic View Post

One more thing - is it possible that it is caused by setting maximum pre rendered frames to default in NVControlPanel? (it is set to programme mode)

When I come back home I will try to change it to 3 or 4 but just asking - I guess that if I will choose to pre render more frames by CPU, than GPU will have more work to do?

Truthfully, I have no idea what it does. You can play around with it to see if it helps though.
I is bad@naming
(21 items)
 
Up and running!!
(27 items)
 
 
CPUMotherboardGraphicsGraphics
Intel 4930k Asus Rampage IV Black edition Powercolor 7870 PCS+ Sapphire 7950 
RAMHard DriveHard DriveHard Drive
16gb 2133mhz G.Skill Sniper  Kingston SSD Western Digital R4 Seagate Barracuda 
CoolingCoolingCoolingOS
EK Supremacy acetyl/Nickel XSPC EX240 Phobya DC-12 400 Windows 7 
MonitorKeyboardPowerCase
Asus 23.5" Corsair K70 Antec True Power Quattro 850w Coolermaster Storm Trooper 
MouseMouse PadAudioAudio
Logitech G400 Steelseries QCK Schiit Magni Schiit Modi 
Audio
Hifiman HE-400 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K Asrock Extreme 6 Z77 PowerColor 7870 PCS+ MYST Corsair Vengeance 
RAMHard DriveHard DriveHard Drive
Corsair Vengeance 30gb Kingston SSD 500gb seagate Western Digital R4 
Hard DriveOptical DriveCoolingCooling
Seagate Barracuda Lite-on 18x Danger Den TDX XSPC EX240 
CoolingOSOSOS
Phobya DC12-400 Windows 7 Home Premium 64bit Windows 8 pro 64bit Ubuntu 
MonitorMonitorKeyboardPower
Asus VH236H Acer V203W Logitech Business class Antec Truepower Quattro 850w 
CaseMouseMouse PadAudio
CoolerMaster Storm trooper Logitech G400 Steelseries QCK MOH edition Audio-Technica AD-700 
AudioAudioOther
Creative Soundblaster z Sony XB-800 Logysis white cold cathodes 
  hide details  
Reply
I is bad@naming
(21 items)
 
Up and running!!
(27 items)
 
 
CPUMotherboardGraphicsGraphics
Intel 4930k Asus Rampage IV Black edition Powercolor 7870 PCS+ Sapphire 7950 
RAMHard DriveHard DriveHard Drive
16gb 2133mhz G.Skill Sniper  Kingston SSD Western Digital R4 Seagate Barracuda 
CoolingCoolingCoolingOS
EK Supremacy acetyl/Nickel XSPC EX240 Phobya DC-12 400 Windows 7 
MonitorKeyboardPowerCase
Asus 23.5" Corsair K70 Antec True Power Quattro 850w Coolermaster Storm Trooper 
MouseMouse PadAudioAudio
Logitech G400 Steelseries QCK Schiit Magni Schiit Modi 
Audio
Hifiman HE-400 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K Asrock Extreme 6 Z77 PowerColor 7870 PCS+ MYST Corsair Vengeance 
RAMHard DriveHard DriveHard Drive
Corsair Vengeance 30gb Kingston SSD 500gb seagate Western Digital R4 
Hard DriveOptical DriveCoolingCooling
Seagate Barracuda Lite-on 18x Danger Den TDX XSPC EX240 
CoolingOSOSOS
Phobya DC12-400 Windows 7 Home Premium 64bit Windows 8 pro 64bit Ubuntu 
MonitorMonitorKeyboardPower
Asus VH236H Acer V203W Logitech Business class Antec Truepower Quattro 850w 
CaseMouseMouse PadAudio
CoolerMaster Storm trooper Logitech G400 Steelseries QCK MOH edition Audio-Technica AD-700 
AudioAudioOther
Creative Soundblaster z Sony XB-800 Logysis white cold cathodes 
  hide details  
Reply
post #8 of 9
Thread Starter 
I set my maximum pre rendered frames to "3" - it helped a bit. What I get now is constant 1346 MHz on GPU BUT still usage hovers around 40-60%. I've tried to overclock my CPU to 4,8 GHz and than declock it to 3,4 GHz - GPU usage in every case is the same.

I suppose it is driver fault than.

What is ridiculous is the fact, that there were already multiple drivers released for Kepler and it still can't handle Vsync with Triple buffering in older games causing performance drops.

Anyway I reinstalled the game and removed a HD minimap mod and it is quite fluent now (only on some maps FPS goes down to 48-50 but it is playable). Today I will try to use FPS limiter instead of Vsync because with 3 pre rendered frames I don't have screen tearing at all when I turn off Vsync.

Maybe the problem is not fully solved but now at least I know it's not my hardware fault. I also read about setting fixed clocks by disabling boost but as I can see it won't help here because my clocks are stable at kepler boost. It's the GPU usage which suffers.
post #9 of 9
Thread Starter 
Well I'm basically back to square one.

I tested some more games:

Sim City 2013, Train Simulator 2013, Mount and Blade WB with texture packs.........

Everywhere the same thing. Low GPU usage, performance drops. frown.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › GTX 660Ti or GTX 670 performance/gpu usage in World of Tanks - please help