Overclock.net › Forums › Components › Mice › Problems with new Razer DeathAdder 2013 edition.
New Posts  All Forums:Forum Nav:

Problems with new Razer DeathAdder 2013 edition.

post #1 of 4
Thread Starter 
I just got my Razer DeathAdder, and it's hardly working at all on my (SteelSeries Qck+)mousepad, but it kind of works on other surfaces. It works fine on the mousepad until I lift it, then after that it seems like it's stuck to one spot; however, if I turn the sensitivity all the way up, it looks like the cursor is having a seizure in that spot when I try to move it. When that happens, if I go to surface calibration and recalibrate it, it works until I lift it again.

Any ideas on what I can do?
post #2 of 4
I think you need to clean your Qck+. I had the exact same problem on a Razer Kabuto, which cleaning solved. I guess the DA2013 sensor doesn't like dirt.

If that fails, try playing with the LoD setting in Synapse and see if it makes any difference.
Crysis Slayer
(16 items)
 
Gaming Mice
(9 items)
 
CPUMotherboardGraphicsRAM
Intel Core i5-4670K ASUS MAXIMUS VI GENE EVGA GeForce GTX 770 SC w/ ACX Cooling G.SKILL Ripjaws Z Series 16GB (2 x 8GB) 
Hard DriveHard DriveCoolingOS
Samsung 840 PRO 256GB SSD HSGT 7K1000 3x Corsair Air Series SP120 PWM Quiet Edition Microsoft Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
ASUS VG248QE Max Keyboard Blackbird Tenkeyless G1B-UK SeaSonic X Series X650 Gold Corsair Obsidian 350D 
MouseMouse PadAudioAudio
Cooler Master MasterMouse MM520 Turtle Beach Drift XL Beyerdynamic MMX 300 Focal XS Book Wireless 2.0 
  hide details  
Reply
Crysis Slayer
(16 items)
 
Gaming Mice
(9 items)
 
CPUMotherboardGraphicsRAM
Intel Core i5-4670K ASUS MAXIMUS VI GENE EVGA GeForce GTX 770 SC w/ ACX Cooling G.SKILL Ripjaws Z Series 16GB (2 x 8GB) 
Hard DriveHard DriveCoolingOS
Samsung 840 PRO 256GB SSD HSGT 7K1000 3x Corsair Air Series SP120 PWM Quiet Edition Microsoft Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
ASUS VG248QE Max Keyboard Blackbird Tenkeyless G1B-UK SeaSonic X Series X650 Gold Corsair Obsidian 350D 
MouseMouse PadAudioAudio
Cooler Master MasterMouse MM520 Turtle Beach Drift XL Beyerdynamic MMX 300 Focal XS Book Wireless 2.0 
  hide details  
Reply
post #3 of 4
Increase the LOD in the settings to maximum, clean your lens and mouse pad.

Sounds like you don't clean your equipment or maybe your mouse is a dud.

Anyway, if you do not have the proper amount of light on a dark surface the sensor cannot perform to its potential.
post #4 of 4
Thread Starter 
Quote:
Originally Posted by Artifact View Post

I think you need to clean your Qck+. I had the exact same problem on a Razer Kabuto, which cleaning solved. I guess the DA2013 sensor doesn't like dirt.

If that fails, try playing with the LoD setting in Synapse and see if it makes any difference.

Tried cleaning the mousepad and messing with the LOD, but it didn't make any difference. I know it can work fine on the mousepad, but as soon as I lift it even a little bit, it stops working.

The mousepad does feel much nicer now, though.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › Problems with new Razer DeathAdder 2013 edition.