Overclock.net › Forums › Video Games › PC Gaming › Games don't appear to be "smooth" without vsync?
New Posts  All Forums:Forum Nav:

Games don't appear to be "smooth" without vsync?

post #1 of 4
Thread Starter 
It's a question I've had for who knows how long, but I'm curious if someone could explain this phenomena. When I'm in games above 60 fps, it's "smooth" I guess you could say, but there's always a very apparent very consistently happening stutter. Moving left to right I can see this mostly. Based on my limited knowledge I would assume it's the screen tearing that makes the games appear to have that stutter, but I want to make sure that I can't do anything else about this, so that's why I'm asking you all. Really wish this wasn't the case as I can't stand the input lag introduced by vsync, and it'd be nice to have all my games have the ultimate smoothness, but when I need 1:1 reactions when playing MP FPSs, for example, that input delay vsync brings is just too much to bear.

Also, are there different ways of implementing vsync? For some reason, the vsync in far cry 3 has very very little input delay introduced comparing to other titles I've tried.
Edited by venomblade - 3/28/13 at 8:55pm
post #2 of 4
You could try limiting your framerate to 59/58/57 in addition to vsync with msi afterburner/nvidia inspector or any other software of the like. This should eliminate the input lag completely in theory. I know it's a common method used on this cases but can't confirm how it'll work out for you.
Little Beast
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @4.5ghz Asus P8P67 Pro Asus GTX 970 Corsair Dominator 8gb 1600mhz 
Hard DriveHard DriveCoolingOS
Western Digital Caviar Black 1TB Western Digital Caviar Black 1TB Cooler Master Hyper 212+ Windows 7 64bit 
PowerCase
Antec HCP-850W Cooler Master HAF 922 
  hide details  
Reply
Little Beast
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @4.5ghz Asus P8P67 Pro Asus GTX 970 Corsair Dominator 8gb 1600mhz 
Hard DriveHard DriveCoolingOS
Western Digital Caviar Black 1TB Western Digital Caviar Black 1TB Cooler Master Hyper 212+ Windows 7 64bit 
PowerCase
Antec HCP-850W Cooler Master HAF 922 
  hide details  
Reply
post #3 of 4
Thread Starter 
Quote:
Originally Posted by Brainsick View Post

You could try limiting your framerate to 59/58/57 in addition to vsync with msi afterburner/nvidia inspector or any other software of the like. This should eliminate the input lag completely in theory. I know it's a common method used on this cases but can't confirm how it'll work out for you.

Thanks a bunch, I'll give it a try now. Just curious, do you experience anything like I detailed in my OP? Noticeable "unsmoothness" most likely caused by tearing when at framerates above 60?

edit: Oh man this nearly solved all of my problems, unfortunately when capped to 58-59 and testing by looking at wall moving left to right, I notice a slight consistent "stutter". It's the subtlest thing, but my eye seems to catch it everytime and it throws me off. I honestly hope that I'm not so sensitive to these occurrences that the fact that I'm a mere 1fps shy from 60, my eyes don't like it....ugh what a curse.
Edited by venomblade - 3/28/13 at 10:13pm
post #4 of 4
hi,
The problem with v-sync is that is requires a constant over 60fps to work best. It eliminates the screen tearing (images get split horizontaly when moving ) but I'm not sure it will do anything about stuttering. To you notice a framerate drop when it happens ?
Now The input lag is all about the frame buffer, I read something about it. Try and figure out which way you have to set that buffer to reduce it. In Farcry 3 for exemple you can set the buffer for 1, 2, 3 etc frames. Maybe V-sync is smooth then because it is well ajusted.
I'd recommend you disable the V-sync if your PC can't handle to be over 60 fps at any moment in the game. If your fps drops below 60, then the v-sync will jump to a 30 fps sync and that introduce violent input lag.
in the last gen of geforce cards, nvidia introduced "adaptive v-sync" which automaticaly switch v-sync off if your fps drops below 60 to deal with the problems it would cause.
Most of the fps players don't use v-sync anyways.
deus ex machina
(14 items)
 
  
Reply
deus ex machina
(14 items)
 
  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Games don't appear to be "smooth" without vsync?