Overclock.net › Forums › Video Games › PC Gaming › Bioshock Infinate
New Posts  All Forums:Forum Nav:

Bioshock Infinate

post #1 of 5
Thread Starter 
I have been playing it but it has been plagued by framerate dips to 30fps on ultra with my GTX 670. That seems very odd to me. Nothing should dip below maximum framerate on ultra besides poorly optimized games like metro 2033(and certain RTS games). My GPU is not even getting near overheating but it is oddly at 100% usage.... I set it to very high and that fixes the framerate dips at no loss in quality but what can be the setting that brings my card to its knees on ultimate? I will play around with the settings but I just wanted to vent my frustration. If I find the answer good. If someone else does, fine. Now I want to start a new game because it plays 130% better without those dips in framerate I had until now.
post #2 of 5
I can't play without vsync on a 7950, can't stand it. Took me forever to get it perfect, also started using a controller to mitigate the input lag. I got most of it gone on the mouse, but this is run2 so I'm gonna sit back and enjoy it a bit more.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #3 of 5
I've been running on a 7970 on Ultra with vsync on with no problems. GPU usage is generally pretty low, nowhere near max it seems. Don't notice any input lag. I've had nothing but good experiences.

One thing that does bother me, all unreal 3 engine games take me a couple minutes to get used too. I seem to get a little nauseous whenever I start playing them. rolleyes.gif
600t
(16 items)
 
  
CPUMotherboardGraphicsRAM
2600k Z77 Extreme4 7970 4x4GB Corsair Arctic White LP Vengeance @ 1600 
Hard DriveHard DriveHard DriveOptical Drive
crucial m4 Caviar Black Caviar Green LG Blu-Ray 
CoolingOSMonitorMonitor
H100 Windows 7 Dell U2412m Dell 2407WFP 
KeyboardPowerCaseMouse
Saitek Eclipse Seasonic x-760 600t Logitech G700 
  hide details  
Reply
600t
(16 items)
 
  
CPUMotherboardGraphicsRAM
2600k Z77 Extreme4 7970 4x4GB Corsair Arctic White LP Vengeance @ 1600 
Hard DriveHard DriveHard DriveOptical Drive
crucial m4 Caviar Black Caviar Green LG Blu-Ray 
CoolingOSMonitorMonitor
H100 Windows 7 Dell U2412m Dell 2407WFP 
KeyboardPowerCaseMouse
Saitek Eclipse Seasonic x-760 600t Logitech G700 
  hide details  
Reply
post #4 of 5
Thread Starter 
Bioshock infinite is optimized for amd if you notice the big amd thing at the beginning. The setting that does what I was complaining about is shadows, on ultra it makes the card work overtime but move it down one notch to very high and tada 60fps buttery smooth!
post #5 of 5
Thread Starter 
Another thing I have noticed is that unless I have it on high or lower there are always parts where the framerate dips down to 30fps. And, the load screen is capped at 30fps(like a lot of games). I think, this is a game that will take anther generation of graphics card to max(unless you have an AMD card).
Edited by phantasmor - 3/29/13 at 11:18pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Bioshock Infinate