Overclock.net › Forums › Components › Monitors and Displays › Problem with Crossover 27 QD
New Posts  All Forums:Forum Nav:

Problem with Crossover 27 QD

post #1 of 10
Thread Starter 
I have had my 27inch Crossover from about a month now.
Already from the beginning it had this tick from time to time when it apparently would lose it`s signal, the status-light started flashing between blue and red, the panel going from dark to lit, but no signal. Also there was this clicking sound from the back of the panel. The same sound you hear when you connect the monitors power cord. It would flicker like this for a couple seconds or maybe a minute before the signal came back on like nothing had happened. All the while my other monitors("normal resolutions") were working just like normal.

The last week this has started to happen like all the time!confusedsmiley.png and now it can last for hours at a time! To tell the truth I have barely been able to use the damn thing the last days.

Any of you experienced something similar or have any idea what the problem might be?
post #2 of 10
Probably a bad cap on one of the boards, or a break in a solder point that's gotten worse over time.
post #3 of 10
Thread Starter 
Might be hard for me to fix the problem then. Today it has only worked for 3-4 minutes like 3 times ;p
post #4 of 10
Best thing you can do is contact the seller and ask for a replacement
Project Zero
(10 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570K Updating  EVGA GeForce GTX 670 FTW+ 4GB w/Backplate Samsung Wonder Ram 8GB 
Hard DriveCoolingOSMonitor
Samsung 830 128GB Corsair H100i Windows 7 Ultimate 64bit 2 X Dell U2713HM  
PowerCase
Corsair AX750 Fractal Design Define R4 Black Pearl with Window 
  hide details  
Reply
Project Zero
(10 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570K Updating  EVGA GeForce GTX 670 FTW+ 4GB w/Backplate Samsung Wonder Ram 8GB 
Hard DriveCoolingOSMonitor
Samsung 830 128GB Corsair H100i Windows 7 Ultimate 64bit 2 X Dell U2713HM  
PowerCase
Corsair AX750 Fractal Design Define R4 Black Pearl with Window 
  hide details  
Reply
post #5 of 10
Quote:
Originally Posted by Tharayman View Post

Might be hard for me to fix the problem then. Today it has only worked for 3-4 minutes like 3 times ;p

Well, in that case, I have to agree with this man here. If you had some electronics knowledge it would most likely be fixable, but otherwise:
Quote:
Originally Posted by GEEKICON View Post

Best thing you can do is contact the seller and ask for a replacement
post #6 of 10
Thread Starter 
They gave me a to-do-checklist long as F... Did most of it, will wait until my new DVI-cable arrives, and if it doesnt work out, the seller has agreed to send me a new Power adapter or PCB!
post #7 of 10
Did you ever get a resolution to your issue? I am having the exact same problem right now =(
post #8 of 10
Thread Starter 
Not at all! The cursed seller put me trough weeks and weeks of ridicolus troubleshooting, documentation and so on.
In the end they demanded 20$ for shipping to send me a new PCB. When it finaly arrived just last week, it was a PCB that did not fit the monitor case in any way. But the worst thing was that a capacitor had been broken loose so it did not work at all... Now the seller(redcap) will not even answer me anymore. Worst ebay seller I have ever encountered!

Maybe both of us can try finding out where we can order a new PCB? If we don`t get one the rest of the monitor is just trash :/

How long had you been using your monitor before it stopped working?
post #9 of 10
OK that stinks, I also bought from RedCap. I will start looking for a place to purchase replacement PCBs.
post #10 of 10
Thread Starter 
****! They are the worst EVER. They are total ******* morons, just trying to slip out from their responsebility. Making them send me the PCB was hell. And when it finaly arrived it was broken, and for some other monitor. One week now, and they still have not answered my reminders....
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › Problem with Crossover 27 QD