Overclock.net › Forums › Components › Sound Cards and Computer Audio › Pairing Astro A50 and Creative Zx - I need your help!
New Posts  All Forums:Forum Nav:

Pairing Astro A50 and Creative Zx - I need your help!

post #1 of 6
Thread Starter 
Hi everyone!

I have some trouble getting my Astro A50 to work with my new Creative Zx soundcard.
For some reason the sound will only play in my headset when I choose "Astro Wireless Transmitter" which is connected via USB cable.



When I switch to the "SPDIF-Out" option from Sound Blaster Z all sound stops. So right now I have a new soundcard, but for some reason it won't connect properly with the A50's.

The MixAmp is connected with a usb/power cable to the PC and with an optical cable into the Sound Blaster Zx.

Link to headset: http://www.astrogaming.com/a50-wireless-system
Link to soundcard: http://dk.creative.com/products/product.asp?category=1&subcategory=872&product=21384&eventcategory=MHL&eventaction=homepage&eventlabel=SoundBlasterZx

I really hope one of you bright heads can help me out here! smile.gif

Best regards
TheDomino
post #2 of 6
You're using a USB headset. That's the problem. You are bypassing your sound card completely when you do that. If you're going to continue to use that headset you might as well sell your sound card. As for the spdif, you'll need to check in the creative control panel and make sure that you have the dolby digital/DTS encoder disabled. Then you will be able to use the spdif out option that you're referring.
post #3 of 6
Thread Starter 
In the specs it says "Outputs:Optical Passthrough, USB Power & Voice, USB Charging Port"
http://www.astrogaming.com/a50-wireless-system#specsmenu

So I don't understand why it's an USB headset then, the mixamp is connected with an optical cable to the soundcard.
post #4 of 6
I misunderstood and thought that the signal was coming from USB. Use the 3.5mm input.
post #5 of 6
Thread Starter 
This is the backside of the mixamp



Shouldn't I use the OPT-IN slot and connect it with an optical cable to the OPT-OUT at the Zx soundcard?
post #6 of 6
Quote:
Originally Posted by TheDomino View Post

This is the backside of the mixamp



Shouldn't I use the OPT-IN slot and connect it with an optical cable to the OPT-OUT at the Zx soundcard?
You can, but when you use the 3.5mm the DAC in the sound card is being used. When you use optical, the DAC in the headset is being used. If you want to use the spdif out with DD encoding, you will need to enable it in the creative control panel. When doing this, make sure that you still have the default output device in windows sound control panel as the speakers from the sound card. Do not set it to spdif out. You will only set it to spdif out if you have the encoder disabled in the creative control panel.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Pairing Astro A50 and Creative Zx - I need your help!