Overclock.net › Forums › Graphics Cards › AMD/ATI › System won't start with 7970 plugged in
New Posts  All Forums:Forum Nav:

System won't start with 7970 plugged in

Poll Results: Further testing or RMA?

 
  • 100% (2)
    Test
  • 0% (0)
    RMA
2 Total Votes  
post #1 of 7
Thread Starter 
My system won't boot with my XFX 7970 plugged in the power supply (Corsair AX750) just clicks twice. As soon as it is unplugged, the system can POST. I removed the 7970 and put in a GTX470 and the system can boot just fine with that so it seems like it's not my PSU. Should I test the 7970 in someone else's system or just start the RMA process?
post #2 of 7
Quote:
Originally Posted by Acrimonus View Post

My system won't boot with my XFX 7970 plugged in the power supply (Corsair AX750) just clicks twice. As soon as it is unplugged, the system can POST. I removed the 7970 and put in a GTX470 and the system can boot just fine with that so it seems like it's not my PSU. Should I test the 7970 in someone else's system or just start the RMA process?

Hvae you tried another PCI-E slot or does it do it in all the slots?

How old is that XFX 7970 can you return it?
Seravee
(24 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I7 6850K Gigabyte X99 Ultra Gaming Gigabyte GTX 970 G1 Gaming Kingston HyperX DDR4 Savage 3000 MHz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Evo WD Green WD30EZRX  WD Green WD40EZRX  WD Green WD60EZRX  
Hard DriveOptical DriveCoolingCooling
WD Red WD80EFZX 8TB  LG CH12NS30 5x Noctua NF-A14 FLX Noctua NH-D15 
OSMonitorKeyboardPower
Windows 7 64 Bit Asus PG279Q Corsair Gaming Strafe RGB EVGA SuperNova G2 750 watt 
CaseMouseMouse PadAudio
Phanteks Enthoo Luxe Roccat Kone XTD Laser Roccat Sense Metor Sennheiser HD 598 
AudioAudioOtherOther
Onkyo TX NR646  Harman Kardon HKTS 60 CableMod E series PSU cable set CableMod LED Strips 
  hide details  
Reply
Seravee
(24 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I7 6850K Gigabyte X99 Ultra Gaming Gigabyte GTX 970 G1 Gaming Kingston HyperX DDR4 Savage 3000 MHz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Evo WD Green WD30EZRX  WD Green WD40EZRX  WD Green WD60EZRX  
Hard DriveOptical DriveCoolingCooling
WD Red WD80EFZX 8TB  LG CH12NS30 5x Noctua NF-A14 FLX Noctua NH-D15 
OSMonitorKeyboardPower
Windows 7 64 Bit Asus PG279Q Corsair Gaming Strafe RGB EVGA SuperNova G2 750 watt 
CaseMouseMouse PadAudio
Phanteks Enthoo Luxe Roccat Kone XTD Laser Roccat Sense Metor Sennheiser HD 598 
AudioAudioOtherOther
Onkyo TX NR646  Harman Kardon HKTS 60 CableMod E series PSU cable set CableMod LED Strips 
  hide details  
Reply
post #3 of 7
Thread Starter 
Quote:
Originally Posted by shilka View Post

Hvae you tried another PCI-E slot or does it do it in all the slots?

How old is that XFX 7970 can you return it?

It was bought January 8, 2013 from newegg so no I cannot return it to them, I would have to go through XFX. It does the same thing in both PCI-E slots.
post #4 of 7
Quote:
Originally Posted by Acrimonus View Post

It was bought January 8, 2013 from newegg so no I cannot return it to them, I would have to go through XFX. It does the same thing in both PCI-E slots.

Sory to say this but the XFX cards have the worst coolers of all AMD 7000 series cards the cooler sucks

Good luck with XFX RMA that sucks just as hard as their coolers
Seravee
(24 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I7 6850K Gigabyte X99 Ultra Gaming Gigabyte GTX 970 G1 Gaming Kingston HyperX DDR4 Savage 3000 MHz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Evo WD Green WD30EZRX  WD Green WD40EZRX  WD Green WD60EZRX  
Hard DriveOptical DriveCoolingCooling
WD Red WD80EFZX 8TB  LG CH12NS30 5x Noctua NF-A14 FLX Noctua NH-D15 
OSMonitorKeyboardPower
Windows 7 64 Bit Asus PG279Q Corsair Gaming Strafe RGB EVGA SuperNova G2 750 watt 
CaseMouseMouse PadAudio
Phanteks Enthoo Luxe Roccat Kone XTD Laser Roccat Sense Metor Sennheiser HD 598 
AudioAudioOtherOther
Onkyo TX NR646  Harman Kardon HKTS 60 CableMod E series PSU cable set CableMod LED Strips 
  hide details  
Reply
Seravee
(24 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I7 6850K Gigabyte X99 Ultra Gaming Gigabyte GTX 970 G1 Gaming Kingston HyperX DDR4 Savage 3000 MHz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Evo WD Green WD30EZRX  WD Green WD40EZRX  WD Green WD60EZRX  
Hard DriveOptical DriveCoolingCooling
WD Red WD80EFZX 8TB  LG CH12NS30 5x Noctua NF-A14 FLX Noctua NH-D15 
OSMonitorKeyboardPower
Windows 7 64 Bit Asus PG279Q Corsair Gaming Strafe RGB EVGA SuperNova G2 750 watt 
CaseMouseMouse PadAudio
Phanteks Enthoo Luxe Roccat Kone XTD Laser Roccat Sense Metor Sennheiser HD 598 
AudioAudioOtherOther
Onkyo TX NR646  Harman Kardon HKTS 60 CableMod E series PSU cable set CableMod LED Strips 
  hide details  
Reply
post #5 of 7
Thread Starter 
I didn't really have any heat issues, not under Furmark or playing Crysis so that comment doesn't really seem valid. I can't comment on the XFX RMA process though, I've never had to RMA a component before.
post #6 of 7
Quote:
Originally Posted by Acrimonus View Post

I didn't really have any heat issues, not under Furmark or playing Crysis so that comment doesn't really seem valid. I can't comment on the XFX RMA process though, I've never had to RMA a component before.

Have heard alot say they are as bad as Asus or worse but i would not know first hand about either of them
Seravee
(24 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I7 6850K Gigabyte X99 Ultra Gaming Gigabyte GTX 970 G1 Gaming Kingston HyperX DDR4 Savage 3000 MHz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Evo WD Green WD30EZRX  WD Green WD40EZRX  WD Green WD60EZRX  
Hard DriveOptical DriveCoolingCooling
WD Red WD80EFZX 8TB  LG CH12NS30 5x Noctua NF-A14 FLX Noctua NH-D15 
OSMonitorKeyboardPower
Windows 7 64 Bit Asus PG279Q Corsair Gaming Strafe RGB EVGA SuperNova G2 750 watt 
CaseMouseMouse PadAudio
Phanteks Enthoo Luxe Roccat Kone XTD Laser Roccat Sense Metor Sennheiser HD 598 
AudioAudioOtherOther
Onkyo TX NR646  Harman Kardon HKTS 60 CableMod E series PSU cable set CableMod LED Strips 
  hide details  
Reply
Seravee
(24 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I7 6850K Gigabyte X99 Ultra Gaming Gigabyte GTX 970 G1 Gaming Kingston HyperX DDR4 Savage 3000 MHz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Evo WD Green WD30EZRX  WD Green WD40EZRX  WD Green WD60EZRX  
Hard DriveOptical DriveCoolingCooling
WD Red WD80EFZX 8TB  LG CH12NS30 5x Noctua NF-A14 FLX Noctua NH-D15 
OSMonitorKeyboardPower
Windows 7 64 Bit Asus PG279Q Corsair Gaming Strafe RGB EVGA SuperNova G2 750 watt 
CaseMouseMouse PadAudio
Phanteks Enthoo Luxe Roccat Kone XTD Laser Roccat Sense Metor Sennheiser HD 598 
AudioAudioOtherOther
Onkyo TX NR646  Harman Kardon HKTS 60 CableMod E series PSU cable set CableMod LED Strips 
  hide details  
Reply
post #7 of 7
How did RMA go?
I think I killed mine doing an aftermarket cooler upgrade.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › System won't start with 7970 plugged in