Overclock.net › Forums › Graphics Cards › AMD/ATI › I think i broke my GPU
New Posts  All Forums:Forum Nav:

I think i broke my GPU - Page 4

post #31 of 48
Quote:
Originally Posted by FatKoala View Post

Ok, so i bought a new card, (the amd radeon 7870) and everything is working fine now, so the GPU was indeed broken but like i said everything else is working.

THANK YOU EVERYONE smile.gif

what are you going to do with the old card?
     
CPUMotherboardGraphicsRAM
Intel Core i5 2500k @ 4.9Ghz Gigabyte GA-Z77X-UP7 EVGA GTX 980Ti SC 4x 4GB Patriot Viper Xtreme 2133Mhz 
Hard DriveHard DriveCoolingOS
Intel 520 Series 120GB SSD WD Caviar Blue SATA II 640GB EK CPUWB & Rad, Temporary XSPC Pump & Res, All ... Windows 7 Home Premium 
MonitorKeyboardPowerCase
3x 1080p 24" Monitors Razer BlackWidow Ultimate Corsair HX-750 NZXT Lexa S (Highly Modified) 
MouseMouse PadAudio
Razer Naga 2014 Steelseries QCK Kenwood KA-5500 Reciever & (Temporary) ATH-M30X's 
CPUMotherboardGraphicsRAM
Intel Atom D525 2C/4T 1.8Ghz SuperMicro X7SPE-HF-D525 Integrated - Not Used 2x 2GB DDR3 Sodimms 
Hard DriveCoolingOSPower
4GB Sata DOM Passive (except for PSU Fan) Debian GNU/Linux 8.0 Jessie PicoPSU 120Watt with 60Watt EDAC Brick 
CaseOther
1U Supermicro DHCP/DNS/Munin 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel Core i5 2500k @ 4.9Ghz Gigabyte GA-Z77X-UP7 EVGA GTX 980Ti SC 4x 4GB Patriot Viper Xtreme 2133Mhz 
Hard DriveHard DriveCoolingOS
Intel 520 Series 120GB SSD WD Caviar Blue SATA II 640GB EK CPUWB & Rad, Temporary XSPC Pump & Res, All ... Windows 7 Home Premium 
MonitorKeyboardPowerCase
3x 1080p 24" Monitors Razer BlackWidow Ultimate Corsair HX-750 NZXT Lexa S (Highly Modified) 
MouseMouse PadAudio
Razer Naga 2014 Steelseries QCK Kenwood KA-5500 Reciever & (Temporary) ATH-M30X's 
CPUMotherboardGraphicsRAM
Intel Atom D525 2C/4T 1.8Ghz SuperMicro X7SPE-HF-D525 Integrated - Not Used 2x 2GB DDR3 Sodimms 
Hard DriveCoolingOSPower
4GB Sata DOM Passive (except for PSU Fan) Debian GNU/Linux 8.0 Jessie PicoPSU 120Watt with 60Watt EDAC Brick 
CaseOther
1U Supermicro DHCP/DNS/Munin 
  hide details  
Reply
post #32 of 48
Thread Starter 
Quote:
Originally Posted by EpicAMDGamer View Post

what are you going to do with the old card?
I don't really know, what do you think??
post #33 of 48
Quote:
Originally Posted by FatKoala View Post

I don't really know, what do you think??
Did you try RMAing it? If not, try that and then if you get a working card back crossfire them. thumb.gif
Number Cruncher
(16 items)
 
HTPC
(11 items)
 
750TIMINER2
(15 items)
 
CPUMotherboardGraphicsRAM
i7 2600k ASUS Sabertooth Z77 Sapphire 290 Tri-x 4GB OC CORSAIR Vengeance 16GB 
Hard DriveHard DriveHard DriveOptical Drive
Intel 520 120 GB SSD Seagate Barracuda 1 TB 250GB Samsung 840 EVO SSD LG Blu-Ray Lightscribe Combo Burner 
CoolingOSMonitorPower
Swiftech H320 (CPU only) Windows 7 Ultimate 27" Shimian 1440p Monitor 1000W Corsair PSU 
CaseMouseMouse PadAudio
800D custom painted and fixed up! 15 year old Microsoft Custom Minecraft Mousepad Logitech 2.1 Speakers (wub wubbity wub wub) 
CPUMotherboardGraphicsRAM
i5 3570k MSI Z68 MA-ED55 MSI GTX 750 Ti 6GB Corsair XMP 
Hard DriveOptical DriveCoolingOS
500GB WD Blue ASUS DVD Burner Hyper 212+ Windows 8.1 
PowerCase
Rosewill HIVE 750W Rosewill Blackbone 
CPUMotherboardGraphicsRAM
AMD Sempron 145 Gigabyte 990FXA-UD3 4x MSI GTX 750 Ti 6 GB Corsair XMP 
Hard DriveCoolingOSMonitor
500 GB Seagate Barracuda Stock Windows 7 LG 20" 900p display 
KeyboardPowerCaseMouse
Dell generic Rosewill HIVE 750W Rosewill Thor V2 Dell generic 
Other
4x USB Powered Risers 
  hide details  
Reply
Number Cruncher
(16 items)
 
HTPC
(11 items)
 
750TIMINER2
(15 items)
 
CPUMotherboardGraphicsRAM
i7 2600k ASUS Sabertooth Z77 Sapphire 290 Tri-x 4GB OC CORSAIR Vengeance 16GB 
Hard DriveHard DriveHard DriveOptical Drive
Intel 520 120 GB SSD Seagate Barracuda 1 TB 250GB Samsung 840 EVO SSD LG Blu-Ray Lightscribe Combo Burner 
CoolingOSMonitorPower
Swiftech H320 (CPU only) Windows 7 Ultimate 27" Shimian 1440p Monitor 1000W Corsair PSU 
CaseMouseMouse PadAudio
800D custom painted and fixed up! 15 year old Microsoft Custom Minecraft Mousepad Logitech 2.1 Speakers (wub wubbity wub wub) 
CPUMotherboardGraphicsRAM
i5 3570k MSI Z68 MA-ED55 MSI GTX 750 Ti 6GB Corsair XMP 
Hard DriveOptical DriveCoolingOS
500GB WD Blue ASUS DVD Burner Hyper 212+ Windows 8.1 
PowerCase
Rosewill HIVE 750W Rosewill Blackbone 
CPUMotherboardGraphicsRAM
AMD Sempron 145 Gigabyte 990FXA-UD3 4x MSI GTX 750 Ti 6 GB Corsair XMP 
Hard DriveCoolingOSMonitor
500 GB Seagate Barracuda Stock Windows 7 LG 20" 900p display 
KeyboardPowerCaseMouse
Dell generic Rosewill HIVE 750W Rosewill Thor V2 Dell generic 
Other
4x USB Powered Risers 
  hide details  
Reply
post #34 of 48
Quote:
Originally Posted by FatKoala View Post

Quote:
Originally Posted by EpicAMDGamer View Post

what are you going to do with the old card?
I don't really know, what do you think??

 

 I think you should ship it Pizzaman or myself for repair.. its likely a blown SMD on the input stage for power good.

 

**and NO - There is NOT anything on GPU PCB to prevent short or power surge. GPU are "dumb" component.. not "active". When you short the GPU.. you blow components.. there is no "fuse" of any kind.. not even on top-tier GPU's.

post #35 of 48
Perhaps post high res pics of the back of the PCB to see if there's obvious damage?

If not perhaps I'd like it for the cooler...

Quote:
Originally Posted by CL3P20 View Post

I think you should ship it Pizzaman or myself for repair.. its likely a blown SMD on the input stage for power good.

**and NO - There is NOT anything on GPU PCB to prevent short or power surge. GPU are "dumb" component.. not "active". When you short the GPU.. you blow components.. there is no "fuse" of any kind.. not even on top-tier GPU's.

Thanks for backing me up about the fuses topic.
     
CPUMotherboardGraphicsRAM
Intel Core i5 2500k @ 4.9Ghz Gigabyte GA-Z77X-UP7 EVGA GTX 980Ti SC 4x 4GB Patriot Viper Xtreme 2133Mhz 
Hard DriveHard DriveCoolingOS
Intel 520 Series 120GB SSD WD Caviar Blue SATA II 640GB EK CPUWB & Rad, Temporary XSPC Pump & Res, All ... Windows 7 Home Premium 
MonitorKeyboardPowerCase
3x 1080p 24" Monitors Razer BlackWidow Ultimate Corsair HX-750 NZXT Lexa S (Highly Modified) 
MouseMouse PadAudio
Razer Naga 2014 Steelseries QCK Kenwood KA-5500 Reciever & (Temporary) ATH-M30X's 
CPUMotherboardGraphicsRAM
Intel Atom D525 2C/4T 1.8Ghz SuperMicro X7SPE-HF-D525 Integrated - Not Used 2x 2GB DDR3 Sodimms 
Hard DriveCoolingOSPower
4GB Sata DOM Passive (except for PSU Fan) Debian GNU/Linux 8.0 Jessie PicoPSU 120Watt with 60Watt EDAC Brick 
CaseOther
1U Supermicro DHCP/DNS/Munin 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel Core i5 2500k @ 4.9Ghz Gigabyte GA-Z77X-UP7 EVGA GTX 980Ti SC 4x 4GB Patriot Viper Xtreme 2133Mhz 
Hard DriveHard DriveCoolingOS
Intel 520 Series 120GB SSD WD Caviar Blue SATA II 640GB EK CPUWB & Rad, Temporary XSPC Pump & Res, All ... Windows 7 Home Premium 
MonitorKeyboardPowerCase
3x 1080p 24" Monitors Razer BlackWidow Ultimate Corsair HX-750 NZXT Lexa S (Highly Modified) 
MouseMouse PadAudio
Razer Naga 2014 Steelseries QCK Kenwood KA-5500 Reciever & (Temporary) ATH-M30X's 
CPUMotherboardGraphicsRAM
Intel Atom D525 2C/4T 1.8Ghz SuperMicro X7SPE-HF-D525 Integrated - Not Used 2x 2GB DDR3 Sodimms 
Hard DriveCoolingOSPower
4GB Sata DOM Passive (except for PSU Fan) Debian GNU/Linux 8.0 Jessie PicoPSU 120Watt with 60Watt EDAC Brick 
CaseOther
1U Supermicro DHCP/DNS/Munin 
  hide details  
Reply
post #36 of 48
Np.. *I see you wink.gif
post #37 of 48
Thread Starter 
post #38 of 48
Quote:
Originally Posted by FatKoala View Post

Ok so here is what i did:

1. I accidentaly touched my gpu with a metal object while the computer was running.
2. Immediatly when i touched it, the Led:s on the GPU turned off and my monitor stopped getting any signal from the computer.
3. I turned off my computer and everything started as normal EXCEPT the GPU and the monitor, it seemed like the GPU didn't get any power.
4. The GPU fans are running at 100%(i can hear it from the sound)
5. The VGA_Light on the motherboard is red all the time(shouldn't it just flash red at the startup?)
6. All the other lights on the motherboard are normal.

So i think that my GPU is broken and that the reason to it was a short circuit when i touched the GPU. Am i right??? And if i'm right, is it possible that there is like a fuse on the GPU that would've saved it from getting destroyed.

And if it was a short circuit can anything else be broken, all the fans are working and everything looks normal except the GPU. Everything insinde the computer looks normal except the GPU lights and the VGA_light (GPU lights are not on, VGA_Light is on all the time)

Here are some of the computer specs:
Motherboard: Asus p8p67 EVO
Video card: MSI Radeon HD r6970 Lightning
CPU: Intel i5 2500K
Power supply: Corsair CX750

So is my GPU broken?
Is something else and the GPU broken?
How can i fix any possible problems?


I will try to answer your questions ASAP!!

O_O Uh-oh!!! Yea.... It is possible that you shorted to ground and may have burnt a resistor in the GPU... :'( I'm very sad to hear this... (Sorry if my post is redundant.)
post #39 of 48
Quote:
Originally Posted by FatKoala View Post

You asked for pictures so here you are.

20130414_191445.jpg 2012k .jpg file

20130414_191409.jpg 2104k .jpg file

I don't see any obvious damage. Yep, the card is done for frown.gif
     
CPUMotherboardGraphicsRAM
Intel Core i5 2500k @ 4.9Ghz Gigabyte GA-Z77X-UP7 EVGA GTX 980Ti SC 4x 4GB Patriot Viper Xtreme 2133Mhz 
Hard DriveHard DriveCoolingOS
Intel 520 Series 120GB SSD WD Caviar Blue SATA II 640GB EK CPUWB & Rad, Temporary XSPC Pump & Res, All ... Windows 7 Home Premium 
MonitorKeyboardPowerCase
3x 1080p 24" Monitors Razer BlackWidow Ultimate Corsair HX-750 NZXT Lexa S (Highly Modified) 
MouseMouse PadAudio
Razer Naga 2014 Steelseries QCK Kenwood KA-5500 Reciever & (Temporary) ATH-M30X's 
CPUMotherboardGraphicsRAM
Intel Atom D525 2C/4T 1.8Ghz SuperMicro X7SPE-HF-D525 Integrated - Not Used 2x 2GB DDR3 Sodimms 
Hard DriveCoolingOSPower
4GB Sata DOM Passive (except for PSU Fan) Debian GNU/Linux 8.0 Jessie PicoPSU 120Watt with 60Watt EDAC Brick 
CaseOther
1U Supermicro DHCP/DNS/Munin 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel Core i5 2500k @ 4.9Ghz Gigabyte GA-Z77X-UP7 EVGA GTX 980Ti SC 4x 4GB Patriot Viper Xtreme 2133Mhz 
Hard DriveHard DriveCoolingOS
Intel 520 Series 120GB SSD WD Caviar Blue SATA II 640GB EK CPUWB & Rad, Temporary XSPC Pump & Res, All ... Windows 7 Home Premium 
MonitorKeyboardPowerCase
3x 1080p 24" Monitors Razer BlackWidow Ultimate Corsair HX-750 NZXT Lexa S (Highly Modified) 
MouseMouse PadAudio
Razer Naga 2014 Steelseries QCK Kenwood KA-5500 Reciever & (Temporary) ATH-M30X's 
CPUMotherboardGraphicsRAM
Intel Atom D525 2C/4T 1.8Ghz SuperMicro X7SPE-HF-D525 Integrated - Not Used 2x 2GB DDR3 Sodimms 
Hard DriveCoolingOSPower
4GB Sata DOM Passive (except for PSU Fan) Debian GNU/Linux 8.0 Jessie PicoPSU 120Watt with 60Watt EDAC Brick 
CaseOther
1U Supermicro DHCP/DNS/Munin 
  hide details  
Reply
post #40 of 48
Dang Finland, if you were close I'll get that thing working got a lot of spare GPU parts.
Current
(15 items)
 
  
CPUMotherboardGraphicsRAM
XEON Rampage 3 Black Edition GTX 580 (x2) 24GB DDR3 
Hard DriveHard DriveHard DriveCooling
WD VelociRaptor WD Black RE3 WD Black (x3) Delta Fans (13) 
OSMonitorKeyboardPower
Win7 Ultimate 32-bit (Kernel Unlocked) Triple T220 MS Natural 4000 Dual 620Watts 
CaseMouseMouse Pad
Custom Built Razer Orochi func 360 
  hide details  
Reply
Current
(15 items)
 
  
CPUMotherboardGraphicsRAM
XEON Rampage 3 Black Edition GTX 580 (x2) 24GB DDR3 
Hard DriveHard DriveHard DriveCooling
WD VelociRaptor WD Black RE3 WD Black (x3) Delta Fans (13) 
OSMonitorKeyboardPower
Win7 Ultimate 32-bit (Kernel Unlocked) Triple T220 MS Natural 4000 Dual 620Watts 
CaseMouseMouse Pad
Custom Built Razer Orochi func 360 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › I think i broke my GPU