Overclock.net › Forums › Components › Monitors and Displays › [Official] The Qnix/X-Star 1440p Monitor Club
New Posts  All Forums:Forum Nav:

[Official] The Qnix/X-Star 1440p Monitor Club - Page 1310

post #13091 of 25935
Quote:
Originally Posted by Dyekid217 View Post

well after much debate and personal thinking.. I just picked up another 660 for SLI !!

Now all I have to do is get my hands on one of these 120hz babys.
knew you'd cave haha
post #13092 of 25935
Quote:
Originally Posted by hammelgammler View Post

Yeah im german. My two monitors were send with FedEx and i had to pay 19% VAT but as far i can remember no zoll cost.
The third monitor is the one of my girlfriend. She bought it from green-sum, and after asking them they should mark it as a gift and send it with DHL, she doesn't need to pay any other costs at the door at all.
The monitor was also declared with a lower value than it actually was. (220$ instead of 359$)
Yeah dd you had to pick it up from zoll or did you receive it at the door and when did you receive your VAT bill?
Sorry for bombing you with questions I'm just excited.
post #13093 of 25935
Quote:
Originally Posted by ImmortalTechniq View Post

Yeah dd you had to pick it up from zoll or did you receive it at the door and when did you receive your VAT bill?
Sorry for bombing you with questions I'm just excited.

I received it at the door and i think a few weeks later a bill for the VAT from FedEx.
No problem.
post #13094 of 25935
Quote:
Originally Posted by hammelgammler View Post

I received it at the door and i think a few weeks later a bill for the VAT from FedEx.
No problem.
Thank You! Yeah I hope I get the same experience I get it via UPS though and as far as I know UPS is terrible.
post #13095 of 25935
Quote:
Originally Posted by ImmortalTechniq View Post

Thank You! Yeah I hope I get the same experience I get it via UPS though and as far as I know UPS is terrible.

Good luck with your monitor.
Hopefully you're getting one without major BLB or dead/stuck pixels. thumb.gif
post #13096 of 25935
Quote:
Originally Posted by hammelgammler View Post

Good luck with your monitor.
Hopefully you're getting one without major BLB or dead/stuck pixels. thumb.gif
Thanks mate.
post #13097 of 25935
Getting my monitor tomorrow I'll let you guys know how it is when it arrives (if it does since it snowing like crazy here)
post #13098 of 25935
Arg, my X-Star is held up in customs and the waiting is killing me. I ordered last Tuesday, it feels like it's been forever, especially seeing people that ordered later getting theirs earlier. smile.gif
post #13099 of 25935
Thanks to Lawson for all your help!! I'm running at 120hz now and appears to be stable.

See my explanation of the problem on page 1306 of this thread.

I am also using your 120hz ini and it looks great. Just like it did out of the box at 60hz as far as color.

May try your blb fix at some point too but mine is so minimal, I'm not sure I want to have any risk of breaking it just to fix it.
post #13100 of 25935
Quote:
Originally Posted by MapRef41N93W View Post

Who has AA turned on at that resolution you say... how about most because it still helps at 1440p. Even at 4k AA is still noticeable.

It's sad to see people who have no idea what they're talking about giving out 'advice'.

There was not even the tiniest jaggie to be seen when I was gaming. Everyone who knows what they've got in this screen knows to turn off AA.

I played all the usual suspects, including heavily modded maxed out Skyrim (sans AA), on a 1440p and 660ti and was getting great frame rates. Sorry but you've no clue what you're on about.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › [Official] The Qnix/X-Star 1440p Monitor Club