Overclock.net › Forums › Components › Monitors and Displays › [Official] The Qnix/X-Star 1440p Monitor Club
New Posts  All Forums:Forum Nav:

[Official] The Qnix/X-Star 1440p Monitor Club - Page 932

post #9311 of 25891
Anyone else having this issue where the dektop lags @ 60Hz but on 96Hz it's fine. it feels like frame skipping but it's not. my Mouse cursor feels very laggy and so on. hard to explain. BTW I'm on crossfire R9-280x cards
Main Gaming RIG
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k ASUS VII Ranger Galax hof gtx 980 ti 16GB 1600mhz adata ram 
Hard DriveHard DriveHard DriveCooling
128GB SSD Samsung 840 evo 1TB WD blue Liteon 256GB SSD Phanteks PH-TC14PE 
OSMonitorKeyboardPower
Windows 8.1 ASUS PG279Q Cooler master Quickfire XT Corsair AX850w 
CaseMouseMouse PadAudio
Corsair Air carbide 540 Steelseries Ikari Laser Steelsereies QCK+ sound Blaster Z 
Audio
Sennheiser HD 598 
  hide details  
Reply
Main Gaming RIG
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k ASUS VII Ranger Galax hof gtx 980 ti 16GB 1600mhz adata ram 
Hard DriveHard DriveHard DriveCooling
128GB SSD Samsung 840 evo 1TB WD blue Liteon 256GB SSD Phanteks PH-TC14PE 
OSMonitorKeyboardPower
Windows 8.1 ASUS PG279Q Cooler master Quickfire XT Corsair AX850w 
CaseMouseMouse PadAudio
Corsair Air carbide 540 Steelseries Ikari Laser Steelsereies QCK+ sound Blaster Z 
Audio
Sennheiser HD 598 
  hide details  
Reply
post #9312 of 25891
Maybe you've gotten used to the 96Hz on the desktop, so that anything slower "feels" like lag.

I keep my Qnix constantly at 120Hz, but I have a 60Hz IPS monitor right next to it and everything on that monitor feels very slow if I'm moving programs around (mouse as well).
    
CPUMotherboardGraphicsRAM
Intel i5 3570K [Delid] Asrock Z77E-ITX XFX Radeon R9 Fury X G.SKILL 2133MHz 8GB DDR3 
Hard DriveHard DriveHard DriveHard Drive
Crucial M4 256GB Silicon Power S60 120GB Western Digital Blue Scorpio 1TB Seagate Constellation 2 1TB 
CoolingCoolingCoolingCooling
Swiftech Apogee Drive II XSPC RX240+EX240 [Painted White] 5x 2150RPM Gentle Typhoons PWM [Painted Black+W... Bitspower Water Tank Z-Multi 80 Inline Reservoir  
OSMonitorMonitorKeyboard
Windows 10 LG 34UC88-B 34" Ultrawide 3440x1440 75Hz HP ZR2240w IPS WASD CODE 87-Key [MX Clear + PBT Keycaps] 
PowerCaseMouseAudio
Seasonix X-750 Case Labs Mercury S3 Logitech G502 Sennheiser HD 598 SE 
Audio
Micca OriGen 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i5 3570K [Delid] Asrock Z77E-ITX XFX Radeon R9 Fury X G.SKILL 2133MHz 8GB DDR3 
Hard DriveHard DriveHard DriveHard Drive
Crucial M4 256GB Silicon Power S60 120GB Western Digital Blue Scorpio 1TB Seagate Constellation 2 1TB 
CoolingCoolingCoolingCooling
Swiftech Apogee Drive II XSPC RX240+EX240 [Painted White] 5x 2150RPM Gentle Typhoons PWM [Painted Black+W... Bitspower Water Tank Z-Multi 80 Inline Reservoir  
OSMonitorMonitorKeyboard
Windows 10 LG 34UC88-B 34" Ultrawide 3440x1440 75Hz HP ZR2240w IPS WASD CODE 87-Key [MX Clear + PBT Keycaps] 
PowerCaseMouseAudio
Seasonix X-750 Case Labs Mercury S3 Logitech G502 Sennheiser HD 598 SE 
Audio
Micca OriGen 
  hide details  
Reply
post #9313 of 25891
Quote:
Originally Posted by Kokin View Post

Maybe you've gotten used to the 96Hz on the desktop, so that anything slower "feels" like lag.

I keep my Qnix constantly at 120Hz, but I have a 60Hz IPS monitor right next to it and everything on that monitor feels very slow if I'm moving programs around (mouse as well).
But at work I'm using a normal 1080p 60Hz screen and it feels much smoother.
Main Gaming RIG
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k ASUS VII Ranger Galax hof gtx 980 ti 16GB 1600mhz adata ram 
Hard DriveHard DriveHard DriveCooling
128GB SSD Samsung 840 evo 1TB WD blue Liteon 256GB SSD Phanteks PH-TC14PE 
OSMonitorKeyboardPower
Windows 8.1 ASUS PG279Q Cooler master Quickfire XT Corsair AX850w 
CaseMouseMouse PadAudio
Corsair Air carbide 540 Steelseries Ikari Laser Steelsereies QCK+ sound Blaster Z 
Audio
Sennheiser HD 598 
  hide details  
Reply
Main Gaming RIG
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k ASUS VII Ranger Galax hof gtx 980 ti 16GB 1600mhz adata ram 
Hard DriveHard DriveHard DriveCooling
128GB SSD Samsung 840 evo 1TB WD blue Liteon 256GB SSD Phanteks PH-TC14PE 
OSMonitorKeyboardPower
Windows 8.1 ASUS PG279Q Cooler master Quickfire XT Corsair AX850w 
CaseMouseMouse PadAudio
Corsair Air carbide 540 Steelseries Ikari Laser Steelsereies QCK+ sound Blaster Z 
Audio
Sennheiser HD 598 
  hide details  
Reply
post #9314 of 25891
Quote:
Originally Posted by DiceAir View Post

But at work I'm using a normal 1080p 60Hz screen and it feels much smoother.

Yeah i had that issue after applying the overclock the first time i went back planning on using 60hz again but in bf3 everything was hella jittery. Thought it must be just me. Switched back to 96hz and haven't really given it a second thought now tho tbh.
I'm back baby!!!
(23 items)
 
  
CPUMotherboardGraphicsRAM
i5 4670k Asus sabertooth z97 mark 2 sapphire tri x r9 290 corsair ripjaws x 1600 (16gb) 
Hard DriveHard DriveHard DriveHard Drive
samsung evo 120gb ssd seagate 1tb hdd 1tb external hdd seagate 2tb hdd 
Optical DriveCoolingOSMonitor
samsung cd drive coolermaster vortex plus windows 7 ultimate Sony W800B (50 inch) 
KeyboardPowerCaseMouse
Corsair vengeance k65 Corsair rm1000 Fractal Design node 605 Razer Naga left hand edition 
Mouse PadAudioOtherOther
Razer kabuto creative gigaworks t40 series ii logitech g930 wireless headset Logitech wireless touchpad 
Other
Vantec 310S3 Hard drive enclosure x2 
  hide details  
Reply
I'm back baby!!!
(23 items)
 
  
CPUMotherboardGraphicsRAM
i5 4670k Asus sabertooth z97 mark 2 sapphire tri x r9 290 corsair ripjaws x 1600 (16gb) 
Hard DriveHard DriveHard DriveHard Drive
samsung evo 120gb ssd seagate 1tb hdd 1tb external hdd seagate 2tb hdd 
Optical DriveCoolingOSMonitor
samsung cd drive coolermaster vortex plus windows 7 ultimate Sony W800B (50 inch) 
KeyboardPowerCaseMouse
Corsair vengeance k65 Corsair rm1000 Fractal Design node 605 Razer Naga left hand edition 
Mouse PadAudioOtherOther
Razer kabuto creative gigaworks t40 series ii logitech g930 wireless headset Logitech wireless touchpad 
Other
Vantec 310S3 Hard drive enclosure x2 
  hide details  
Reply
post #9315 of 25891
Hey folks - been reading this thread for a few weeks and finally decided to take the plunge biggrin.gif

Got my QNIX ordered from "excellentcastle" last night for £199.98 with free shipping. I live in Scotland, so there will be import tax. Asked him to mark it as a gift with a value of £50 (didn't want to be too unrealistic), which he said he would. Fingers crossed!

Anyways, very excited now biggrin.gif I've always had a TN panel and never used anything over 1920x1080, I feel like a kid on Christmas eve...

I've got an option to add a SquareTrade 3 year warranty for £30. It says I can buy the warranty up to 30 days after purchasing the monitor. Anyone in the UK have experience with this in regards to these monitors?

The only draw back at the moment is that I run two MSI 7970 Lightning cards - and they DO NOT have dual link DVI ports frown.gif I have no idea if I can overclock my QNIX using an active DisplayPort to dual link DVI adapter, but I don't want to spend £80 on an adapter to find out. Any advice? In the mean time I got my hands on a cheap EVGA GTX 680, while I decide what to do with my GPUs. May sell them both and pick up a 7xx.

I do love new tech smile.gif Will let you know how my back light bleed etc is.
post #9316 of 25891
Quote:
Originally Posted by mboner1 View Post

Yeah i had that issue after applying the overclock the first time i went back planning on using 60hz again but in bf3 everything was hella jittery. Thought it must be just me. Switched back to 96hz and haven't really given it a second thought now tho tbh.

Just funny cause my monitor at work feels smoother. i can see the mouse cursor on my screen is laggy. It looks like frame skipping etc etc. i hope I haven't damaged the monitor by overclocking it. For now i will leave it at 96hz but it's just funny that i get this issue.
Main Gaming RIG
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k ASUS VII Ranger Galax hof gtx 980 ti 16GB 1600mhz adata ram 
Hard DriveHard DriveHard DriveCooling
128GB SSD Samsung 840 evo 1TB WD blue Liteon 256GB SSD Phanteks PH-TC14PE 
OSMonitorKeyboardPower
Windows 8.1 ASUS PG279Q Cooler master Quickfire XT Corsair AX850w 
CaseMouseMouse PadAudio
Corsair Air carbide 540 Steelseries Ikari Laser Steelsereies QCK+ sound Blaster Z 
Audio
Sennheiser HD 598 
  hide details  
Reply
Main Gaming RIG
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k ASUS VII Ranger Galax hof gtx 980 ti 16GB 1600mhz adata ram 
Hard DriveHard DriveHard DriveCooling
128GB SSD Samsung 840 evo 1TB WD blue Liteon 256GB SSD Phanteks PH-TC14PE 
OSMonitorKeyboardPower
Windows 8.1 ASUS PG279Q Cooler master Quickfire XT Corsair AX850w 
CaseMouseMouse PadAudio
Corsair Air carbide 540 Steelseries Ikari Laser Steelsereies QCK+ sound Blaster Z 
Audio
Sennheiser HD 598 
  hide details  
Reply
post #9317 of 25891
Quote:
Originally Posted by DiceAir View Post

Just funny cause my monitor at work feels smoother. i can see the mouse cursor on my screen is laggy. It looks like frame skipping etc etc. i hope I haven't damaged the monitor by overclocking it. For now i will leave it at 96hz but it's just funny that i get this issue.

Yeah it was definitely noticeable for me as well, i thought the laser on my mouse was stuffed or something. 96hz looks a lot better than the original 60hz anyway so i say just overclock it and forget about it.
I'm back baby!!!
(23 items)
 
  
CPUMotherboardGraphicsRAM
i5 4670k Asus sabertooth z97 mark 2 sapphire tri x r9 290 corsair ripjaws x 1600 (16gb) 
Hard DriveHard DriveHard DriveHard Drive
samsung evo 120gb ssd seagate 1tb hdd 1tb external hdd seagate 2tb hdd 
Optical DriveCoolingOSMonitor
samsung cd drive coolermaster vortex plus windows 7 ultimate Sony W800B (50 inch) 
KeyboardPowerCaseMouse
Corsair vengeance k65 Corsair rm1000 Fractal Design node 605 Razer Naga left hand edition 
Mouse PadAudioOtherOther
Razer kabuto creative gigaworks t40 series ii logitech g930 wireless headset Logitech wireless touchpad 
Other
Vantec 310S3 Hard drive enclosure x2 
  hide details  
Reply
I'm back baby!!!
(23 items)
 
  
CPUMotherboardGraphicsRAM
i5 4670k Asus sabertooth z97 mark 2 sapphire tri x r9 290 corsair ripjaws x 1600 (16gb) 
Hard DriveHard DriveHard DriveHard Drive
samsung evo 120gb ssd seagate 1tb hdd 1tb external hdd seagate 2tb hdd 
Optical DriveCoolingOSMonitor
samsung cd drive coolermaster vortex plus windows 7 ultimate Sony W800B (50 inch) 
KeyboardPowerCaseMouse
Corsair vengeance k65 Corsair rm1000 Fractal Design node 605 Razer Naga left hand edition 
Mouse PadAudioOtherOther
Razer kabuto creative gigaworks t40 series ii logitech g930 wireless headset Logitech wireless touchpad 
Other
Vantec 310S3 Hard drive enclosure x2 
  hide details  
Reply
post #9318 of 25891
Quote:
Originally Posted by bullet beard View Post

Hey folks - been reading this thread for a few weeks and finally decided to take the plunge biggrin.gif

Got my QNIX ordered from "excellentcastle" last night for £199.98 with free shipping. I live in Scotland, so there will be import tax. Asked him to mark it as a gift with a value of £50 (didn't want to be too unrealistic), which he said he would. Fingers crossed!

Anyways, very excited now biggrin.gif I've always had a TN panel and never used anything over 1920x1080, I feel like a kid on Christmas eve...

I've got an option to add a SquareTrade 3 year warranty for £30. It says I can buy the warranty up to 30 days after purchasing the monitor. Anyone in the UK have experience with this in regards to these monitors?

The only draw back at the moment is that I run two MSI 7970 Lightning cards - and they DO NOT have dual link DVI ports frown.gif I have no idea if I can overclock my QNIX using an active DisplayPort to dual link DVI adapter, but I don't want to spend £80 on an adapter to find out. Any advice? In the mean time I got my hands on a cheap EVGA GTX 680, while I decide what to do with my GPUs. May sell them both and pick up a 7xx.

I do love new tech smile.gif Will let you know how my back light bleed etc is.

Are you sure? Those are pretty modern cards (and newer than mine in fact) so I'd be really surprised if they didn't support dual-link DVI.
post #9319 of 25891
Quote:
Originally Posted by bloodr0se View Post

Are you sure? Those are pretty modern cards (and newer than mine in fact) so I'd be really surprised if they didn't support dual-link DVI.

Unfortunately, yeah frown.gif Have a look, Hilbert mentions it most of the way down the page:

http://www.guru3d.com/articles_pages/msi_radeon_hd_7970_lightning_review,3.html
post #9320 of 25891
Quote:
Originally Posted by bullet beard View Post

Unfortunately, yeah frown.gif Have a look, Hilbert mentions it most of the way down the page:

http://www.guru3d.com/articles_pages/msi_radeon_hd_7970_lightning_review,3.html

I thought the bottom-right port on the 3rd screenshot down was dual-link DVI. That's exactly what the port on my card looks like anyway but the plug on the DL-DVI cable looks like a male version of the DVI port at the top (if that makes sense).

I wonder if an updated BIOS for the card could help with that, it seems quite weird to me.

With regards to your other questions, I ordered mine from ExcellentCastle and the customs charges were around £17 (£10 of that was the courier "admin" fee). DHL sent me a text about that straight away and I'd already paid them online before the monitor even left Incheon.

I have purchased the ST warranty for it as well and submitted the receipt with no problem but obviously I haven't needed to claim on it yet and hopefully won't ever need to at all.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › [Official] The Qnix/X-Star 1440p Monitor Club