Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › I cannot load any Linux OS onto Sager 9150
New Posts  All Forums:Forum Nav:

I cannot load any Linux OS onto Sager 9150 - Page 6

post #51 of 69
write a tutorial of what you did. if it works "normally" that's probably the best solution you can get. it would be very helpful as to how this works.

i'm a bit drunk atm. so take what i say with a bit of leniency... but if you could figure out what acpi mode does and the boot perimeters it would probably be helpfull to a lot of people. i know this might be asking a lot of you, but getting a working distribution on certain hardware can be a pain. don't know a better way to explain this.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #52 of 69
Thread Starter 
Right now I am backing up all my files and then I am going to reformat the hard drive and try to install Windows 7 in UEFI mode and then try to install Ubuntu and or Mint again and see if it will work with both using UEFI. Like I said before, I installed Windows 7 in legacy mode and then tried to load Linux in both modes but Ubuntu would not work in either legacy or UEFI; and Mint would only work in legacy but you have to boot it in ACPI workaround to make it run.

I am thinking that because Windows was not installed in UEFI mode since the Sager 9150 supports UEFI; that is why Linux is having trouble understanding where and how to boot since Windows was installed in Legacy mode.

As soon as I backup everything and re-install windows in UEFI mode, I am going to test the theory and post what happens. Granted I am sure there are more qualified Linux users out there than myself, but I will not give up researching and trying different things until I resolve this problem.
If I do get it working for this laptop model, I will be sure to write a tutorial on how to load both properly so others can avoid the frustration I am having. Thanks.
My Mobile Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
I5 750 @3.809 Ghz MSI P55-GD85 XFX 5850 @ 801/1150 38c idle 8 GB Corsair XMS3 1600 Mhz 
Hard DriveOptical DriveCoolingOS
Raid 0 2TB, 1.5TB Hitachi backup SONY DVD Ram + Lightscribe Hyper 212 Plus Windows 7 64bit / Zorin 
MonitorKeyboardPowerCase
LG FLATRON W2361V Saitek V.5 Cyborg Silverstone Element 750w PSU Cooler Master CM690 II Advanced 
MouseMouse PadAudioAudio
Logitech G700 NA Creative 2.1 Lenovo P950 Headset 
  hide details  
Reply
My Mobile Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
I5 750 @3.809 Ghz MSI P55-GD85 XFX 5850 @ 801/1150 38c idle 8 GB Corsair XMS3 1600 Mhz 
Hard DriveOptical DriveCoolingOS
Raid 0 2TB, 1.5TB Hitachi backup SONY DVD Ram + Lightscribe Hyper 212 Plus Windows 7 64bit / Zorin 
MonitorKeyboardPowerCase
LG FLATRON W2361V Saitek V.5 Cyborg Silverstone Element 750w PSU Cooler Master CM690 II Advanced 
MouseMouse PadAudioAudio
Logitech G700 NA Creative 2.1 Lenovo P950 Headset 
  hide details  
Reply
post #53 of 69
Thread Starter 
I tried to install Windows 7 in UEFI mode; but WIndows 7 would only install in Legacy mode. Now I am back to square 1 once again. I have no idea where to go next except possibly trying suse next. We will see where it goes next.
My Mobile Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
I5 750 @3.809 Ghz MSI P55-GD85 XFX 5850 @ 801/1150 38c idle 8 GB Corsair XMS3 1600 Mhz 
Hard DriveOptical DriveCoolingOS
Raid 0 2TB, 1.5TB Hitachi backup SONY DVD Ram + Lightscribe Hyper 212 Plus Windows 7 64bit / Zorin 
MonitorKeyboardPowerCase
LG FLATRON W2361V Saitek V.5 Cyborg Silverstone Element 750w PSU Cooler Master CM690 II Advanced 
MouseMouse PadAudioAudio
Logitech G700 NA Creative 2.1 Lenovo P950 Headset 
  hide details  
Reply
My Mobile Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
I5 750 @3.809 Ghz MSI P55-GD85 XFX 5850 @ 801/1150 38c idle 8 GB Corsair XMS3 1600 Mhz 
Hard DriveOptical DriveCoolingOS
Raid 0 2TB, 1.5TB Hitachi backup SONY DVD Ram + Lightscribe Hyper 212 Plus Windows 7 64bit / Zorin 
MonitorKeyboardPowerCase
LG FLATRON W2361V Saitek V.5 Cyborg Silverstone Element 750w PSU Cooler Master CM690 II Advanced 
MouseMouse PadAudioAudio
Logitech G700 NA Creative 2.1 Lenovo P950 Headset 
  hide details  
Reply
post #54 of 69
Win 7 does not have secure boot. So I'm guessing this is verificatin that your UEFI boot mode defaults to secure boot. That is the root of your linux woes, if you cannot boot from legacy on a CD/USB you are forced to use secure boot enabled distros. I know Fedora, openSUSE, and Ubuntu all have secure boot/shim support with Grub2. I don't know what other distros have and would assume lesser distros (including spins) probably don't have support.

Take that how you will, if you cannot boot install media in legacy that's your only option. Otherwise, like I said in another post, you have to boot without secure boot enabled. If you can do that with win7, you can do it with a linux distro.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #55 of 69
Thread Starter 
I continue to be unable to load a Linux OS native or alongside windows on this Sager 9150. I will just have to resolve to running linux in VMware and keep at it until I find a resolution.
My Mobile Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
I5 750 @3.809 Ghz MSI P55-GD85 XFX 5850 @ 801/1150 38c idle 8 GB Corsair XMS3 1600 Mhz 
Hard DriveOptical DriveCoolingOS
Raid 0 2TB, 1.5TB Hitachi backup SONY DVD Ram + Lightscribe Hyper 212 Plus Windows 7 64bit / Zorin 
MonitorKeyboardPowerCase
LG FLATRON W2361V Saitek V.5 Cyborg Silverstone Element 750w PSU Cooler Master CM690 II Advanced 
MouseMouse PadAudioAudio
Logitech G700 NA Creative 2.1 Lenovo P950 Headset 
  hide details  
Reply
My Mobile Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
I5 750 @3.809 Ghz MSI P55-GD85 XFX 5850 @ 801/1150 38c idle 8 GB Corsair XMS3 1600 Mhz 
Hard DriveOptical DriveCoolingOS
Raid 0 2TB, 1.5TB Hitachi backup SONY DVD Ram + Lightscribe Hyper 212 Plus Windows 7 64bit / Zorin 
MonitorKeyboardPowerCase
LG FLATRON W2361V Saitek V.5 Cyborg Silverstone Element 750w PSU Cooler Master CM690 II Advanced 
MouseMouse PadAudioAudio
Logitech G700 NA Creative 2.1 Lenovo P950 Headset 
  hide details  
Reply
post #56 of 69
Did you try running a raw VM partition, installing to that (which will install grub to the partition). Then try EasyBCD to chainload to grub. If you can boot the HDD legacy, that should work.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #57 of 69
Thread Starter 
I will give that a try mushroomboy. Thanks for the info.
My Mobile Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
I5 750 @3.809 Ghz MSI P55-GD85 XFX 5850 @ 801/1150 38c idle 8 GB Corsair XMS3 1600 Mhz 
Hard DriveOptical DriveCoolingOS
Raid 0 2TB, 1.5TB Hitachi backup SONY DVD Ram + Lightscribe Hyper 212 Plus Windows 7 64bit / Zorin 
MonitorKeyboardPowerCase
LG FLATRON W2361V Saitek V.5 Cyborg Silverstone Element 750w PSU Cooler Master CM690 II Advanced 
MouseMouse PadAudioAudio
Logitech G700 NA Creative 2.1 Lenovo P950 Headset 
  hide details  
Reply
My Mobile Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
I5 750 @3.809 Ghz MSI P55-GD85 XFX 5850 @ 801/1150 38c idle 8 GB Corsair XMS3 1600 Mhz 
Hard DriveOptical DriveCoolingOS
Raid 0 2TB, 1.5TB Hitachi backup SONY DVD Ram + Lightscribe Hyper 212 Plus Windows 7 64bit / Zorin 
MonitorKeyboardPowerCase
LG FLATRON W2361V Saitek V.5 Cyborg Silverstone Element 750w PSU Cooler Master CM690 II Advanced 
MouseMouse PadAudioAudio
Logitech G700 NA Creative 2.1 Lenovo P950 Headset 
  hide details  
Reply
post #58 of 69
Well it's a last ditch effort, from what I can gather. If you can't get it to boot/install via cd/usb than I don't know what else to do outside of installing linux on another PC and moving the HDD back. =( Which is just about as much effort. Seems weird that it won't boot linux from any medium.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #59 of 69
Thread Starter 
I found a way to run Linux on the Sager 9150 but it still does not make any sense. I installed Linux Mint not onto my internal drives but on a usb stick. I can boot and run Mint off the USB stick with no issues whatsoever. I still cannot understand why it will not run when installed onto one of my internal drives. This makes no sense because if it installs onto a USB and then boots off the USB and then operates fine; why will it not run off the hard drive or SSD. Makes no sense.
My Mobile Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
I5 750 @3.809 Ghz MSI P55-GD85 XFX 5850 @ 801/1150 38c idle 8 GB Corsair XMS3 1600 Mhz 
Hard DriveOptical DriveCoolingOS
Raid 0 2TB, 1.5TB Hitachi backup SONY DVD Ram + Lightscribe Hyper 212 Plus Windows 7 64bit / Zorin 
MonitorKeyboardPowerCase
LG FLATRON W2361V Saitek V.5 Cyborg Silverstone Element 750w PSU Cooler Master CM690 II Advanced 
MouseMouse PadAudioAudio
Logitech G700 NA Creative 2.1 Lenovo P950 Headset 
  hide details  
Reply
My Mobile Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
I5 750 @3.809 Ghz MSI P55-GD85 XFX 5850 @ 801/1150 38c idle 8 GB Corsair XMS3 1600 Mhz 
Hard DriveOptical DriveCoolingOS
Raid 0 2TB, 1.5TB Hitachi backup SONY DVD Ram + Lightscribe Hyper 212 Plus Windows 7 64bit / Zorin 
MonitorKeyboardPowerCase
LG FLATRON W2361V Saitek V.5 Cyborg Silverstone Element 750w PSU Cooler Master CM690 II Advanced 
MouseMouse PadAudioAudio
Logitech G700 NA Creative 2.1 Lenovo P950 Headset 
  hide details  
Reply
post #60 of 69
I'm going to go out on a limb and say the controller that runs your internal disks is different to the one that runs the usb drive?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › I cannot load any Linux OS onto Sager 9150