Overclock.net › Forums › Cooling › Water Cooling › Aquaero 5, No output on fan channels
New Posts  All Forums:Forum Nav:

Aquaero 5, No output on fan channels - Page 2

post #11 of 15
Thread Starter 
Thanks Shoggy for your reply, but I have already thrown the unit in the bin...During my troubleshooting I took apart my case and while viewing the unit from a angle which I didn't see before, I saw that one of the fittings on the block must have come loose and leaked, I removed the block and it was not a pretty sight...

So this time the blame is on me for not doublechecking the fittings one last time...
post #12 of 15
Shoggy, I've been wondering, since you folks know that these units are going to be used in liquid cooled computers primarily why dont you fully pot the boards? If the electronics were sealed there wouldn't be an issue with a little leakage and I know from experience there is always a little leakage.

Any reason for not potting the boards?
post #13 of 15
Only generates unnecessary additional costs for a scenario that should not happen at all. If you think this way than all other parts in your PC must be sealed too.
post #14 of 15
Actually, none of the other parts of my computer are sold specifically to be used with liquid cooling except the devices I buy from you. It seems to me that if you know your device is going to be used in an environment that has the potential to expose it to liquid it's probably a good investment on my side To pay a little bit more to make sure your device will survive that inevitable encounter. I can't ask that of the other manufacturers that make computer parts not specifically designed to be used with liquid cooling, but I do feel justified in asking that of you!

I'd be curious to hear other people thought about this as well.
post #15 of 15
I think it would drive up the cost for a feature very few people would want or use.
Dark Vader
(6 items)
 
  
CoolingCoolingCoolingCooling
39 X AP-45 2150 rpm Gentle Typhoon fans Lamptron CW611 FrozenQ Dual Bay Reservoir 2x XT45 480. 1x UT60 480 ~ 1x UT60 360 ~ 1x UT... 
OSCase
Linux Ubuntu CaseLabs STH10 
  hide details  
Reply
Dark Vader
(6 items)
 
  
CoolingCoolingCoolingCooling
39 X AP-45 2150 rpm Gentle Typhoon fans Lamptron CW611 FrozenQ Dual Bay Reservoir 2x XT45 480. 1x UT60 480 ~ 1x UT60 360 ~ 1x UT... 
OSCase
Linux Ubuntu CaseLabs STH10 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › Aquaero 5, No output on fan channels