Overclock.net › Forums › Graphics Cards › NVIDIA › Poor performance in BF3
New Posts  All Forums:Forum Nav:

Poor performance in BF3

post #1 of 9
Thread Starter 
Recently I've been dropping down to 40 - 50fps in BF3 when I used to always get 80 - 120+ settings I'm running in BF3: http://i.imgur.com/kpT3wVy.jpg

My specs are

Intel I7 3820 @ Stock
Corsair H100i
Point of View GeForce GTX 680 EXO 2GB
ASUS P9X79 Motherboard
16GB (4x4) Kingston HyperX 1600mhz

I have all the latest drivers and my temperatures are fine, any idea why this is happening?
post #2 of 9
That's pretty odd, with Sli 580's I push 120+ fps with max settings. Try the latest WHQL drivers (NOT BETA), and use this guide to properly install them CLICK

Also make sure your nvidia control panel power management profile is set for maximum performance.
Edited by TheLawIX - 5/14/13 at 9:58am
post #3 of 9
Thread Starter 
Quote:
Originally Posted by TheLawIX View Post

That's pretty odd, with Sli 580's I push 120+ fps with max settings. Try the latest WHQL drivers (NOT BETA), and use this guide to properly install them CLICK

Also make sure your nvidia control panel power management profile is set for maximum performance.
Nope still drops down to 40 - 50fps :/
post #4 of 9
Lot of people with the same complaint recently, I am not sure of the cause but you are not alone and it seems nvidia driver related and a patch conflict with the game or something along those lines, also some people getting artifacts and distorted colours. I do not have the issue as using amd gpu but some friends have reported issues in the bf3 thread if you want to check there
post #5 of 9
Quote:
Originally Posted by Ghost12 View Post

Lot of people with the same complaint recently, I am not sure of the cause but you are not alone and it seems nvidia driver related and a patch conflict with the game or something along those lines, also some people getting artifacts and distorted colours. I do not have the issue as using amd gpu but some friends have reported issues in the bf3 thread if you want to check there

I've been getting artifacts with the latest WHQL and horrible performance with the latest beta drivers, betas are worse. Maybe the 680's are suffering worse. You should be getting 70+ fps with BF3 MAXED. Bump everything to max, what fps are you getting?
Edited by TheLawIX - 5/15/13 at 8:40pm
post #6 of 9
Thread Starter 
Quote:
Originally Posted by TheLawIX View Post

I've been getting artifacts with the latest WHQL and horrible performance with the latest beta drivers, betas are worse. Maybe the 680's are suffering worse. You should be getting 70+ fps with BF3 MAXED. Bump everything to max, what fps are you getting?

On the Ultra preset with drivers 314.07 (A friend of mine that also owns a 680 was getting good fps on them so I installed them, still didn't help) I get between 50 - 110fps. I've noticed it differs alot from which map but on maps like Gulf of Oman it sometimes drops down to 40fps, thus on Operation Firestorm I was getting above 70 at all times.
Edited by xJMHD - 5/16/13 at 4:41am
post #7 of 9
Reason: Gulf of Oman, a very poorly coded map just like nearly all B2K maps.

Fix: drop settings or move onto a different expansion.
PROGENITOR
(17 items)
 
Emulator Box
(17 items)
 
The contender
(15 items)
 
CPUMotherboardGraphicsGraphics
i7 4770k Gigabyte GA-Z87X-OC Gigabyte Windforce 780Ti 3072mb Gigabyte Windforce 780Ti 3072mb 
RAMHard DriveHard DriveOptical Drive
16GB Avexir Orange 2133mhz 1TB Crucial M550 2TB Seagate Barracuda 7200 LG BDR/DVDR 
CoolingCoolingOSMonitor
OCUK Fathom with HW Labs Black Ice 240 rad Mayhem's Gigabyte Orange 8.1 64 OEM Dell U2713HM 
KeyboardPowerCaseMouse
Ducky DK-9008 Shine III MX Brown Superflower Leadex 1000w Platinum Black NZXT Switch 810 Logitech G602 
Audio
SoundBlaster Z PCI-E 
CPUMotherboardGraphicsRAM
AMD FX 8320 Vishera ASUS M5A99X EVO R2.0 Sapphire R9 290 Tri-X 4096MB Avexir Blitz 2000mhz 8GB 
Hard DriveOptical DriveCoolingOS
1TB Hitachi Deskstar + 500GB Hitachi Deskstar 7... Samsung DVDR/CDR Noctua NH-U12P windows 7 Ultimate 64-bit 
MonitorPowerCase
AOC 22" LED 1920x1080 SuperFlower Golden Green HX 550W 80 Plus Gold Xigmatek Utguard 
  hide details  
Reply
PROGENITOR
(17 items)
 
Emulator Box
(17 items)
 
The contender
(15 items)
 
CPUMotherboardGraphicsGraphics
i7 4770k Gigabyte GA-Z87X-OC Gigabyte Windforce 780Ti 3072mb Gigabyte Windforce 780Ti 3072mb 
RAMHard DriveHard DriveOptical Drive
16GB Avexir Orange 2133mhz 1TB Crucial M550 2TB Seagate Barracuda 7200 LG BDR/DVDR 
CoolingCoolingOSMonitor
OCUK Fathom with HW Labs Black Ice 240 rad Mayhem's Gigabyte Orange 8.1 64 OEM Dell U2713HM 
KeyboardPowerCaseMouse
Ducky DK-9008 Shine III MX Brown Superflower Leadex 1000w Platinum Black NZXT Switch 810 Logitech G602 
Audio
SoundBlaster Z PCI-E 
CPUMotherboardGraphicsRAM
AMD FX 8320 Vishera ASUS M5A99X EVO R2.0 Sapphire R9 290 Tri-X 4096MB Avexir Blitz 2000mhz 8GB 
Hard DriveOptical DriveCoolingOS
1TB Hitachi Deskstar + 500GB Hitachi Deskstar 7... Samsung DVDR/CDR Noctua NH-U12P windows 7 Ultimate 64-bit 
MonitorPowerCase
AOC 22" LED 1920x1080 SuperFlower Golden Green HX 550W 80 Plus Gold Xigmatek Utguard 
  hide details  
Reply
post #8 of 9
Thread Starter 
Seems to be fixed after reinstalling, getting pretty much above 100fps on all Vanilla maps with the settings I originally posted. Thanks for the help
post #9 of 9
No problem. glad you got it working well.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › Poor performance in BF3