Overclock.net › Forums › Graphics Cards › NVIDIA › Upgraded GPU and still having major lag issues, any ideas?
New Posts  All Forums:Forum Nav:

Upgraded GPU and still having major lag issues, any ideas?

post #1 of 25
Thread Starter 
So, I'm working on my girlfriends computer and I'm trying to get it up to snuff to be able to play Tera:Rising, an MMO. She had an old Radeon HD 6570 in the pc and it was terrible, completely unusable in most situations. Today I just bought her a new GTX 650 TI(link to specific card I bought, http://www.microcenter.com/product/402514/ZT-61102-10M_NVIDIA_GeForce_GTX_650_Ti_2048MB_GDDR5_PCIe_30_x16_Video_Card ) . It's a fairly large upgrade and I figured it wouldn't have much if any problems running the game. Her computer has 8 Gigs of RAM and an AMD Phenom II 1055T Six-Core Processor, so neither of those things should be causing the issue. I installed all of the newest drivers and uninstalled all of the old AMD drivers. Anyone have any ideas why I'm having such issues, the game is still only pulling about 14-16 FPS even after optimization in Nvidia Control Panel and in game(aiming for mid level graphics). My personal rig is more than able to keep up with the game on maximum settings using a GTX 660 Ti, which, although better shouldn't be enough to cause the large gap in play quality.

Any suggestions?

Thanks
post #2 of 25
Perhaps you had a bad driver uninstall with the AMD drivers. Somewhere here there is an excellent tutorial on the best way to uninstall and install new drivers, if that helps.
Red Rover
(25 items)
 
 
CPUMotherboardGraphicsRAM
intel i5 2550K Asus Maximus V Gene XFX 6950 reference Avexir CORE series red LED 16 GB 
Hard DriveHard DriveOptical DriveOS
Mushkin Enhanced Chronos 120 GB SSD WD Blue 2.5" ASUS DVD-RW Win7 Ultimate 
MonitorMonitorKeyboardPower
Acer 23' LED LCD 5ms monitor Acer 23' LED LCD 5ms monitor Cooler Master Storm Trigger XFX 750w  
CaseMouseMouse PadAudio
NZXT Phantom Full Tower in White/Red Logitech G600 generic red/white/black mouse pad Sony 520w stereo 
OtherOtherOtherOther
Bitfenix single-sleeved cable extensions Red Swiftech MCR420-QP Swiftech MCR420-QP Swiftech Apogee Drive II 
OtherOtherOtherOther
Swiftech Maelsrtom EK FC6970 waterblock NZXT FS200 (x5) NZXT FX120 (x1) 
Other
XSPC Xinrulian 120mm (x8) 
  hide details  
Reply
Red Rover
(25 items)
 
 
CPUMotherboardGraphicsRAM
intel i5 2550K Asus Maximus V Gene XFX 6950 reference Avexir CORE series red LED 16 GB 
Hard DriveHard DriveOptical DriveOS
Mushkin Enhanced Chronos 120 GB SSD WD Blue 2.5" ASUS DVD-RW Win7 Ultimate 
MonitorMonitorKeyboardPower
Acer 23' LED LCD 5ms monitor Acer 23' LED LCD 5ms monitor Cooler Master Storm Trigger XFX 750w  
CaseMouseMouse PadAudio
NZXT Phantom Full Tower in White/Red Logitech G600 generic red/white/black mouse pad Sony 520w stereo 
OtherOtherOtherOther
Bitfenix single-sleeved cable extensions Red Swiftech MCR420-QP Swiftech MCR420-QP Swiftech Apogee Drive II 
OtherOtherOtherOther
Swiftech Maelsrtom EK FC6970 waterblock NZXT FS200 (x5) NZXT FX120 (x1) 
Other
XSPC Xinrulian 120mm (x8) 
  hide details  
Reply
post #3 of 25
Thread Starter 
That's always a possibility I suppose. Another thing that's worth noting is that her mobo only has a PCI Express x16 slot and the card is a PcIE 2.0 and I know they're backwards compatible but do you think the fact that the slot is older perhaps it's not able to run as fast? My laptop that's significantly older and is significantly less powerful than this computer can run the game more efficiently than this computer can, so I am completely baffled. Also, the pc was store bought, not home built so that may have a little play but the vast majority of the old unnecessary programs have been removed so I don't think it is what's causing these issues.
post #4 of 25
I gonna guess that there is still some of the AMD driver in the registry some where. I know just going into the control panel won't uninstall all of the driver. Had this problem going from a crappy running 660 to a 7870 not to long ago. ( with things still being left in the registry after uninstalling nvidia driver)
jeffro37
(14 items)
 
755 websurfer
(9 items)
 
 
CPUMotherboardGraphicsRAM
I5-2500k MSI Z77A-G45 EVGA 780 sc Kingston Hyper X Genises 1600mhz 
Hard DriveHard DriveOptical DriveCooling
Samsung 840  Seagate 750gb sata III Samsung 24x DVD-RW Corsair H100 
OSMonitorKeyboardPower
Windows 10 pro Samsung 26" LCD Logitec 520 (wireless) Corsair TX 750 
CaseMouse
Coolermaster HAF X Logitec laser 
CPUMotherboardGraphicsRAM
Intel c2d e7400 xFx 750i sli ext. Evga 660 sc Kingston ddr2 800 
Hard DriveCoolingOSPower
WD 250 gb  hyper 212+ Windows 7 64 ultimate/ Ubuntu 13.04 Ultra X3 600w / full modular 
Case
Coolermaster Storm Enforcer 
  hide details  
Reply
jeffro37
(14 items)
 
755 websurfer
(9 items)
 
 
CPUMotherboardGraphicsRAM
I5-2500k MSI Z77A-G45 EVGA 780 sc Kingston Hyper X Genises 1600mhz 
Hard DriveHard DriveOptical DriveCooling
Samsung 840  Seagate 750gb sata III Samsung 24x DVD-RW Corsair H100 
OSMonitorKeyboardPower
Windows 10 pro Samsung 26" LCD Logitec 520 (wireless) Corsair TX 750 
CaseMouse
Coolermaster HAF X Logitec laser 
CPUMotherboardGraphicsRAM
Intel c2d e7400 xFx 750i sli ext. Evga 660 sc Kingston ddr2 800 
Hard DriveCoolingOSPower
WD 250 gb  hyper 212+ Windows 7 64 ultimate/ Ubuntu 13.04 Ultra X3 600w / full modular 
Case
Coolermaster Storm Enforcer 
  hide details  
Reply
post #5 of 25
You do know that a program/games needs to be programmed to use the extra cores on your CPU, most MMO's tend to use only a 1-4 cores and usually no more. What does mater more is when games can't use all the available cores the clock speed of the CPU is what you need to be looking at. Your cpu is running at a low 2.8ghz stock, that is pretty low. Tera:Rising is probably pretty poorly optimized and most likely only uses one of you 6 cores. So in that regards a C2D at 2.8ghz would probably pay the game just as good as that 6 core phenom II. Try overclocking that CPU. NVM if your PC is OEM.


Though make sure you have wiped all the drivers out, not wiping out the old drivers when switching brands can really make things act funny. If you just pull the old card out without uninstalling the AMD drivers your doing it wrong.
Edited by DzillaXx - 5/14/13 at 7:42pm
Red Dragon
(19 items)
 
HTPC
(20 items)
 
HomeServer
(13 items)
 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K @4.8ghz Asrock p67 Extreme4 GTX1080 G.SKILL Ripjaws X Series 16GB 9-11-11-31 2133MHz 
Hard DriveHard DriveHard DriveHard Drive
3x 640 WD blacks Raid 0 Mushkin Enhanced Reactor 512GB SSD Sandisk 1TB SSD Samsung 470 Series 128GB SSD 
CoolingOSMonitorKeyboard
XSPC Raystorm Windows 10 64bit Microboard m340clz 100hz 3440x1440 Corsair K70 
PowerCaseMouseAudio
TX850 HAF922 Logitech G502 Creative Sound Blaster Z  
AudioAudioAudio
Elac B6 & Dayton Audio SUB-800 Yamaha HTR-5790 Audio Technica ATH-A700 headphones 
CPUMotherboardGraphicsRAM
Q9550 @ 4GHZ Gigabyte EP45 UD3P GTX470 4GB OCZ Reaper 1150mhz 
Hard DriveHard DriveOptical DriveCooling
Western Digital Blue 500gb OCZ Vertex 2 60GB LG Bluray Corsair H50 
OSKeyboardPowerCase
Windows 7 Home Premium  Logitech K400 Corsair CX500 nMEDIAPC 6000B 
AudioOtherOtherOther
Yamaha HTR-5063 PS3 80GB BC PS3 with 250GB hard drive. Polk Audio Monitor 60s Bi-AMP Front Polk Audio Monitor 30s Rear 
OtherOther
Polk Audio CS1 Center Polk Audio PSW10 
CPUMotherboardGraphicsRAM
Xeon Harpertown 3.6ghz Asus P5Q SE/R HD7770 4GB DDR2 800mhz Corsair 
Hard DriveHard DriveHard DriveHard Drive
5TB Toshiba 5TB Toshiba 5TB Toshiba 2TB Hitachi 
Hard DriveHard DriveHard DriveOS
2TB Seagate 2TB Western Digital 1TB Hitachi Windows Home Server 2011 
Power
Corsair CX500 
  hide details  
Reply
Red Dragon
(19 items)
 
HTPC
(20 items)
 
HomeServer
(13 items)
 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K @4.8ghz Asrock p67 Extreme4 GTX1080 G.SKILL Ripjaws X Series 16GB 9-11-11-31 2133MHz 
Hard DriveHard DriveHard DriveHard Drive
3x 640 WD blacks Raid 0 Mushkin Enhanced Reactor 512GB SSD Sandisk 1TB SSD Samsung 470 Series 128GB SSD 
CoolingOSMonitorKeyboard
XSPC Raystorm Windows 10 64bit Microboard m340clz 100hz 3440x1440 Corsair K70 
PowerCaseMouseAudio
TX850 HAF922 Logitech G502 Creative Sound Blaster Z  
AudioAudioAudio
Elac B6 & Dayton Audio SUB-800 Yamaha HTR-5790 Audio Technica ATH-A700 headphones 
CPUMotherboardGraphicsRAM
Q9550 @ 4GHZ Gigabyte EP45 UD3P GTX470 4GB OCZ Reaper 1150mhz 
Hard DriveHard DriveOptical DriveCooling
Western Digital Blue 500gb OCZ Vertex 2 60GB LG Bluray Corsair H50 
OSKeyboardPowerCase
Windows 7 Home Premium  Logitech K400 Corsair CX500 nMEDIAPC 6000B 
AudioOtherOtherOther
Yamaha HTR-5063 PS3 80GB BC PS3 with 250GB hard drive. Polk Audio Monitor 60s Bi-AMP Front Polk Audio Monitor 30s Rear 
OtherOther
Polk Audio CS1 Center Polk Audio PSW10 
CPUMotherboardGraphicsRAM
Xeon Harpertown 3.6ghz Asus P5Q SE/R HD7770 4GB DDR2 800mhz Corsair 
Hard DriveHard DriveHard DriveHard Drive
5TB Toshiba 5TB Toshiba 5TB Toshiba 2TB Hitachi 
Hard DriveHard DriveHard DriveOS
2TB Seagate 2TB Western Digital 1TB Hitachi Windows Home Server 2011 
Power
Corsair CX500 
  hide details  
Reply
post #6 of 25
Thread Starter 
In reference to removing old drivers I also ran CCleaner following uninstall to hopefully wipe the issues outta the registry. As far as OCing the CPU the Mobo in the PC is a POS (N-Alvorix-RS880-uATX), so I don't really want to push the CPU due to the fact that the Mobo is pretty weak.
post #7 of 25
Thread Starter 
So I went ahead and did some testing by switching out the cards between my rig and hers, my 660 ti in her rig and her 650 ti in mine. In mine, the 650 performed flawlessly, in hers the 660 was an improvement but there was still a fair bit of lag, enough so that I would consider it unplayable. All in all I've realized it's just time to fork over the cash and get her a new Mobo and CPU as those are the components that I'm sure are bottlenecking the new card. I plan to go with an i5 3570k and for her rig I'm looking at this mobo(Z77 Extreme4 LGA 1155 Z77 ATX Intel Motherboard ), anyone have any opinions on that mobo? Also, am I going to be needing a new case as I heard somewhere that the power switch for OEM cases have specific plugs that will more or less only connect to the PoS mobo that came with the pc at the time of purchase??
Any suggestions on a mobo to go with? Last question, will the new mobo fit into an OEM case if the power plug is actually compatible? "

Thanks!
post #8 of 25
before you spend the cash on basically a new system you should try reinstalling the OS just to see if that fixes the issue.
    
CPUMotherboardGraphicsRAM
Intel Core i7 4770k Gigabyte GA-Z87X-UD4H GeForce GTX 680  Crucial Ballistix Elite 
Hard DriveHard DriveOptical DriveCooling
WD30EZRX x2 Intel 520 SSD LG Bluray Burner WH12LS39 x2 Fully Liquid Cooled 
OSMonitorKeyboardPower
Win 7 Pro Qnix QX2710 Razer Blackwidow Ultimate 2013 BF4 Edition Corsair AX760 
CaseMouseMouse Pad
Switch 810 Gunmetal G700s Steelseries 4HD 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7 4770k Gigabyte GA-Z87X-UD4H GeForce GTX 680  Crucial Ballistix Elite 
Hard DriveHard DriveOptical DriveCooling
WD30EZRX x2 Intel 520 SSD LG Bluray Burner WH12LS39 x2 Fully Liquid Cooled 
OSMonitorKeyboardPower
Win 7 Pro Qnix QX2710 Razer Blackwidow Ultimate 2013 BF4 Edition Corsair AX760 
CaseMouseMouse Pad
Switch 810 Gunmetal G700s Steelseries 4HD 
  hide details  
Reply
post #9 of 25
Quote:
Originally Posted by Meleeking View Post

So I went ahead and did some testing by switching out the cards between my rig and hers, my 660 ti in her rig and her 650 ti in mine. In mine, the 650 performed flawlessly, in hers the 660 was an improvement but there was still a fair bit of lag, enough so that I would consider it unplayable. All in all I've realized it's just time to fork over the cash and get her a new Mobo and CPU as those are the components that I'm sure are bottlenecking the new card. I plan to go with an i5 3570k and for her rig I'm looking at this mobo(Z77 Extreme4 LGA 1155 Z77 ATX Intel Motherboard ), anyone have any opinions on that mobo? Also, am I going to be needing a new case as I heard somewhere that the power switch for OEM cases have specific plugs that will more or less only connect to the PoS mobo that came with the pc at the time of purchase??
Any suggestions on a mobo to go with? Last question, will the new mobo fit into an OEM case if the power plug is actually compatible? "

Thanks!

If your looking for a good Price/Performance look at the FX6350. Really I think that would be the best way to go, maybe even OC it to 4.4-4.8ghz. Just get a Decent CPU cooler with the money you save not getting the i5.

Also board should fit fine as long as your picking a board meant for the size of the case. if it only has 4 pci slots then any micro atx or smaller board should work. Powersupply should be fine, but if it still a OEM PS then it is probably crap.

http://www.newegg.com/Product/Product.aspx?Item=N82E16817151086

Something like that would be fine and safer to use.
Edited by DzillaXx - 5/14/13 at 10:34pm
Red Dragon
(19 items)
 
HTPC
(20 items)
 
HomeServer
(13 items)
 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K @4.8ghz Asrock p67 Extreme4 GTX1080 G.SKILL Ripjaws X Series 16GB 9-11-11-31 2133MHz 
Hard DriveHard DriveHard DriveHard Drive
3x 640 WD blacks Raid 0 Mushkin Enhanced Reactor 512GB SSD Sandisk 1TB SSD Samsung 470 Series 128GB SSD 
CoolingOSMonitorKeyboard
XSPC Raystorm Windows 10 64bit Microboard m340clz 100hz 3440x1440 Corsair K70 
PowerCaseMouseAudio
TX850 HAF922 Logitech G502 Creative Sound Blaster Z  
AudioAudioAudio
Elac B6 & Dayton Audio SUB-800 Yamaha HTR-5790 Audio Technica ATH-A700 headphones 
CPUMotherboardGraphicsRAM
Q9550 @ 4GHZ Gigabyte EP45 UD3P GTX470 4GB OCZ Reaper 1150mhz 
Hard DriveHard DriveOptical DriveCooling
Western Digital Blue 500gb OCZ Vertex 2 60GB LG Bluray Corsair H50 
OSKeyboardPowerCase
Windows 7 Home Premium  Logitech K400 Corsair CX500 nMEDIAPC 6000B 
AudioOtherOtherOther
Yamaha HTR-5063 PS3 80GB BC PS3 with 250GB hard drive. Polk Audio Monitor 60s Bi-AMP Front Polk Audio Monitor 30s Rear 
OtherOther
Polk Audio CS1 Center Polk Audio PSW10 
CPUMotherboardGraphicsRAM
Xeon Harpertown 3.6ghz Asus P5Q SE/R HD7770 4GB DDR2 800mhz Corsair 
Hard DriveHard DriveHard DriveHard Drive
5TB Toshiba 5TB Toshiba 5TB Toshiba 2TB Hitachi 
Hard DriveHard DriveHard DriveOS
2TB Seagate 2TB Western Digital 1TB Hitachi Windows Home Server 2011 
Power
Corsair CX500 
  hide details  
Reply
Red Dragon
(19 items)
 
HTPC
(20 items)
 
HomeServer
(13 items)
 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K @4.8ghz Asrock p67 Extreme4 GTX1080 G.SKILL Ripjaws X Series 16GB 9-11-11-31 2133MHz 
Hard DriveHard DriveHard DriveHard Drive
3x 640 WD blacks Raid 0 Mushkin Enhanced Reactor 512GB SSD Sandisk 1TB SSD Samsung 470 Series 128GB SSD 
CoolingOSMonitorKeyboard
XSPC Raystorm Windows 10 64bit Microboard m340clz 100hz 3440x1440 Corsair K70 
PowerCaseMouseAudio
TX850 HAF922 Logitech G502 Creative Sound Blaster Z  
AudioAudioAudio
Elac B6 & Dayton Audio SUB-800 Yamaha HTR-5790 Audio Technica ATH-A700 headphones 
CPUMotherboardGraphicsRAM
Q9550 @ 4GHZ Gigabyte EP45 UD3P GTX470 4GB OCZ Reaper 1150mhz 
Hard DriveHard DriveOptical DriveCooling
Western Digital Blue 500gb OCZ Vertex 2 60GB LG Bluray Corsair H50 
OSKeyboardPowerCase
Windows 7 Home Premium  Logitech K400 Corsair CX500 nMEDIAPC 6000B 
AudioOtherOtherOther
Yamaha HTR-5063 PS3 80GB BC PS3 with 250GB hard drive. Polk Audio Monitor 60s Bi-AMP Front Polk Audio Monitor 30s Rear 
OtherOther
Polk Audio CS1 Center Polk Audio PSW10 
CPUMotherboardGraphicsRAM
Xeon Harpertown 3.6ghz Asus P5Q SE/R HD7770 4GB DDR2 800mhz Corsair 
Hard DriveHard DriveHard DriveHard Drive
5TB Toshiba 5TB Toshiba 5TB Toshiba 2TB Hitachi 
Hard DriveHard DriveHard DriveOS
2TB Seagate 2TB Western Digital 1TB Hitachi Windows Home Server 2011 
Power
Corsair CX500 
  hide details  
Reply
post #10 of 25
Thread Starter 
Just bought a new Corsair CX 600M today, and that will be more than enough to run the new system. The reason I don't want to use an AMD processor is the fact that she's coming off of a 6 core and realistically 6 cores is more than most games can utilize, I would rather have the power condensed into 4 cores seeing as how gaming is going to be the primary function of the rig. As far as OC'ing I plan on Oc'ing the I5 to 4.4-4.5 GHz which is where mine sits(With a CM212Evo cooler.)

In response to the above post mentioning reinstalling the OS, although it may help to clear up some issues I really just want to upgrade her system and get it up to snuff, so to speak.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › Upgraded GPU and still having major lag issues, any ideas?