Overclock.net › Forums › Cooling › Water Cooling › Swiftech H220 Issue
New Posts  All Forums:Forum Nav:

Swiftech H220 Issue

post #1 of 4
Thread Starter 
So I picked up a Swiftech H220 this morning, came home, and installed it in my rig. This is my first liquid cooler, but I'm guessing something is not quite right. While it is keeping the temperatures down on my CPU, I can hear the coolant flowing constantly. It sounds like someone left the sink on in the other room. Does anyone know what might be causing this?
post #2 of 4
This is a good place to ask such a question.

That being said, it sounds like you may have air bubbles trapped in your line. They may work themselves out or you'll need to move your system around to get em out.
Errdegahr Ktonos
(22 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i5 3570k Asus Sabertooth Z77 EVGA GTX 670 4gb Superclocked EVGA GTX 670 4gb Superclocked 
RAMHard DriveHard DriveHard Drive
Patriot Viper 3 Black Mamba WD Caviar Black OCZ Vertex 3 OCZ Vertex 4 
Hard DriveOptical DriveCoolingCooling
OCZ Vertex 3 MAX IOPS asus bw-12b1st Swiftech H320 Silverstone FHP-141 
OSMonitorKeyboardPower
Windows 7 professional 64-bit Benq XL2420T Corsair K90 Seasonic 860 w Platinum 
CaseMouseMouse PadAudio
Corsair 800D  Logitech G400s Razer Vespula Creative Soundblaster Z 
AudioOther
Sennheiser HD 595 Leapmotion 
  hide details  
Reply
Errdegahr Ktonos
(22 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i5 3570k Asus Sabertooth Z77 EVGA GTX 670 4gb Superclocked EVGA GTX 670 4gb Superclocked 
RAMHard DriveHard DriveHard Drive
Patriot Viper 3 Black Mamba WD Caviar Black OCZ Vertex 3 OCZ Vertex 4 
Hard DriveOptical DriveCoolingCooling
OCZ Vertex 3 MAX IOPS asus bw-12b1st Swiftech H320 Silverstone FHP-141 
OSMonitorKeyboardPower
Windows 7 professional 64-bit Benq XL2420T Corsair K90 Seasonic 860 w Platinum 
CaseMouseMouse PadAudio
Corsair 800D  Logitech G400s Razer Vespula Creative Soundblaster Z 
AudioOther
Sennheiser HD 595 Leapmotion 
  hide details  
Reply
post #3 of 4
Thread Starter 
Quote:
Originally Posted by Ryld Baenre View Post

This is a good place to ask such a question.

That being said, it sounds like you may have air bubbles trapped in your line.


Is there an easy fix for this or, given that I have thirty days to return it to the store, should I just swap it for a different one?
post #4 of 4
Hi, there is a special topic for the H220 from Swiftech, were you can ask your questions. I assume that you place the rad above the pump? I think you have to fill the loop with extra coolant, because there is not enough in the loop right now.
BF4 Gaming
(13 items)
  
Reply
BF4 Gaming
(13 items)
  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › Swiftech H220 Issue