Overclock.net › Forums › Cooling › Water Cooling › Alphacool D5 does not seem to work
New Posts  All Forums:Forum Nav:

Alphacool D5 does not seem to work

post #1 of 6
Thread Starter 
Today after 2 months of acquiring my watercooling components I finally put it together. I had filled the bay res with water and turned on the PC and the pump did not come on. I doubled checked the connections and they pump (Alphacool D5) was connected to the molex connection firmly. Tried to start the PC again and the pump did not come on, no noise, no water flowing nothing. This was disappointing to say the least. I tried connecting to pump to a another molex cable and still nothing. I will be contacting FrozenCPU Monday to get some help but was wondering is there anything else I can try. It is a variable speed model and I had set it at 2. Pump looks to be seating firmly in the Res.

Here is the Bay res that I got:

http://www.frozencpu.com/products/13884/ex-res-300/XSPC_Dual_525_Bay_Clear_Reservoir_-_w_D5_Variant_Pump_Installed.html?tl=g30c97s152#blank
post #2 of 6
Don't try to fill a loop by turning on the whole PC man. That is a great way to destroy equipment.

You need to have either an external power source for the pump while filling or have everything but the pump unplugged from the power supply on your rig. Leaking is very common on first installation and water on powered components is bad news.

Its possibly an airlock in the pump, they make no noise even though they are turning if no water can get directly into the pump impeller.
Kusanagi
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K Asus Sabertooth Z77 EVGA GTX 780 SC Corsair Vengeance Pro CMY16GX3M2A2133C11 16GB 
Hard DriveCoolingCoolingCooling
Samsung 840 Pro 256GB X2 EK Supremacy Aqua Computer Aquaero 6 Pro Aqua Computer D5 USB 
CoolingCoolingCoolingCooling
Aquacomputer MPS 400 flow meter EK-CoolStream PE 360 EK-Coolstream PE 240 Noiseblocker Eloop B12-PS 
CoolingCoolingCoolingCooling
EK Vardar F2 EK-FC Titan Acetal & Nickel EK-RAM Monarch X4 Clean CSQ - Acetal+Nickel EK-D5 X-RES 140 CSQ 
OSMonitorMonitorPower
Win 8.1 Pro 64 bit Samsung S27A750d LG E2290V-SN Silverstone Strider Plus 850W ST85F-P 
Case
Corsair Obsidian 750D 
  hide details  
Reply
Kusanagi
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K Asus Sabertooth Z77 EVGA GTX 780 SC Corsair Vengeance Pro CMY16GX3M2A2133C11 16GB 
Hard DriveCoolingCoolingCooling
Samsung 840 Pro 256GB X2 EK Supremacy Aqua Computer Aquaero 6 Pro Aqua Computer D5 USB 
CoolingCoolingCoolingCooling
Aquacomputer MPS 400 flow meter EK-CoolStream PE 360 EK-Coolstream PE 240 Noiseblocker Eloop B12-PS 
CoolingCoolingCoolingCooling
EK Vardar F2 EK-FC Titan Acetal & Nickel EK-RAM Monarch X4 Clean CSQ - Acetal+Nickel EK-D5 X-RES 140 CSQ 
OSMonitorMonitorPower
Win 8.1 Pro 64 bit Samsung S27A750d LG E2290V-SN Silverstone Strider Plus 850W ST85F-P 
Case
Corsair Obsidian 750D 
  hide details  
Reply
post #3 of 6
Thread Starter 
Quote:
Originally Posted by Jakusonfire View Post

Don't try to fill a loop by turning on the whole PC man. That is a great way to destroy equipment.

You need to have either an external power source for the pump while filling or have everything but the pump unplugged from the power supply on your rig. Leaking is very common on first installation and water on powered components is bad news.

Its possibly an airlock in the pump, they make no noise even though they are turning if no water can get directly into the pump impeller.

I took apart the loop and to test have just the bay res pump attached to a radiator. I filled the res until the water is almost full and tried to connect the pump to the PSU. The pump still does not seem to be working.
post #4 of 6
Try taking the pump right out of the res so it is bare and try it. Turing it on for like a second won't hurt it and you will be able to definitely see if it turns.
Kusanagi
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K Asus Sabertooth Z77 EVGA GTX 780 SC Corsair Vengeance Pro CMY16GX3M2A2133C11 16GB 
Hard DriveCoolingCoolingCooling
Samsung 840 Pro 256GB X2 EK Supremacy Aqua Computer Aquaero 6 Pro Aqua Computer D5 USB 
CoolingCoolingCoolingCooling
Aquacomputer MPS 400 flow meter EK-CoolStream PE 360 EK-Coolstream PE 240 Noiseblocker Eloop B12-PS 
CoolingCoolingCoolingCooling
EK Vardar F2 EK-FC Titan Acetal & Nickel EK-RAM Monarch X4 Clean CSQ - Acetal+Nickel EK-D5 X-RES 140 CSQ 
OSMonitorMonitorPower
Win 8.1 Pro 64 bit Samsung S27A750d LG E2290V-SN Silverstone Strider Plus 850W ST85F-P 
Case
Corsair Obsidian 750D 
  hide details  
Reply
Kusanagi
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K Asus Sabertooth Z77 EVGA GTX 780 SC Corsair Vengeance Pro CMY16GX3M2A2133C11 16GB 
Hard DriveCoolingCoolingCooling
Samsung 840 Pro 256GB X2 EK Supremacy Aqua Computer Aquaero 6 Pro Aqua Computer D5 USB 
CoolingCoolingCoolingCooling
Aquacomputer MPS 400 flow meter EK-CoolStream PE 360 EK-Coolstream PE 240 Noiseblocker Eloop B12-PS 
CoolingCoolingCoolingCooling
EK Vardar F2 EK-FC Titan Acetal & Nickel EK-RAM Monarch X4 Clean CSQ - Acetal+Nickel EK-D5 X-RES 140 CSQ 
OSMonitorMonitorPower
Win 8.1 Pro 64 bit Samsung S27A750d LG E2290V-SN Silverstone Strider Plus 850W ST85F-P 
Case
Corsair Obsidian 750D 
  hide details  
Reply
post #5 of 6
Thread Starter 
Quote:
Originally Posted by Jakusonfire View Post

Try taking the pump right out of the res so it is bare and try it. Turing it on for like a second won't hurt it and you will be able to definitely see if it turns.

Did that, nothing looks to be moving nor any sounds emitted from the pump.
post #6 of 6
Well that's it then. If it doesn't turn when it is getting power then there is nothing you can really do.

Assuming you have tested that there is definitely power coming from the PSU on the molex plugs. Send that sucker back.
Kusanagi
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K Asus Sabertooth Z77 EVGA GTX 780 SC Corsair Vengeance Pro CMY16GX3M2A2133C11 16GB 
Hard DriveCoolingCoolingCooling
Samsung 840 Pro 256GB X2 EK Supremacy Aqua Computer Aquaero 6 Pro Aqua Computer D5 USB 
CoolingCoolingCoolingCooling
Aquacomputer MPS 400 flow meter EK-CoolStream PE 360 EK-Coolstream PE 240 Noiseblocker Eloop B12-PS 
CoolingCoolingCoolingCooling
EK Vardar F2 EK-FC Titan Acetal & Nickel EK-RAM Monarch X4 Clean CSQ - Acetal+Nickel EK-D5 X-RES 140 CSQ 
OSMonitorMonitorPower
Win 8.1 Pro 64 bit Samsung S27A750d LG E2290V-SN Silverstone Strider Plus 850W ST85F-P 
Case
Corsair Obsidian 750D 
  hide details  
Reply
Kusanagi
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K Asus Sabertooth Z77 EVGA GTX 780 SC Corsair Vengeance Pro CMY16GX3M2A2133C11 16GB 
Hard DriveCoolingCoolingCooling
Samsung 840 Pro 256GB X2 EK Supremacy Aqua Computer Aquaero 6 Pro Aqua Computer D5 USB 
CoolingCoolingCoolingCooling
Aquacomputer MPS 400 flow meter EK-CoolStream PE 360 EK-Coolstream PE 240 Noiseblocker Eloop B12-PS 
CoolingCoolingCoolingCooling
EK Vardar F2 EK-FC Titan Acetal & Nickel EK-RAM Monarch X4 Clean CSQ - Acetal+Nickel EK-D5 X-RES 140 CSQ 
OSMonitorMonitorPower
Win 8.1 Pro 64 bit Samsung S27A750d LG E2290V-SN Silverstone Strider Plus 850W ST85F-P 
Case
Corsair Obsidian 750D 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › Alphacool D5 does not seem to work