Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Trouble with Samsung 840 512Gb after firmware update
New Posts  All Forums:Forum Nav:

Trouble with Samsung 840 512Gb after firmware update

post #1 of 4
Thread Starter 
Hi, this is my first post, though I have lurked here for a while. I have a Samsung 840 512Gb ssd, (not pro) which I have been running in my Acer 4720G notebook. I upgraded the firmware with Magician to the latest version (DXT08B0Q) a few days ago, and now I am randomly getting bsod's on cold boot and have to F8 after bios and use "last known good configuration" to boot up. For the bsods, it reports 0x0000007b which is a boot device failure error. When it does boot, I get an "installing device driver sofware" message, followed by a "device driver installation failed" message. If I look at device manager, windows reports the drive as working ok, but it shows that no drivers are installed, and if I select "update driver", it tries and then fails to install one.

With Magician, it appears that there is no way to revert to a previous firmware version. Even creating a boot usb or cd rom does not give this option. Has anyone else had this problem, and any ideas what to do? Or, maybe a hint on how to get rid of this error message, since the drive performance seems to be same as normal anyway.

My system specs: Acer 4720G notebook running Win 7 Pro 64 with all latest updates, T9300 2.5Ghz CPU, nVidia 9600M GT 512k DDR3 video, 3Gb ram, and Samsung 840 series SSD 512 Gb.

BTW, I have given this drive a pretty good workout, as I do a lot of video restoration work. To date, the drive has had over 10.5 Tb written to it in just 2 1/2 months and almost 1000hrs on the clock, and has worked perfectly up till now.

Thanks in advance for your advice,

Regards, Rob
post #2 of 4
Check this thread: http://www.overclock.net/t/1391274/samsung-840-and-pro-firmware-dxt08b0q-dxm05b0q/10

I'm also having problems with latest firmware for 840 Pro. Basically my SSD is frozen (bricked). Unusable.
There's no way to perform a firmware downgrade. I hope we can find a way to fix this before Samsung does.. which will take them some time until next firmware release I guess.
post #3 of 4
i also have an 840 500gb in my sager laptop and the f/w updated .
i did have some issues with irst 12.6 so i reverted back to the windows default.
also, there was an instance when the drive was not detected by windows. the first thing i did was reseat the drive, it took two or three tries.
try some of these, and hopefully they resolve your issues.
post #4 of 4
i also have an 840 500gb in my sager laptop and the f/w updated .
i did have some issues with irst 12.6 so i reverted back to the windows default.
also, there was an instance when the drive was not detected by windows. the first thing i did was reseat the drive, it took two or three tries.
try some of these, and hopefully they resolve your issues.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: SSD
Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Trouble with Samsung 840 512Gb after firmware update