Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Setting up a wifi network, aironet 1140 help.
New Posts  All Forums:Forum Nav:

Setting up a wifi network, aironet 1140 help.

post #1 of 5
Thread Starter 
I am having this issue. I currently have a wifi network which is not that great. It covers about half my house but I don't want to have to keep adding extenders. I currently have the following setup.
Lynksys E1200 in the back most room, where the internet connection comes in. Then about 30 feet away the signal strength is only about35% so I have a range extender there. That gives me coverage for about another 20 feet. Basically my walls are concrete with cinder blocks and rebar. So I know that has to be an issue. I can't even get a wifi signal if I clsoe the bathroom door and that is only about 15 feet from either wifi ap. So this was my idea. I found a Cisco Aironet 1140 in my moving boxes. I think it works, I never really knew what it was till I started investigating. And I found out its supposedly good for 50 meters of indoor functionality. Well, If I can get just a 20meter radius out of it I am happy. This I can just run an Ethernet cable to a central room and have that cover the entire home? My living space is about 55 feet x 25 feet. I do have a room that is basically smack in the middle. Think this will work? Also how hard is setting up an aironet 1140?
Valery
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k GA-P67A-UD4-B3 Radeon 7970 Reference G. Skill Sniper 
Hard DriveOptical DriveOSMonitor
Corsair NOVA SSD 64gb + 500gb Storage + 1TB Storag HP DVD burner Windows 7 64bit 37" 1080p60hz 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Rosewill Lightning 1000W Single Rail LianLi PC-K58 Razer Spectre 
Mouse Pad
Razer Goliathus Speed 
  hide details  
Reply
Valery
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k GA-P67A-UD4-B3 Radeon 7970 Reference G. Skill Sniper 
Hard DriveOptical DriveOSMonitor
Corsair NOVA SSD 64gb + 500gb Storage + 1TB Storag HP DVD burner Windows 7 64bit 37" 1080p60hz 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Rosewill Lightning 1000W Single Rail LianLi PC-K58 Razer Spectre 
Mouse Pad
Razer Goliathus Speed 
  hide details  
Reply
post #2 of 5
You just "found" an enterprise-grade WAP in your moving boxes? What?
    
CPUMotherboardGraphicsRAM
2x intel Xeon E5-2650 Supermicro MBD-X9DR3-F-O Onboard awesomeness 8 x 8GB Kingston DDR3 1333 ECC 
Hard DriveCoolingOSMonitor
4x WD Green 2TB in RAID 10 2x Coolermaster Hyper 212 EVOs Windows Server 2012 Datacenter 3x Dell Ultrasharp U2410s 
PowerCase
Corsair AX1200 Case Labs TX10-D 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
2x intel Xeon E5-2650 Supermicro MBD-X9DR3-F-O Onboard awesomeness 8 x 8GB Kingston DDR3 1333 ECC 
Hard DriveCoolingOSMonitor
4x WD Green 2TB in RAID 10 2x Coolermaster Hyper 212 EVOs Windows Server 2012 Datacenter 3x Dell Ultrasharp U2410s 
PowerCase
Corsair AX1200 Case Labs TX10-D 
  hide details  
Reply
post #3 of 5
^ that, lol.

It's 'okay' to set up a basic environment, but you have to know a bit about what components to configure (as well as have a console cable to set it up with).

I've included my lab AP's configuration (It's a 1231G) as an example. It doesn't segment out different VLANs per SSID, so you can use it easily in a flat or consumer grade network. You may want to turn up the power parameters for yours.

Also keep in mind you will need an autonomous IOS image for that AP. Most of them come by default with a 'lightweight' one that requires a wireless LAN controller to function properly..

Warning: Spoiler! (Click to show)
Code:
CCNAW-AP1.LAB#show run
Building configuration...

Current configuration : 2167 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CCNAW-AP1.LAB
!
logging buffered 32768 debugging
enable secret 5 xxxxx
!
ip subnet-zero
no ip domain lookup
ip domain name LAB
ip dhcp excluded-address 172.31.255.1 172.31.255.99
!
ip dhcp pool WLAN
   network 172.31.255.0 255.255.255.0
   default-router 10.0.0.1
   dns-server 8.8.8.8
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login local_authen local
aaa authorization console
aaa authorization exec local_author local
aaa authorization network groupauthor local
aaa session-id common
!
dot11 ssid CCNAW-LAB
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 xxxxx
!
!
!
username beers privilege 15 secret 5 xxxxxxx
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers aes-ccm tkip
 !
 ssid CCNAW-LAB
 !
 countermeasure tkip hold-time 30
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 power client 1
 power local cck 1
 power local ofdm 1
 channel 2412
 station-role root
 antenna receive right
 antenna transmit left
 antenna gain 0
 beacon period 1000
 beacon dtim-period 10
 dot11 extension power native
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
 hold-queue 160 in
!
interface BVI1
 ip address dhcp client-id FastEthernet0
 no ip route-cache
!
no ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
 authorization commands 15 beers
line vty 0 4
 authorization exec local_author
line vty 5 15
 authorization exec local_author
!
end

Edited by beers - 5/26/13 at 11:21pm
Waiting on X399
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II B57 @ X4 3.9 Gigabyte 790FXTA-UD5 Sapphire Radeon 290 8 GB G.Skill 2133 
Hard DriveCoolingOSKeyboard
250 GB 840 EVO Noctua NH-D14 Windows 10 Logitech K350 
PowerCaseMouseMouse Pad
Seasonic x750 Corsair 600T Logitech G100s Razer Goliathus Speed 
Audio
Plantronics Gamecom 788 
  hide details  
Reply
Waiting on X399
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II B57 @ X4 3.9 Gigabyte 790FXTA-UD5 Sapphire Radeon 290 8 GB G.Skill 2133 
Hard DriveCoolingOSKeyboard
250 GB 840 EVO Noctua NH-D14 Windows 10 Logitech K350 
PowerCaseMouseMouse Pad
Seasonic x750 Corsair 600T Logitech G100s Razer Goliathus Speed 
Audio
Plantronics Gamecom 788 
  hide details  
Reply
post #4 of 5
Thread Starter 
I had to buy another console cable so will report back when I get them
Valery
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k GA-P67A-UD4-B3 Radeon 7970 Reference G. Skill Sniper 
Hard DriveOptical DriveOSMonitor
Corsair NOVA SSD 64gb + 500gb Storage + 1TB Storag HP DVD burner Windows 7 64bit 37" 1080p60hz 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Rosewill Lightning 1000W Single Rail LianLi PC-K58 Razer Spectre 
Mouse Pad
Razer Goliathus Speed 
  hide details  
Reply
Valery
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k GA-P67A-UD4-B3 Radeon 7970 Reference G. Skill Sniper 
Hard DriveOptical DriveOSMonitor
Corsair NOVA SSD 64gb + 500gb Storage + 1TB Storag HP DVD burner Windows 7 64bit 37" 1080p60hz 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Rosewill Lightning 1000W Single Rail LianLi PC-K58 Razer Spectre 
Mouse Pad
Razer Goliathus Speed 
  hide details  
Reply
post #5 of 5
Thread Starter 
Got it working. Seems to be up. Definitely better than the router I was using. I just need to move it to a central point. I did have to flash it with autonomous ios but that went quick. Damn, how come only enterprise equipment works as expected? Maybe I can haul out my old 2500 series router and my catalyst switch and make something out of it.
Valery
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k GA-P67A-UD4-B3 Radeon 7970 Reference G. Skill Sniper 
Hard DriveOptical DriveOSMonitor
Corsair NOVA SSD 64gb + 500gb Storage + 1TB Storag HP DVD burner Windows 7 64bit 37" 1080p60hz 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Rosewill Lightning 1000W Single Rail LianLi PC-K58 Razer Spectre 
Mouse Pad
Razer Goliathus Speed 
  hide details  
Reply
Valery
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k GA-P67A-UD4-B3 Radeon 7970 Reference G. Skill Sniper 
Hard DriveOptical DriveOSMonitor
Corsair NOVA SSD 64gb + 500gb Storage + 1TB Storag HP DVD burner Windows 7 64bit 37" 1080p60hz 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Rosewill Lightning 1000W Single Rail LianLi PC-K58 Razer Spectre 
Mouse Pad
Razer Goliathus Speed 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security
Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Setting up a wifi network, aironet 1140 help.