Overclock.net › Forums › Intel › Intel Motherboards › help plz
New Posts  All Forums:Forum Nav:

help plz

post #1 of 3
Thread Starter 
i already posted about the mother board
but i got a new one
i installed it the same but its just turning off stright away, (eg powers on but going off again, fans r running ) will try a fresh insalment off whole thing)
think it could be either memory or the power anyone help?


board is sabertooh z77 the
chip is an intel icore i7 -377
grapics card is zotac geforce gtx 650
memory is corsair vengeance 8 gb
power is corsair cx600
i'm putting windows 7 on it or was
Edited by pendar - 5/31/13 at 11:34am
post #2 of 3
Check to see if all the ATX wires are pushed into the ATX connector from the PWR supply

And most important make sure none of the Socket pins are bent
Dreamland
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-6800K ASRock X99 Taichi ASUS GTX 1060 Turbo 6GB 4x4GB G.SKILL DDR4-2400 
Hard DriveOptical DriveCoolingOS
Samsung SM961 128GB Pioneer BDR-208DBK Noctua NH-U9S Windows 10 Enterprise N 
MonitorKeyboardPowerCase
LG 32MP58 Razer Blackwidow Ultimate 2016 EVGA SuperNOVA 750 G2 Antec Three Hundred 
MouseAudio
Logitech G Pro Creative Gigaworks T40 Series II 
  hide details  
Reply
Dreamland
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-6800K ASRock X99 Taichi ASUS GTX 1060 Turbo 6GB 4x4GB G.SKILL DDR4-2400 
Hard DriveOptical DriveCoolingOS
Samsung SM961 128GB Pioneer BDR-208DBK Noctua NH-U9S Windows 10 Enterprise N 
MonitorKeyboardPowerCase
LG 32MP58 Razer Blackwidow Ultimate 2016 EVGA SuperNOVA 750 G2 Antec Three Hundred 
MouseAudio
Logitech G Pro Creative Gigaworks T40 Series II 
  hide details  
Reply
post #3 of 3
Thread Starter 
yes its all pluged it its starting
bent??
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › help plz