Overclock.net › Forums › Components › Mice › Func MS-3 and Windows 8. Any success?
New Posts  All Forums:Forum Nav:

Func MS-3 and Windows 8. Any success?

post #1 of 4
Thread Starter 
Has anybody managed to successfuly get the MS-3 to work reliably on Win8? I got a dual-boot of Win7 and Win8 working yesterday and it seems it works fine with an absolutely clean install, but as soon as I put some of my drivers windows just stops detecting it. I disabled driver signature enforcement with no succes. I heard people managing to make it work with USB hubs.

If you're wondering why I don't just return it: For one, it is very comfortable and my wrist is no longer a tingling mess after 6 years of claw gripping and secondly, I've had it for more than 30 days and I don't want to sell it.
Edited by Geo2160 - 6/2/13 at 9:33am
post #2 of 4
I don't own this mouse but I had this problem with another mouse on a USB 3.0 port, I disabled the 3.0 functionality from BIOS (which I don't use anyway) and it started working normally.
post #3 of 4
Thread Starter 
It's not that, my motherboard is an old P35 MSI, and it doesn't work on ANY USB port, it's a driver issue from Windows.
post #4 of 4
Thread Starter 
I'm back with some news. Very weird news. It seems that the issue is caused by my Xonar DG's drivers. If I uninstall them, the mouse works fine. I even tried the UNi Xonar Drivers to no avail. As long as the drivers are installed, win8 refuses to recognize the MS-3
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › Func MS-3 and Windows 8. Any success?