Overclock.net › Forums › Video Games › PC Gaming › Steam related problems
New Posts  All Forums:Forum Nav:

Steam related problems

post #1 of 4
Thread Starter 
Hello,

Lately (for about 6 months now) I've been having problems with steam. I cannot connect to the steam servers, or even to any websites related with valve (forums.steampowered.com, www.teamfortress.com, ...).
So I've googled quite a lot, and the problem is solved for most people by going to the register, and changing the value of 'Offline' from '1' to '0'. But everytime I do this, and try to go online with steam, the value changes itself back to '1'.
I've also tried to delete my clientregistry.blob/all files except for the steam.exe and SteamApps, but nothing seemed to work.
But about 3 days ago everything suddenly worked, I could go online on steam, visit the websites,...
So I was quite happy.
Until now, I have already played some tf2 today, when I tried to start my steam this evening, it wouldn't connect (I can't visit their websites either).
Does anybody know a solution for this?

Thanks in advance
post #2 of 4
What country are you in and also do you get an error message?
Gaming Rig
(17 items)
 
  
CPUMotherboardGraphicsGraphics
i7 3770k @ 4.8GHz w/ 1.43v ASRock z77 Extreme 6 HD7970 @ 1270/1800 HD7970 @ 1270/1800 
RAMHard DriveHard DriveHard Drive
16GB G. Skill Ripjaws Z 9-11-12-28 OCZ Vertex 3 120GB Caviar Blue 1.0TB WD10EZEX DeskStar 1.5TB HDD 
Hard DriveCoolingCoolingOS
Caviar Blue 1.0TB WD10EZEX Raystorm Chrome XSPC CPU Block Swiftech Komodo 7970 Water Blocks Windows 8 64bit Ultimate 
MonitorPowerCaseAudio
Panasonic 54in VT 25 Corsair Fatl1ty 1000 watt PSU Corsair 800D Onkyo-NR-1008 
Audio
Energy CF70 towers, Energy CLR center, and Ener... 
  hide details  
Reply
Gaming Rig
(17 items)
 
  
CPUMotherboardGraphicsGraphics
i7 3770k @ 4.8GHz w/ 1.43v ASRock z77 Extreme 6 HD7970 @ 1270/1800 HD7970 @ 1270/1800 
RAMHard DriveHard DriveHard Drive
16GB G. Skill Ripjaws Z 9-11-12-28 OCZ Vertex 3 120GB Caviar Blue 1.0TB WD10EZEX DeskStar 1.5TB HDD 
Hard DriveCoolingCoolingOS
Caviar Blue 1.0TB WD10EZEX Raystorm Chrome XSPC CPU Block Swiftech Komodo 7970 Water Blocks Windows 8 64bit Ultimate 
MonitorPowerCaseAudio
Panasonic 54in VT 25 Corsair Fatl1ty 1000 watt PSU Corsair 800D Onkyo-NR-1008 
Audio
Energy CF70 towers, Energy CLR center, and Ener... 
  hide details  
Reply
post #3 of 4
similarly have you changed firewalls and does steam have an exemption in that firewall
post #4 of 4
Thread Starter 
Well, this is pretty weird. I've checked my firewall and gave steam in- and outbound permission. It works now biggrin.gif
Though I don't see why it did work yesterday afternoon, but not in the evening, I'm sure I didn't change any setting in the firewall.

Anyhow, thanks a lot smile.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Steam related problems