Overclock.net › Forums › Intel › Intel - General › Processor Driver Deleted - Can't Find it Again
New Posts  All Forums:Forum Nav:

Processor Driver Deleted - Can't Find it Again

post #1 of 9
Thread Starter 
So In the device Manager, when troubleshooting an issue (that I have since solved), I deleted my driver that's under "processors" (right click - properties/driver/uninstall).

I've fixed my original unrelated issue, but now I'm having issues with slow performance and frames dropping in a couple high-end 3d apps (PFTrack, Maya, Nuke).

I went to intel's website and did the Intel Driver Update Utility, but it says that everything is up to date. However, in my device manager I can go to my processor and see that it says the driver for my i5 2500k 3.3Ghz CPU (quad core) is listed as:

Driver date: 6/21/2006

Driver version: 6.1.7600.16385

..and I'm assuming that this is out of date.

MY QUESTION: What driver am I missing to update this?



WHAT I HAVE TRIED:



I've done the Intel Driver Update Utility here:
https://downloadcenter.intel.com/default.aspx?iid=subhd...
and it reads only about the "chipset driver" (and graphics/audio/wifi...) which is version:

chipset: 9.4.0.1017 (Which apparently isn't the same thing as the driver I uninstalled listed above)

I also used the "Find by category" here:
https://downloadcenter.intel.com/Default.aspx?lang=eng
entering in the appropriate info:

windows 7 ultimate, 64-bit version

...and I get driver results for one driver:

Intel® HD Graphics for Intel® Pentium® and Celeron® Processors with Intel® HD Graphics
Date: 3/7/2013
version 2.0

...with no download link, only giving me a "URL location" that sends me back to the Intel Driver Update Utility. So I'm not even sure If I have that or not, but I have a Radeon HD 6850 graphics card with the driver up to date on it, so do I really need this anyways?

I also used the "Update driver" option in the Device Manager, and it also says that it is up to date...

I've been trying to fix this for 3 days straight now, and I've just hit a wall and would love somebody to give me a little aid. Thanks so much!
post #2 of 9
CPU Drivers are normally installed automatically when you install Windows as far as I know... I think reinstalling Windows may be your only option unless someone else here as a solution.
post #3 of 9
i got 2500k says same version driver as you posted i dont think you can udate this
post #4 of 9
You can try clicking update driver software>browse my computer>Let me pick from a list, then select Intel. You'll have to restart for it to take effect.
Big Daddy
(18 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5 3570K @ 4.5 GHz Gigabyte Z77X-UD3H EVGA 980 Ti Classified G Skill ripjaws x 16 GB 1866 
Hard DriveHard DriveCoolingOS
Seagate Barracuda 1 TB 7200 RPM Crucial MX 100 Corsair H80i GT Windows 7 Professional 64-bit 
MonitorMonitorKeyboardPower
Asus ROG Swift PG279Q Dell P170S KBP V80 TKL Seasonic X-750 
CaseMouseMouse PadAudio
Fractal Design Define R4 Titanium Grey Logitech G502 Razer Goliathus Speed M Creative Sound Blaster X-Fi Titanium 
AudioOther
AKG K7XX NZXT Mesh 5 Channel Fan Cantroller 
CPUGraphicsHard DriveCooling
Intel Core i7 2620M AMD Radeon HD 6470M Hitachi 320 GB 7200 rpm SED Stock, AC MX-4 
OSMonitorMouseMouse Pad
Windows 7 Professional 64 1600x900 Logitech G700 Razer Goliathus 
Audio
Onboard 
  hide details  
Reply
Big Daddy
(18 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5 3570K @ 4.5 GHz Gigabyte Z77X-UD3H EVGA 980 Ti Classified G Skill ripjaws x 16 GB 1866 
Hard DriveHard DriveCoolingOS
Seagate Barracuda 1 TB 7200 RPM Crucial MX 100 Corsair H80i GT Windows 7 Professional 64-bit 
MonitorMonitorKeyboardPower
Asus ROG Swift PG279Q Dell P170S KBP V80 TKL Seasonic X-750 
CaseMouseMouse PadAudio
Fractal Design Define R4 Titanium Grey Logitech G502 Razer Goliathus Speed M Creative Sound Blaster X-Fi Titanium 
AudioOther
AKG K7XX NZXT Mesh 5 Channel Fan Cantroller 
CPUGraphicsHard DriveCooling
Intel Core i7 2620M AMD Radeon HD 6470M Hitachi 320 GB 7200 rpm SED Stock, AC MX-4 
OSMonitorMouseMouse Pad
Windows 7 Professional 64 1600x900 Logitech G700 Razer Goliathus 
Audio
Onboard 
  hide details  
Reply
post #5 of 9
Thread Starter 
Thanks for the speedy help! So, it's up to date... hmmm I guess that that isn't the issue.

@MME: I tried that, doesn't seem to help

What about the Intel HD graphics driver:

"Intel® HD Graphics for Intel® Pentium® and Celeron® Processors with Intel® HD Graphics
Date: 3/7/2013
version 2.0

Do I need this if I have my Radeon HD 6850 driver?
Edited by threedsnack - 6/3/13 at 6:18pm
post #6 of 9
Quote:
Originally Posted by threedsnack View Post

Thanks for the speedy help! So, it's up to date... hmmm I guess that that isn't the issue.

What about the Intel HD graphics driver:

"Intel® HD Graphics for Intel® Pentium® and Celeron® Processors with Intel® HD Graphics
Date: 3/7/2013
version 2.0

Do I need this if I have my Radeon HD 6850 driver?

If the IGP is disabled in your BIOS you shouldn't need it.
Big Daddy
(18 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5 3570K @ 4.5 GHz Gigabyte Z77X-UD3H EVGA 980 Ti Classified G Skill ripjaws x 16 GB 1866 
Hard DriveHard DriveCoolingOS
Seagate Barracuda 1 TB 7200 RPM Crucial MX 100 Corsair H80i GT Windows 7 Professional 64-bit 
MonitorMonitorKeyboardPower
Asus ROG Swift PG279Q Dell P170S KBP V80 TKL Seasonic X-750 
CaseMouseMouse PadAudio
Fractal Design Define R4 Titanium Grey Logitech G502 Razer Goliathus Speed M Creative Sound Blaster X-Fi Titanium 
AudioOther
AKG K7XX NZXT Mesh 5 Channel Fan Cantroller 
CPUGraphicsHard DriveCooling
Intel Core i7 2620M AMD Radeon HD 6470M Hitachi 320 GB 7200 rpm SED Stock, AC MX-4 
OSMonitorMouseMouse Pad
Windows 7 Professional 64 1600x900 Logitech G700 Razer Goliathus 
Audio
Onboard 
  hide details  
Reply
Big Daddy
(18 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5 3570K @ 4.5 GHz Gigabyte Z77X-UD3H EVGA 980 Ti Classified G Skill ripjaws x 16 GB 1866 
Hard DriveHard DriveCoolingOS
Seagate Barracuda 1 TB 7200 RPM Crucial MX 100 Corsair H80i GT Windows 7 Professional 64-bit 
MonitorMonitorKeyboardPower
Asus ROG Swift PG279Q Dell P170S KBP V80 TKL Seasonic X-750 
CaseMouseMouse PadAudio
Fractal Design Define R4 Titanium Grey Logitech G502 Razer Goliathus Speed M Creative Sound Blaster X-Fi Titanium 
AudioOther
AKG K7XX NZXT Mesh 5 Channel Fan Cantroller 
CPUGraphicsHard DriveCooling
Intel Core i7 2620M AMD Radeon HD 6470M Hitachi 320 GB 7200 rpm SED Stock, AC MX-4 
OSMonitorMouseMouse Pad
Windows 7 Professional 64 1600x900 Logitech G700 Razer Goliathus 
Audio
Onboard 
  hide details  
Reply
post #7 of 9
Quote:
Originally Posted by threedsnack View Post

Thanks for the speedy help! So, it's up to date... hmmm I guess that that isn't the issue.

@MME: I tried that, doesn't seem to help

What about the Intel HD graphics driver:

"Intel® HD Graphics for Intel® Pentium® and Celeron® Processors with Intel® HD Graphics
Date: 3/7/2013
version 2.0

Do I need this if I have my Radeon HD 6850 driver?

You shouldn't unless you have iGPU enabled.
post #8 of 9
Thread Starter 
Ok, so I just noticed a little exclamation in my toolbar everyitime I open PFTrack saying that the color scheme has changed, and will automatically be changed back one it's closed, and I don't have the issues anymore in my other apps as long as PFtrack is closed. So I realise this is now likely in the domain of PFtrack, but is there a way to tell Windows 7 not to change the color scheme for this App upon opening? I just check the in-app settings, and there's nothing about disabling a change in color scheme. The color scheme change seems to be destroying my in-app abilites as well as Maya, Nuke's etc performance. Any ideas?
post #9 of 9
Thread Starter 
I Figured out the cause, but don't have a solution:

I have a projector and a monitor connected to my single graphics card from my desktop, and I use my projector to work off of, When I turn off the projector and use just my single monitor the issue is gone, and the color space doesn't change, all my apps work great.

So the issue is that Windows 7 is not able to handle dual screen setup for whatever reason when I open up my Apps, and "changes the color scheme to windows 7 basic" which for whatever reason destroys my performance, causes tearing etc.

Even stranger, to get my apps to work with dual screens (projector and monitor), I have to now open up the app with the second screen off, THEN turn on the second screen and drag over my work. Doing it in such a way doesn't cause Windows 7 to change color schemes, and I can work with my dual screen setup.

Any ideas as to why this is happening? Again, I did play with a couple of my drivers (the video card and the processor driver, which are apparently both up to date), so I don;t know if it's as easy as a driver install or something deeper that Microsoft doesn't seem to want to address:

http://www.sevenforums.com/performance-maintenance/201908-color-scheme-keeps-changing-windows-7-basic-random.html

Thanks guys!

EDIT: I reposted this on the Windows Forum seeing that it would be more fitting for them to answer. Thanks for the help here guys!

http://www.overclock.net/t/1397595/windows-7-changes-color-scheme-to-basic-with-dual-screens
Edited by threedsnack - 6/4/13 at 11:32am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel - General
Overclock.net › Forums › Intel › Intel - General › Processor Driver Deleted - Can't Find it Again