Overclock.net › Forums › Components › Other Peripherals › USB ports wont work on my new PC
New Posts  All Forums:Forum Nav:

USB ports wont work on my new PC

post #1 of 2
Thread Starter 
Hello There

Today I finished building my PC and i wanted to go on to check the BIOS but it will not let me because the Monitor is on power save mode and when i try to put a mouse and keyboard in, the PC wont recognise it.

Does this mean that My motherboard is damage?
post #2 of 2
    From your description, it sounds like the computer is failing to POST.  If the monitor is in power save mode, that means that your computer is not outputting any video signal.  Make sure that your monitor is plugged into the correct video port (if there are several, try each one).  Try a different video card.  Make sure that you've connected power to the video card if applicable.  Don't forget to plug the 12v power cable in for the CPU.  Remove the memory and all add-in cards (except for the video card) and try one memory stick at a time.  If after all of this, the power turns on and still nothing appears on the screen, the motherboard is most likely at fault.
My desktop PC
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Gigabyte P67A-D3-B3 NVIDIA GeForce 8400 GS  1x Corsair 8 GB 
Hard DriveHard DriveHard DriveOS
Kingston SV300S3 WesternDigital WD10EZEX Samsung HD154UI Windows 7 Ultimate SP1 x64 
MonitorMonitorKeyboardPower
Daewoo L947BK Gateway FPD1530 HTK-2001 Dynex DX-400WPS 
MouseAudio
Kensington K72400 Realtek ALC889 
  hide details  
Reply
My desktop PC
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Gigabyte P67A-D3-B3 NVIDIA GeForce 8400 GS  1x Corsair 8 GB 
Hard DriveHard DriveHard DriveOS
Kingston SV300S3 WesternDigital WD10EZEX Samsung HD154UI Windows 7 Ultimate SP1 x64 
MonitorMonitorKeyboardPower
Daewoo L947BK Gateway FPD1530 HTK-2001 Dynex DX-400WPS 
MouseAudio
Kensington K72400 Realtek ALC889 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Peripherals
Overclock.net › Forums › Components › Other Peripherals › USB ports wont work on my new PC