Overclock.net › Forums › Intel › Intel Motherboards › Asus Sabertooth Z77 USB 3.0 ports not working, please help.
New Posts  All Forums:Forum Nav:

Asus Sabertooth Z77 USB 3.0 ports not working, please help.

post #1 of 2
Thread Starter 
I have had this motherboard for just over 10 months now and the USB 3.0 ports have not worked since purchased. This has not bothered me since I had just 1 external HDD up until now. I have now been given 2 more USB 3.0 compatible HDDs (500 and 1000GB editions) and my motherboard isn't reading either of them when I plug them into the 3.0 ports. The HDDs are not defective since they work on the 2.0 ports and I have the newest drivers installed which I found here if anyone needs to correct me: http://support.asus.com/download.aspx?SLanguage=en&m=SABERTOOTH+Z77&os=30

This is actually a major issue for me now since I actually want to connect all 3 to the motherboard and I want to be able to use both of my 3.0 ports. Can somebody explain to me how to possibly fix this problem I've had for this long?

My specs are:
Windows 7 64-bit
i7-3770k @4ghz
16GB RAM
GTX 680
Z77 Sabertooth

Thank you very much for your help.
post #2 of 2
Did you try the 3.0 drivers from the disc? Sometimes older drivers do work better.
    
CPUMotherboardGraphicsRAM
Intel i-3770k Asus z77 Sabertooth EVGA GTX 780 Corsair Vengeance 
Hard DriveHard DriveCoolingOS
Samsung 840 pro WD Velociraptor Custom Water Loop Windows 7 64bit 
MonitorKeyboardOther
asus vs248 Steel Series  Heatkiller GPU-X3 Titan 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i-3770k Asus z77 Sabertooth EVGA GTX 780 Corsair Vengeance 
Hard DriveHard DriveCoolingOS
Samsung 840 pro WD Velociraptor Custom Water Loop Windows 7 64bit 
MonitorKeyboardOther
asus vs248 Steel Series  Heatkiller GPU-X3 Titan 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › Asus Sabertooth Z77 USB 3.0 ports not working, please help.